08:30:02 <anac1> #startmeeting Yardstick work meeting
08:30:02 <collabot`> Meeting started Mon Jan 18 08:30:02 2016 UTC.  The chair is anac1. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:30:02 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:30:02 <collabot`> The meeting name has been set to 'yardstick_work_meeting'
08:30:09 <anac1> #info Ana Cunha
08:30:32 <QiLiang> #info QiLiang
08:30:36 <kubi1> #info kubi
08:30:39 <jnon_> #info jnon
08:30:57 <anac1> #topic release scenarios
08:30:58 <MMcG> #info MMcG
08:31:19 <anac1> #link https://build.opnfv.org/ci/view/OPNFV%20Platform%20CI%20-%20Alternative%20View/
08:31:35 <anac1> #info page above shows the release scenarios
08:31:50 <anac1> #info scenarios will be frozen today
08:32:45 <anac1> common fault for yardstick on ODL scenario: SSH timeout - any ideas to move forward on the troubleshooting?
08:33:37 <kubi1> vping of functest is also failed
08:33:42 <anac1> #info SSH timeout is preventing Yardstick to run on ODL scenarios
08:33:49 <kubi1> in ODL scenario
08:33:57 <anac1> kubi1: yes, we have a common fault
08:34:04 <jnon_> yes
08:34:22 <jnon_> ssh to instances dont work
08:34:34 <anac1> jose_lausuch: ssh timeout on ODL - do you have any ideas how to fix this?
08:34:57 <jose_lausuch> anac1: hi
08:35:03 <jose_lausuch> anac1: where can I see the error?
08:35:46 <akiskourtis> #info akiskourtis
08:36:04 <anac1> jose_lausush: hi, check yardstick jobs on jenkins page, same fault for fuel, joid, compass
08:36:17 <anac1> same fault as your vping
08:36:33 <andrasb> #info andrasb
08:36:45 <jose_lausuch> mmm
08:36:49 <anac1> as jnon_ wrote: ssh to instances doesn't work on odl scenarios
08:36:51 <jose_lausuch> we dont ssh in vping
08:37:01 <anac1> ok
08:37:22 <anac1> jose_lausuch: can you help with this fault?
08:37:59 <jose_lausuch> anac1: I'll try :)
08:38:02 <anac1> #link https://etherpad.opnfv.org/p/yardstick_release_b_troubleshooting
08:38:15 <jose_lausuch> lf pod2 is offline...
08:38:20 <jose_lausuch> cannot troubleshoot there
08:38:25 <jose_lausuch> is ericsson pod2 working?
08:38:33 <jose_lausuch> havent  checked it yet
08:38:53 <anac1> please share info on the etherpad (link above)
08:39:17 <anac1> moving on ...
08:39:37 <anac1> #topic results dashboard
08:40:42 <anac1> #info the target dB has been moved to 130.211.154.108
08:40:50 <vincenzo_riccobe> 'morning
08:40:52 <anac1> just a few minutes ago ...
08:40:58 <vincenzo_riccobe> is that the one on the Montreal Testbed?
08:41:15 <anac1> vincenzo_roccobe: no, the mongo dB that was hosted in Orange POD
08:41:36 <vincenzo_riccobe> ok
08:41:51 <anac1> #info it has been agreed to use the same server also for influxdB and Grafana
08:42:11 <anac1> #info meaning we need to move to the new server, which is public
08:42:25 <akiskourtis> exit
08:42:41 <anac1> jnon_ and anac1 can add users, please send your public key
08:42:41 <QiLiang> does influxdb work now?
08:43:05 <anac1> jnon_: have you managed to start installation in the new server?
08:43:17 <anac1> QiLiang: you mean the one in Montreal lab ?
08:43:22 <jnon_> no i have not started installing yet
08:43:31 <anac1> jnon_: ok
08:43:47 <QiLiang> infulxdb run on oragne
08:44:00 <akiskourtis> should we send our keys to you Ana?
08:44:28 <anac1> akiskoutis: yes, I (and jnon_) can add users
08:44:45 <akiskourtis> ok
08:45:13 <anac1> QiLiang: in Orange POD was the MongodB, in Montreal Ericsson lab the influxdB, last I heard from you and Akis, the influxDB in Montreal lab was not working
08:45:48 <akiskourtis> yes until now that I checked it is not working, neither grafana nor influxdb
08:46:21 <anac1> akiskourtis: thanks for info
08:46:24 <jnon_> not it did not work last week
08:47:03 <anac1> i just got info that mongodB is moved to the new server, i'll add all info to troubleshooting etherpad
08:47:25 <anac1> it does not look like the test dashboard that LF is working will be ready
08:48:07 <anac1> i think we need to focus on the grafana so we can show our graphs - what is the general opinion?
08:48:44 <anac1> both influxdB and mongodB will be public
08:48:53 <QiLiang> so we need only push the test result to mogodb(for lf-pod2), other lab push the result to infuxdb
08:49:19 <QiLiang> we will use influxdb hosted on orange ?
08:49:42 <anac1> influxdb is not hosted on orange, the new server is on LF hardware
08:50:33 <QiLiang> ok
08:50:44 <anac1> mongodB, influxdB, grafana will all be on the new server, on LF hardware (also there is a prototype on elastic search + kibana there)
08:51:50 <anac1> it is late now, so i think we need to focus on one alternative, my question to you all is : focus on influxDB + grafana ?
08:52:01 <anac1> or on mongo db?
08:52:34 <anac1> we need to decide as a team and i'll discuss with the release team
08:53:22 <akiskourtis> from my side influx + grafana +1
08:53:33 <kubi1> influxDB + grafana, in personal opinion
08:53:37 <QiLiang> i think we can focus on influxdb+ grafana
08:53:49 <QiLiang> and just push some result to mongodb
08:53:52 <jnon_> influxdb + grafana
08:54:21 <vincenzo_riccobe> +1
08:54:33 <anac1> #agreed the team decides to focus on influxdB+grafana
08:54:50 <anac1> #action anac1 to communicate to the release team
08:55:13 <anac1> so, we need to get influxdB + grafana installed in the new server
08:55:21 <QiLiang> anac1: what's the public key mentioned above using for? to login to the influxdb/grafan or the lf pod?
08:55:48 <QiLiang> or the new server
08:56:07 <anac1> QiLiang: to login to the server on LF POD and do changes/installations as needed
08:56:41 <anac1> for influx, grafana and also possible to access the mongodB
08:56:46 <QiLiang> i'll send you my key, thx
08:56:52 <anac1> thanks
08:57:06 <vincenzo_riccobe> will that server have a public IP address?
08:57:38 <jnon_> yes 130.211.154.108
08:57:46 <anac1> vincenzo_riccobe: yes, we need to choose a port and update here: https://wiki.opnfv.org/opnfv_test_dashboard#test_results_server
08:57:57 <anac1> so the permissions will be set
08:58:50 <anac1> jnon_, akiskourtis; vincenzo_riccobe: can the three of you install during today, so QiLiang can start working on tuesday ?
08:59:18 <jnon_> i can start with influxdb
08:59:30 <anac1> jnon_: great, thanks
08:59:49 <akiskourtis> I can install grafana, as soon as I have access
08:59:56 <jnon_> i dont remember which version we should use
09:00:05 <anac1> akiskourtis: great, thanks
09:00:16 <akiskourtis> the latest, or 0.9.3
09:00:21 <jnon_> ok
09:00:44 <anac1> #action jnon_ install influxdB, akiskourtis install grafana
09:01:17 <anac1> QiLiang: we'll add info to troubleshooting etherpad, so you can check when you start tuesday morning if it works
09:01:30 <QiLiang> ok, thanks
09:02:17 <anac1> anything else on test results visualization?
09:03:18 <anac1> #topic documentation
09:04:26 <vincenzo_riccobe> I saw the documentation I uploaded last week has been merged, is there anything else needed on my side on documentation?
09:04:48 <anac1> #info test result template was discussed on test & performance meeting
09:05:08 <anac1> #info overal opinion is that the template looks good
09:05:50 <anac1> vincenzo_riccobe: you need to document the results, but for this we need to run on stable brach, 4 times successfully - we are not there yet
09:06:20 <vincenzo_riccobe> ok
09:06:24 <anac1> vincenzo_riccobe: the autodo didn't work?
09:06:29 <anac1> autodoc
09:06:44 <vincenzo_riccobe> I went for the manual way
09:07:04 <vincenzo_riccobe> it seems the easiest, it was just couple of methods, not so much
09:07:19 <anac1> i noticed, it gives all the info you need, right?
09:07:36 <vincenzo_riccobe> yes
09:08:01 <vincenzo_riccobe> I think so
09:08:10 <anac1> #info deadline for documentation is jan 26th
09:09:27 <anac1> anything else on documentation?
09:09:59 <anac1> #topic other
09:10:21 <anac1> questions, comments on other issues?
09:10:42 <vincenzo_riccobe> I would need to add TC 006, 007 020 and 021 on Jenkins
09:10:45 <kalyan> is there anything on troubleshooting we can do??
09:10:59 <vincenzo_riccobe> on the Montreal testbed
09:11:10 <vincenzo_riccobe> probably need to sync with Jorgen on that
09:11:41 <anac1> kalyan: we need to find out why ssh timeout when running on odl, check faults here: https://build.opnfv.org/ci/view/yardstick/
09:12:01 <jnon_> do we want a separate jenkins job for vTC or not ?
09:12:06 <anac1> vincenzo_riccobe: yes, check with jnon_
09:12:22 <anac1> jnon_: i think so
09:12:32 <vincenzo_riccobe> I think we do, do we want to have an off-line chat about it?
09:12:33 <kalyan> ok..i will check...
09:12:45 <jnon_> yes then maybe fatih should help a bit
09:12:57 <anac1> kalyan: this issue is the most urgent, help is appreciated
09:13:53 <kalyan> ok..i will try my best....
09:13:55 <anac1> #action vincenzo_riccobe, jnon_: discuss with fdegir and update the job for vTC
09:13:56 <fdegir> jnon_: can you please remind me what is needed?
09:14:32 <jnon_> fdegir: a job for vTC on LF-POD1
09:14:47 <fdegir> jnon_: LF POD1?
09:14:50 <anac1> kalyan: please add finding, questions here: https://etherpad.opnfv.org/p/yardstick_release_b_troubleshooting
09:15:01 <anac1> jnon_: not LF, Ericsson POD1
09:15:03 <jnon_> fdegir: no ERI POD1 :)
09:15:31 <eyoufet> Ana: Is someone working to fix Ericsson POD1 ...The nodes are now discovered but still no env is there
09:16:25 <anac1> eyoufet: the yardstick part still not working, do you have time to look into it?
09:17:02 <kalyan> anac1: ok sure
09:17:12 <anac1> kalyan: thanks
09:17:48 <anac1> anything else ?
09:18:13 <eyoufet> anac1: I would like to but since the environment is not there ...there isn't too much I can't help on
09:18:15 <anac1> kubi1: great work on ipv6, thanks !
09:18:43 <kubi1> :)
09:18:47 <anac1> eyoufet: ok, thanks - we'll try to fix it
09:19:02 <jnon_> yes good work kubi
09:19:16 <kubi1> thanks
09:19:20 <anac1> #info yardstick test case for ipv6 connected to ci, working on Hauwei SC POD
09:20:07 <anac1> as the relase approaches, should we have a short meeting wednesday, same time ?
09:20:11 <anac1> release
09:20:48 <kalyan> ok sure
09:20:49 <QiLiang> ok for me
09:20:55 <kubi1> ok
09:21:26 <jnon_> yes
09:21:33 <eyoufet> Anac1 when the env is up  I can set up Yardstick instance and test everything related to it
09:21:44 <anac1> #agreed additional meeting on wedesday 20th jan, UTC 8:30-9:00
09:21:59 <anac1> eyoufet: ok
09:22:08 <anac1> thanks everyone for today
09:22:13 <anac1> #endmeeting