08:29:44 <kubi> #startmeeting Yardstick work meeting
08:29:44 <collabot`> Meeting started Mon May 23 08:29:44 2016 UTC.  The chair is kubi. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:29:44 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:29:44 <collabot`> The meeting name has been set to 'yardstick_work_meeting'
08:29:56 <kubi> #topic call role
08:30:03 <Jing> #info Jing
08:30:04 <kubi> #info Kubi
08:30:28 <Mingjiang6> #info Mingjiang
08:30:46 <qiujuan> #info qiujuan
08:30:56 <MatthewLi> #info Jun Li
08:31:06 <Yaoguang_Wang> #info Yaoguang Wang
08:31:33 <kubi> #topic enhanced HA framework
08:31:45 <Kanglin> #info Kanglin
08:32:05 <kubi> #info qiujuan: JIRA task has been created for you
08:32:32 <qiliang27> #info QiLiang
08:33:10 <kubi> #topic Merge Conflict
08:33:10 <qiujuan> #info kubi: I got it, I will start working on it ASAP.
08:33:19 <kubi> qiujuan: great
08:33:23 <FedericoRessi> #info Federico Ressi
08:33:39 <Wendy_> #info dongwenjuan
08:34:02 <goutham> # info goutham
08:34:40 <kubi> :), welcome, all my friends
08:34:49 <MatthewLi> :)
08:35:44 <kubi> Mingjiang6:  do you have any plan to update this patch https://gerrit.opnfv.org/gerrit/#/c/14409/
08:35:56 <kubi> sorry, this is for Jing
08:36:24 <kubi> Mingjiang6: this is for you, https://gerrit.opnfv.org/gerrit/#/c/14191/
08:37:12 <Mingjiang6> kubi: will update later
08:37:18 <fdegir> kubi: https://gerrit.opnfv.org/gerrit/#/c/14455/
08:37:18 <kubi> Mingjiang6: great
08:37:29 <Jing> I will fix the conflict right after the meeting.
08:38:22 <kubi> fdegir: do you mean that patch could be merged now?
08:38:31 <fdegir> kubi: yes please
08:38:46 <kubi> fdegir: great, thank you.
08:38:53 <fdegir> thx
08:39:11 <kubi> fdegir: done
08:39:18 <fdegir> good
08:39:20 <kubi> #topic code review
08:39:55 <kubi> please review patchs https://gerrit.opnfv.org/gerrit/#/c/14405/
08:40:06 <kubi> #info please review patchs https://gerrit.opnfv.org/gerrit/#/c/14405/
08:40:28 <kubi> #link https://gerrit.opnfv.org/gerrit/#/c/13703/
08:41:10 <kubi> let 's keep actively code review
08:41:21 <kubi> #topic Yardstick CI imporvement
08:42:04 <MatthewLi> yep I have created a JIRA task there
08:42:20 <kubi> MatthewLi:  could you give us a intro about your idea of yardstick CI improvement
08:43:13 <MatthewLi> Kubi: the basic idea is that I want to make it's more clear to developers
08:43:42 <goutham> i have a suggestion.
08:43:47 <MatthewLi> first move /ci directory into /tests
08:43:51 <kubi> goutham: go ahead
08:44:01 <MatthewLi> go ahead
08:44:33 <goutham> i am sorry i am new can we develop a gui jus like rally
08:44:36 <goutham> our own GUI
08:45:04 <YaogaungWang> That's very cool
08:45:06 <kubi> goutham: that's great
08:45:26 <goutham> basically yardstick executes a test_Case generates a HOT template using which two Vms will be created
08:45:37 <goutham> based upon the scenario(PING)
08:45:53 <goutham> creates a stack, and later on it deletes the stack
08:46:27 <goutham> it stores the results in yardstick.out or in mongodb based upon the defaulter in etc
08:46:48 <goutham> we generate a task-id as well while running a test_Case
08:47:27 <goutham> so jus as in rally we create a option for user/ developer yardstick report generate <task-id>
08:48:26 <goutham> so now he can view the JSON  and another command like yardstick report generate <task-id> this will give a good html
08:49:23 <Mingjiang6> The output can be viewed in the grafana at present.
08:49:31 <goutham> sorry yardstick html generate <task-id > to generate a html page i think this helps a developer
08:49:31 <MatthewLi> by now we use influxdb and grafana
08:49:44 <goutham> yea i have gone through that as well
08:50:00 <goutham> but somehow i feel a own GUI jus like rally would be great
08:50:57 <kubi> goutham: i think that is also a good choice for user:).
08:50:58 <goutham> what say  poeple ??
08:51:19 <MatthewLi> personally I think its good just do that
08:51:24 <Mingjiang6> GUI is great for users and developers to use, that' totally true.
08:51:39 <Jing> agree
08:51:42 <kubi> qiliang27:  any comments?
08:52:01 <MatthewLi> and if u can combine the grafana solution
08:52:22 <kubi> goutham: could you like to do something about own Gui
08:52:30 <goutham> yes kubi
08:52:39 <kubi> goutham: that's great!
08:52:54 <goutham> i have some good knowledge on python/and front end development
08:53:09 <kubi> goutham: cool
08:53:20 <goutham> i have not gone through angular js till now but if needed i can extend my skills to angular as well..
08:53:45 <MatthewLi> goutham: good
08:53:59 <Mingjiang6> goutham: awesome
08:54:08 <MatthewLi> then back to my topic?
08:54:13 <MatthewLi> :)
08:54:14 <goutham> thank you :)
08:54:21 <goutham> yea sure mathew :D
08:54:24 <kubi> #agree we develop a gui jus like rally, we create a option for user/ developer yardstick report generate <task-id>.
08:54:32 <kubi> MatthewLi: it's your turn
08:54:55 <kubi> goutham: thank you for your good proposal
08:55:07 <goutham> you are welcome
08:55:14 <MatthewLi> the idea is also same as rally, if u looks its directory, put CI into tests is how they done
08:55:53 <goutham> my idea is that it must  also have multiple scenario executions
08:56:03 <MatthewLi> the second is that we have 2 run-test.sh one for unittest and one for test suite , we should adjust its names....
08:56:05 <goutham> jus like rally <kubi >
08:57:48 <MatthewLi> third is that some hint bugs fix, such as https://gerrit.opnfv.org/gerrit/#/c/14405/
08:58:10 <kubi> MatthewLi: 2 run-test.sh, one for baisc test including unitest and one for Ci task (test suite), they are same name
08:59:03 <kubi> MatthewLi: it will be a little confused for developer
08:59:07 <MatthewLi> kubi: so I plan to do some adjustment, these are written by different people previously
08:59:20 <kubi> MatthewLi: yes, you are right
09:00:00 <kubi> so, any comments about MatthewLi's proposal?
09:00:26 <MatthewLi> as goutham said we can extend to more scenarios, finally
09:01:16 <kubi> MatthewLi: great
09:02:33 <MatthewLi> so I will list the actions here.....
09:03:01 <MatthewLi> #action Jun Li CI directory moves into /tests
09:03:39 <MatthewLi> #action Jun Li rename 2 same run_tests.sh scripts
09:04:21 <MatthewLi> #action Jun Li CI workflow bugs fix and improvement
09:04:43 <kubi> any comments?
09:05:20 <kubi> MatthewLi: great, thank you for your great work.
09:05:38 <kubi> #topic others
09:06:35 <kubi> #info HA team will attend our thursday IRC meeting to discuss HA test cases
09:06:53 <kubi> #the meeting has been extended to one hour
09:07:08 <kubi> #info the meeting has been extended to one hour
09:07:43 <kubi> anything else?
09:08:46 <kubi> ok, thank you for today.
09:08:53 <kubi> #endmeeting