08:29:09 <kubi> #startmeeting Yardstick work meeting
08:29:09 <collabot`> Meeting started Thu Jul  7 08:29:09 2016 UTC.  The chair is kubi. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:29:09 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:29:09 <collabot`> The meeting name has been set to 'yardstick_work_meeting'
08:29:18 <kubi> #topic call role
08:29:22 <kubi> #info Kubi
08:30:07 <Mingjiang5> #info Mingjiang
08:30:11 <Jing> #info Jing
08:30:18 <LiHuan> #info lihuan
08:30:22 <songnon> #info songnon
08:31:12 <qiujuan> #info qiujuan
08:31:27 <kubi> songnon: Hi, nice to see you again, I wonder if you are interested in yardstick. If yes, I 'd like to invite you as a contributor
08:31:38 <songnon> sure
08:31:55 <songnon> kubi: Thanks
08:31:56 <kubi> songnon: great, welcome
08:32:00 <Kanglin> #info Kanglin
08:32:26 <kubi> songnon: could you give me you Name and email address?
08:32:44 <kubi> songnon: so that I can add you into contributor list
08:33:00 <songnon> kubi: Songnon Zhang, email is songnon.zhang@ericsson.com
08:33:46 <kubi> songnon: got it. thanks
08:34:00 <kubi> #topic New contributor
08:34:02 <songnon> kubi: :)
08:34:37 <kubi> #info Songnon Zhang would be a new contributor of yardstick. songnon.zhang@ericsson.com
08:34:55 <Jing> welcome
08:35:01 <Mingjiang5> welcome
08:35:12 <songnon> thanks
08:35:24 <kubi> #action Kubi will add songnon into contributor list
08:35:53 <kubi> #topic Release Plan
08:37:18 <kubi> I reorganize the plan to become clear for everyone
08:37:23 <kubi> #link https://etherpad.opnfv.org/p/yardstick_release_c_feature_freeze
08:38:06 <kubi> #action All please check the release plan, and give commments
08:39:24 <Yaoguang_Wang> #info Yaoguang
08:40:00 <kubi> Yaoguang_Wang: hi , please check this link https://etherpad.opnfv.org/p/yardstick_release_c_feature_freeze
08:40:53 <kubi> any question about this plan?
08:41:13 <Yaoguang_Wang> kubi: yep. i saw it. i am okay for integration storperf and vsperf into yardstick
08:41:29 <kubi> Yaoguang_Wang: great, thanks
08:41:50 <Jing> +1
08:42:02 <kubi> Jing: Thanks
08:42:58 <kubi> There are some test cases unassigned from TC57 to TC68
08:43:15 <Yaoguang_Wang> kubi: if Junli has no enough time to implement capacity/scale, i would like help him do some storage capacity
08:43:35 <kubi> please feel free to assign it if some of you are interested in some test cases
08:43:46 <kubi> Yaoguang_Wang:  that's great
08:44:06 <kubi> please comment it in that etherpad page
08:45:56 <kubi> goutham: ping
08:46:43 <kubi> #topic others
08:47:03 <Mingjiang5> Hi, i'd like to someting to make yardstick test base on scenarios
08:47:14 <Mingjiang5> in ci
08:48:02 <kubi> Mingjiang5: do you mean make yardstick test suite base on scenarios?
08:48:51 <Mingjiang5> for ci, yes
08:48:59 <Mingjiang5> now the ci is using *pod_name*.yaml to decide what to run in one pod.
08:49:32 <Mingjiang5> so all scenarios in one pod are running the same test suite, which doesn't make sense.
08:49:32 <kubi> Mingjiang5: yes, It is based on POD
08:50:25 <kubi> Mingjiang5:  Yes, you are right, We should run different test case in different secnario
08:50:51 <Mingjiang5> kubi: as we know, each installers deploy different scenarios in a series of ci jobs. test cases are related to the scenario, but not the pod. So it's reasonable to run test cases based on scenarios.
08:51:32 <kubi> Mingjiang5:  And also, community also want yardstick test case run based on scenarios
08:52:01 <kubi> Mingjiang5: that is a good idea
08:52:32 <kubi> zhihui_wu: ping
08:53:16 <Mingjiang5> at present, ci use pod_name to call a test suite in yardstick.
08:53:16 <Mingjiang5> to make it run on scenarios, we can simply modify the parameter that pass to yardstick to be a scenario.
08:53:33 <Mingjiang5> we can change it from the pod_name to the scenario_name
08:53:50 <goutham> hi
08:53:57 <goutham> hi kubi
08:53:58 <Mingjiang5> then we can create test suite named by the scenario.
08:54:15 <goutham> i am sorry i was late
08:54:26 <goutham> <kubi> please tell
08:54:34 <kubi> goutham: hi, wait a minutes, we will discuss GUI after Mingjiang's topic
08:54:46 <goutham> yea sure :)
08:54:48 <Mingjiang5> so each scenario owner would be responsible to maintain the sceanrio.yaml
08:55:12 <kubi> Mingjiang5: that's what community want
08:56:14 <Mingjiang5> this is my plan for release C, what do you guys think?
08:56:46 <Jing> sounds good
08:57:17 <kubi> +1
08:57:45 <kubi> I suggest you could propose this idea at today testing weekly meeting
08:58:40 <Mingjiang5> kubi: ok, i'll try it.
08:58:51 <kubi> Mingjiang5: Thanks
08:59:02 <kubi> #topic Yardstick GUI
08:59:21 <goutham> hi
08:59:28 <goutham> can i start kubi??
08:59:34 <kubi> goutham: yes
08:59:50 <goutham> so as of now we can do this way
09:00:07 <goutham> we are using Releng code to store  results in mongodb
09:00:17 <goutham> which intern uses tornado framework
09:00:27 <goutham> using that we can develop GUI
09:00:33 <goutham> but
09:01:05 <goutham> if we want to generate HTMl pages jus as Rally as a application (Raas) does
09:01:33 <goutham> i guess we have to use Mako files and generate HTML pages
09:01:56 <goutham> i mean we have to develop html files using Mako files and
09:02:25 <goutham> generate HTML for which Tornado is not necessry
09:02:46 <goutham> i have sent a wire frame a rough one without any colors via Mails
09:02:52 <goutham> https://etherpad.opnfv.org/p/Yardstick_GUI
09:03:15 <goutham> and this is the Etherpad link you can provide your comments or suggestion
09:03:17 <goutham> here
09:04:27 <goutham> so we should create a web application jus like Rally or should we need a complete dash board (which does execution of test-cases) and shows the result there it self??
09:05:24 <kubi> goutham: what rally does is just a test result report or not?
09:05:39 <goutham> it jus gives a test-report
09:05:45 <goutham> after the executio
09:05:51 <kubi> goutham: got it
09:05:53 <goutham> of test case
09:06:13 <kubi> goutham: what 's your original idea?
09:06:24 <goutham> my idea is to the Rally way
09:06:33 <goutham> to do **
09:07:14 <kubi> goutham: Rally way is great for Yardstick in Colorado
09:09:12 <kubi> goutham: A completed dashboard (which does exection of test case and show the result) will be expected in future Release.
09:09:38 <goutham> ok
09:09:47 <goutham> so if that is the case we can acheive it
09:09:51 <goutham> using tornado
09:09:53 <goutham> itself
09:10:16 <goutham> but  it will be great if we can have some rest api working for that
09:11:23 <kubi> goutham: One more question. Rally way is a web application on the Internet?
09:11:44 <goutham> no
09:11:57 <goutham> its like you run a test-case
09:11:57 <kubi> goutham: could the test report be generated in local.
09:12:26 <kubi> goutham: that's great
09:12:33 <goutham> you get a command which upon executing we get a html page
09:12:50 <goutham> a normal .html page
09:13:07 <goutham> thats it
09:14:16 <kubi> goutham: sounds good
09:14:25 <goutham> this is what rally does
09:14:33 <goutham> so for yardstick
09:15:10 <goutham> should i generate a page like rally or a complete dash board which
09:15:25 <goutham> has both execution and display of results
09:15:29 <Mingjiang5> goutham: so execute a command to tornado, then it generate a html for report?
09:16:24 <goutham> no basically tornado is like a server running on a particular port
09:16:33 <goutham> @Ming
09:16:33 <collabot`> goutham: Error: "Ming" is not a valid command.
09:17:12 <Mingjiang5> goutham: it can only process the rest api, right?
09:17:28 <songnon> goutham: a question I have is that, if the .html page is generated locally, how can the user view that page?
09:18:06 <goutham> yea  it works on Rest-api but
09:18:43 <goutham> the communication but i dont think there something like get or post between Yardstick code and Tornado :|
09:19:14 <goutham> if it is generated locally user jus clicks that a webpage pops out thats it
09:19:41 <goutham> Songnon:
09:19:47 <Mingjiang5> goutham: do the gui has function for user to select which test case to run?
09:21:14 <goutham> Mingjiang5: If we want a full length dash board which contains both execution of test-case and displaying the results then yes it has to be there
09:21:46 <goutham> this can be done using the releng framework..
09:22:52 <kubi> goutham: Mingjiang5: If we want to run test case via GUI, Rest api  would be need, yes?
09:24:51 <goutham> we can do that in another way
09:25:02 <goutham> but i guess thats a crude way :|
09:25:32 <goutham> without rest-calls
09:27:36 <Mingjiang5> i think we truely need rest-api to do this.
09:27:42 <goutham> Like logging the output via cli
09:27:51 <goutham> using subprocess
09:28:05 <goutham> it can be done but not a good way to do that
09:28:16 <goutham> i guess
09:28:29 <goutham> Mingjiang5 : yes
09:28:40 <goutham> we need Rest-API support
09:28:56 <kubi> goutham: I also prefer Rest API
09:29:34 <songnon> Rest API will be a decent way...
09:32:31 <goutham> Kubi:
09:32:54 <goutham> so then i need some help on this
09:33:12 <goutham> i have used Rest Api but never developed using that
09:33:28 <goutham> so it will be great if some one helps me on this
09:33:39 <goutham> Can any one help me on this??
09:34:24 <kubi> goutham: Ok, anyone is familiar with Rest api development?
09:35:20 <kubi> goutham: I will ask Qi liang who did some Rest Api development  to provide the support.
09:36:13 <kubi> goutham: let's discuss more in email, we have to leave the office now.
09:36:17 <goutham> Kubi :thank
09:36:21 <goutham> you
09:36:32 <kubi> goutham: thanks for your great work:)
09:36:32 <goutham> Kubi: yea sure thanks for the time
09:36:53 <Mingjiang5> goutham: i have no experience on that, but i can do some homework to help
09:36:54 <goutham> thank you and same to you
09:37:09 <kubi> thanks all for today.
09:37:19 <kubi> Mingjiang5: thanks for help
09:37:29 <goutham> lets make Yardstick a better product :)
09:37:41 <kubi> goutham: great:)
09:37:49 <kubi> #endmeeting