08:30:16 <kubi> #startmeeting Yardstick work meeting
08:30:16 <collabot> Meeting started Thu Jul 14 08:30:16 2016 UTC.  The chair is kubi. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:30:16 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:30:16 <collabot> The meeting name has been set to 'yardstick_work_meeting'
08:30:25 <kubi> #topic call role
08:30:43 <kubi> #info Kubi
08:30:49 <Kanglin> #info Kanglin
08:31:01 <Mingjiang5> #info Mingjiang
08:31:06 <Julien-zte> #info Julien
08:31:26 <songnon> #info songnon
08:31:51 <qiujuan> #info qiujuan
08:32:17 <kubi> #topic MileStone
08:33:05 <kubi> #link https://wiki.opnfv.org/display/SWREL/Releases+Colorado+Projects
08:33:21 <kubi> #info above link is the status of all project
08:34:12 <kubi> I report the MileStone7 as 80% complete
08:35:05 <kubi> since SFC and  HA proio 1 test cases have been implenmented
08:35:13 <kubi> bu not CI yet
08:35:17 <Mingjiang5> is there any update about the release schedule?
08:36:02 <kubi> Mingjiang5: the original data of MS7 is 7th July
08:36:10 <Julien-zte> hi kubi, in the Jira, 90 To Do, 10 in Progress
08:36:20 <Julien-zte> shall be update the status in Jira
08:36:39 <kubi> Mingjiang5: and one Week delay for all projects
08:36:57 <Julien-zte> yes, to this weekend
08:37:45 <kubi> Julien-zte: thanks for reminder,  I will update the status, most of "To Do" tasks will be moved to D-Release
08:38:03 <Julien-zte> that's great
08:38:29 <Julien-zte> the status will be consistent with the Jira
08:39:09 <kubi> Julien-zte: the main task for Colorado would be the generic test cases , New Feature test cases, Integration with Xperf and installer
08:39:55 <kubi> #info Ruijing has successfully integrated the yardstick with Fuel.
08:40:09 <Julien-zte> zhihui is working on integrate qtip to yardstick, but it won't be released in Colorado
08:40:36 <kubi> Now Fuel could deploy yardstick and run yardstick smoke test cases
08:40:37 <Julien-zte> the yardstick plugin in Fuel?
08:40:48 <kubi> Julien-zte: yes
08:40:54 <Julien-zte> great!
08:42:02 <kubi> So, If some of you still have some task with above area, please upload your patch as soon as possible.
08:43:26 <kubi> #topic DPDK testing
08:43:55 <kubi> Julien-zte: do you know the progress of zhihui's tese case?
08:44:38 <Julien-zte> we have some discussion about this
08:44:45 <zhihui_wu> kubiļ¼Œ check my email
08:45:09 <zhihui_wu> I met a question about latency.
08:45:38 <Julien-zte> the original dpdk dev tools does not support latency metrics
08:45:42 <zhihui_wu> the latest version of pktgen-dpdk do not support latency measure.
08:45:46 <kubi> I see
08:46:19 <zhihui_wu> Any suggestion about it?
08:46:29 <Julien-zte> the basic tools and metrics can be submit but the remain will be delayed to next release.
08:46:37 <Julien-zte> huge work will be involved.
08:47:40 <Julien-zte> considering dpdk, the millseconds is meaningful using ping?
08:47:41 <kubi> zhihui_wu: So, How about throughput?
08:48:15 <zhihui_wu> May this is ok
08:48:49 <kubi> zhihui_wu: OK, I guess we could delay the latency to next release
08:48:59 <Julien-zte> it is different path when using dpdk(l2 forward) and non dpdk(l3, iperf)
08:49:56 <Julien-zte> we maybe have more discussion about this. zhihui can give a doc to introduce this later
08:50:06 <kubi> zhihui_wu: It will be better to contrac with pktgen-dpdk developers to confirm the plan of supporting latency.
08:50:32 <Julien-zte> kubi, it is right. we are contacting intel's developer
08:50:38 <zhihui_wu> ok. I will send an email to them later.
08:50:54 <kubi> If it is not too far, we can delivery it in Colorado 2.0 or Colorado 3.0
08:51:03 <Julien-zte> :)
08:51:22 <kubi> Julien-zte: thanks
08:51:31 <Julien-zte> actually, there are several additional months
08:52:27 <zhihui_wu> about dpdk image, i will post a patch.
08:53:43 <kubi> zhihui_wu: great, I think you can work with akos to make the YARDSTICK-232 and 263 go well.
08:54:59 <kubi> #info zhihui_wu will contrac with pktgen-dpdk developers to confirm the plan of supporting latency measurment
08:55:46 <kubi> #info YARDSTICK-233 may be moved to Colorado 2.0 or further Release.
08:56:16 <kubi> #topic test suite evolution
08:56:51 <kubi> zhihui_wu: did you start the YARDSTICK-289?
08:57:11 <zhihui_wu> Sorry, it does not start
08:57:54 <kubi> zhihui_wu: Ok, do you have plan to do it in Rel C? could you give a priority of this story/
08:58:14 <Mingjiang5> what i'm doing on the ci scenario-suite(yardstick-299) may have some relation with yardstick-289
08:58:49 <zhihui_wu> I have to give it a low priority.
08:59:04 <Mingjiang5> i'd like to add some options in the suite config yaml
08:59:38 <kubi> Mingjiang5: thanks
09:01:02 <kubi> Mingjiang5: that would be useful for yardstick
09:01:41 <kubi> #topic others
09:01:48 <kalyan> hi kubi..
09:01:51 <kalyan> hi all
09:01:55 <kubi> kalyan: hi
09:02:35 <kalyan> tried to login to guest using port-forwarding..
09:02:53 <Mingjiang5> kanglin: i think we can add one new ha test case into a ci suite to test it in community.
09:03:12 <zhihui_wu> Mingjiang, if it blocks you, i plan to start this work next week.
09:03:34 <zhihui_wu> I will ask some help from our team.
09:03:35 <kalyan> mentioned the ip and port in pod.yaml file passed it to the cyclilctest-context.yaml file
09:03:53 <kalyan> i have on doubt here..
09:04:14 <kalyan> https://gerrit.opnfv.org/gerrit/gitweb?p=yardstick.git;a=blob;f=yardstick/benchmark/scenarios/compute/cyclictest.py;h=478b0a1a2d8dde3aabb388f987588f21c64c2c0d;hb=HEAD
09:04:46 <Kanglin> Mingjiang5: It that means I need to add a new test suite file or add cases to existing suite files?
09:04:59 <kalyan> from line 137 ..we are calling both connect_host() and connect_guest()
09:05:52 <kalyan> kubi: when i run the testcase it is always going to connect_host in which port 5555 is not specified and it is failing there
09:06:23 <Mingjiang5> zhihui_wu: that would be great, thanks. if you need some discussion, you can email me.
09:06:25 <kalyan> when i debug the issue..i found the above..i am correct?
09:07:38 <kalyan> i tried commenting the connect_host() call..then the authentication issue resolved..
09:08:02 <zhihui_wu> Mingjiang5, ok.
09:08:03 <Mingjiang5> Kanglin: no need to create a new one, we just add one to the existing virtual-pod first.
09:09:03 <Mingjiang5> Kanglin: in this way, we can test your new ha framework ASAP.
09:09:32 <kalyan> kubi: can you please tel me how to mention port in pod.yaml..is there any such sample file for refernce?
09:10:14 <Kanglin> Mingjiang5: Got it.
09:10:48 <kubi> kalyan: I think I need to check with Qi liang who is the author of this test case.
09:12:36 <kalyan> i think the port 5555 is hardcoded too...we cant use any other port right?
09:12:36 <kubi> kalyan: I guess the value of port is a hard code in this scenario
09:12:55 <kubi> kalyan: yes
09:13:08 <kalyan> kubi: yes i am trying with port 5555
09:13:41 <kubi> kalyan: so you need this port as a value which could be pass by the pod.yaml?
09:14:40 <kalyan> kubi: yes, in the sample pod.yaml, how to pass ip, user, keyfiles mentioned..bt not port.
09:15:05 <kalyan> i am trying it with port: 5555 in pod.yaml
09:15:49 <kalyan> when i mention 5555 port in pod.yaml the request is going to connect_host()
09:16:28 <kalyan> is there anywhere else i can pass the port 5555 ..so that the request will go to connect_guest() in which port is defined
09:17:45 <kubi> kalyan: I think no at now, but it is easy to support
09:18:05 <kubi> kalyan: and I need to double check with Qiliang
09:18:33 <kalyan> kubi: ok..so at now we have to pass port 5555 to pod.yaml right?
09:18:42 <kalyan> kubi: ok :)
09:19:26 <kubi> #action Kubi will double check the cyclictest configure with Qiliang
09:19:39 <kubi> kalyan: I will reply you ASAP
09:19:45 <kalyan> kubi: ok
09:19:55 <kubi> kalyan: thanks for your question
09:19:58 <kalyan> kubi: thanks a lot:)
09:20:11 <kubi> kalyan: :)
09:20:17 <kubi> anything else?
09:20:25 <songnon> what is the pod.yaml used for?
09:21:51 <kalyan> songnon: pod.yaml will contain the vm info on which we want to run cyclictest...and the path for pod.yaml will be mentioned in cyclictest-node-context.yaml
09:23:08 <songnon> so the pod.yaml will provided more info about the nodes?
09:23:34 <songnon> like the ip address, domain names?
09:23:36 <kubi> songnon: pod.yaml generally looks like this https://gerrit.opnfv.org/gerrit/gitweb?p=yardstick.git;a=blob;f=etc/yardstick/nodes/fuel_virtual/pod.yaml;h=8a7f436b973a13e40f2086a5c97de2e31b646436;hb=HEAD
09:23:41 <kalyan> yes exactly..
09:24:02 <songnon> yep, I see that in the code...
09:24:23 <songnon> but I don't have a full picture regarding how it's used
09:24:44 <kubi> kalyan: could you send you pod.yaml to us via the email
09:24:51 <kubi> you-> your
09:25:05 <kalyan> kubi: ok..
09:26:05 <songnon> kubi: thx
09:27:08 <kubi> songnon: I will organize a demo for new contributors after the busy time for release.
09:27:29 <songnon> kubi: that would be great!
09:27:31 <Mingjiang5> songnon: there're several test case using pod.yaml as input info to log in a pod, like tc043, you can refer to it for an example
09:27:45 <kalyan> kubi: great: really that helps a lot :)
09:28:13 <kubi> kalyan: songnon: thanks for your good question
09:28:25 <kubi> anything else?
09:28:30 <kalyan> kubi: :)
09:28:44 <kubi> thanks all for todya
09:28:47 <kubi> today
09:28:55 <kubi> #endmeeting