00:33:44 <trevor_intel> #startmeeting Yardstick
00:33:44 <collabot> Meeting started Tue Jan 10 00:33:44 2017 UTC.  The chair is trevor_intel. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:33:44 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
00:33:44 <collabot> The meeting name has been set to 'yardstick'
00:33:58 <Mingjiang> i cant hear
00:34:02 <Mingjiang> i'll reconnect
00:36:03 <trevor_intel> #topic Action follow-up
00:37:32 <JingLu> link: https://wiki.opnfv.org/display/yardstick/Yardstick+Framework+Architecture+Evolution
00:37:52 <trevor_intel> #info Action was to create Yardstick architecture Wiki, see https://wiki.opnfv.org/display/yardstick/Yardstick+Framework+Architecture+Evolution
00:39:03 <trevor_intel> #info Will be included in Danube documentation
00:39:51 <trevor_intel> #info Looking for feedback in next weeks meeting
00:40:08 <kubi001> I'm online, sorry for the late, there was something wrong with hotel
00:40:30 <kubi001> network
00:40:37 <trevor_intel> kubi001: no problem
00:43:43 <trevor_intel> #action Ross will update diagram for NSB
00:46:10 <trevor_intel> #info See Jira ticket for status - waiting for Ruijing to reply https://jira.opnfv.org/browse/YARDSTICK-529
00:46:53 <trevor_intel> #topic Python 3
00:47:15 <trevor_intel> #info Ross proposed plan in Etherpad https://etherpad.opnfv.org/p/YardstickPython3
00:49:14 <trevor_intel> #info Everybody read Open Stack porting 3 guidelines
00:49:45 <trevor_intel> #info We are in step 1 today
00:50:42 <rbbratta> please review https://gerrit.opnfv.org/gerrit/#/c/25539/
00:50:48 <trevor_intel> #info Step 2 commit is in Gerrit for review - committers please review it
00:51:26 <trevor_intel> #info Ross would like to merge soon - touches lots of other files so have to keep re-basing
00:52:14 <rbbratta> #info Adding Python 3 support  https://gerrit.opnfv.org/gerrit/#/c/25539/
00:52:58 <kubi001> yes, otherwise, it will become a heavy work for rebasing
00:53:40 <rbbratta> I have tested it with opnfv_smoke suite, but it needs more testing.
00:54:32 <Mingjiang> #info yardstick team should review about the patch: kubi, jing, jack, rex, kanglin, zhihui
00:55:31 <kubi001> within two days? is it ok for everyone?
00:56:09 <Mingjiang> limingjiang@huawei.com
00:57:43 <kubi001> Mingjiang:  maybe, you can help to do some local verify besides review
00:58:45 <trevor_intel> #info Ross indicated Python 3 unit tests are key ... do it before or after Danube?
00:59:08 <trevor_intel> #info Rex suggested to do ASAP or will be harder
01:00:09 <kubi001> +1 to before Danube.
01:00:17 <trevor_intel> #info Deepak has proposed patches ... not sure if compatible with Python 3 ... Ross will inform Deepak to prepare accordingly and will help
01:01:10 <trevor_intel> #info Agreed to enable before Danube
01:01:44 <trevor_intel> #agree Enable Python 3 before Danube
01:02:04 <Mingjiang> kubi001:  i'll do that
01:02:53 <trevor_intel> #info Ross is willing to help anybody with porting to Python 3
01:03:02 <kubi001> great
01:03:24 <trevor_intel> #topic Yardstick-Qtip integration
01:04:06 <JingLu> link: https://wiki.opnfv.org/display/yardstick/Yardstick-Qtip+integration
01:05:33 <trevor_intel> #info #link https://wiki.opnfv.org/display/yardstick/Yardstick-Qtip+integration
01:05:47 <trevor_intel> #info https://etherpad.opnfv.org/p/qtip-yardstick
01:06:00 <trevor_intel> #undo
01:06:00 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1f16590>
01:06:06 <trevor_intel> #link https://etherpad.opnfv.org/p/qtip-yardstick
01:22:47 <rbbratta> The Framework can run 5 computing benchmarks: 1. Dhrystone 2. Whetstone 3. RamBandwidth 4. SSL 5. nDPI
01:24:42 <trevor_intel> #info Discussion on Qtip relationship to Yardstick for integration is unclear
01:24:55 <Mingjiang> agree
01:25:02 <trevor_intel> #info Needs some discussion between Yardstick and Qtip team
01:26:21 <trevor_intel> #info Qtip benchmarks listed in Wiki The Framework can run 5 computing benchmarks: 1. Dhrystone 2. Whetstone 3. RamBandwidth 4. SSL 5. nDPI
01:26:55 <rbbratta> https://github.com/ntop/nDPI.git
01:27:46 <kubi001> I guess "1. Dhrystone 2. Whetstone 3. RamBandwidth " should be similar with yardstick test case
01:27:52 <rbbratta> #info nDPI is an open source LGPLv3 library for deep-packet inspection.
01:28:21 <rbbratta> #info These benchmarks can be run in 2 test cases: 1. VM vs Baremetal 2. Baremetal vs Baremetal
01:29:46 <trevor_intel> #topic Sprint
01:30:01 <kubi001> yujun told me that Qtip will mainly calculate score based on yardstick test result instead of testing by themself
01:30:32 <Mingjiang> #link https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=145&view=planning&selectedIssue=YARDSTICK-529&versions=visible
01:31:24 <Mingjiang> #link https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=145&view=detail&selectedIssue=YARDSTICK-524
01:31:38 <trevor_intel> kubi001: ok I think that is also what Bottleneck said ... but maybe its for a different purpose?
01:31:59 <trevor_intel> Detecting bottlenecks vs measuring performance
01:32:50 <Mingjiang> #info the sprint page is to show what yardstick is in progress/to do/done in the active sprint
01:33:13 <Mingjiang> you can easily move it to modify the status of the jira task
01:34:07 <Mingjiang> #info all of this is in the "Agile of YARDSTICK" board: https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=145&view=planning&selectedIssue=YARDSTICK-529&versions=visible
01:37:17 <kubi001> trevor_intel: yes, different purpose, and Bottleneck worked as a load manger, that would be call yardstick iteratively. and Qtip will work as a kind of yardstick result interpreter based on some algorithmic
01:39:06 <rbbratta> old qtip info here:  https://wiki.opnfv.org/display/qtip/Brahmaputra
01:40:38 <trevor_intel> rbbratta
01:40:45 <trevor_intel> rbbratta: thanks
01:41:33 <kubi001> rbbratta: thanks,here is some update from Qtip link https://goo.gl/g16hEG
01:43:00 <trevor_intel> kubi001: yes that presentation is linked as the introduction to Qtip on project wiki
01:43:59 <trevor_intel> I have looked through it a few times but still have questions
01:44:50 <kubi001> trevor_intel: :) shall we have a joint meeting with Qtip at next Yardstick meeting
01:45:09 <trevor_intel> kubi001: good idea!
01:45:13 <Mingjiang> agree
01:45:17 <trevor_intel> +1
01:45:18 <JingLu> +1
01:45:25 <rbbratta> compute QPI:   https://git.opnfv.org/qtip/tree/benchmarks/suite/compute.yaml   weighted arithemetic mean of various stats
01:45:29 <rbbratta> +1
01:45:38 <kubi001> Ok, I will contract with Qtip team
01:45:53 <JackChan1> +1
01:46:16 <kubi001> #action kubi will contract with Qtip team to have a joint meeting at next weekly meeting
01:46:49 <trevor_intel> #action  kubi will contract with Qtip team to have a joint meeting at next weekly meeting
01:47:09 <trevor_intel> #endmeeting