00:30:43 <kubi001> #startmeeting Yardstick Work Meeting
00:30:43 <collabot> Meeting started Tue Jan 24 00:30:43 2017 UTC.  The chair is kubi001. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:30:43 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
00:30:43 <collabot> The meeting name has been set to 'yardstick_work_meeting'
00:31:02 <kubi001> #topic call roll
00:31:07 <kubi001> #info kubi
00:31:18 <JingLu> #info Jing
00:31:21 <zhihui> #info zhihui
00:31:26 <trevor_intel_> #info trevor
00:31:36 <kubi001> 156-176-189
00:31:43 <kubi001> https://global.gotomeeting.com/join/156176189
00:32:06 <trevor_intel_> joining audio now
00:33:26 <trevor_intel_> can't hear anything
00:34:07 <trevor_intel_> its clear now
00:34:10 <zhihui> sorry, I meet a network proble. can not join GTM.
00:34:26 <zhihui> proble->problem
00:34:46 <kubi001> #chair trevor_intel_
00:34:46 <collabot> Current chairs: kubi001 trevor_intel_
00:34:48 <Mingjiang> #info rex
00:34:53 <rbbratta> #info Ross
00:35:00 <kubi001> #topic action items follow up
00:35:13 <kubi001> http://ircbot.wl.linuxfoundation.org/meetings/opnfv-yardstick/2017/opnfv-yardstick.2017-01-17-00.30.html
00:36:22 <kubi001> #info AP1 Ross will update diagram for other part of NSB --> please feel free to update
00:37:12 <kubi001> #link https://wiki.opnfv.org/display/yardstick/Yardstick+Framework+Architecture+Evolution
00:37:18 <zhihui> for the yardstick-qtip-integration, can we use IRC instead. Sorry, I can not join GTM, due to bad network.
00:39:58 <kubi001> #info AP2 kubi will send the minutes to ask trevor and ross' view--> discuss today
00:40:06 <kubi001> #topic committer nomination
00:41:51 <kubi001> #info I'd like to nominate Trevor and Ross as  a Yardstick Committer
00:42:20 <kubi001> #action kubi will upload a patch to ask all yardstick committers to vote in the gerrit
00:42:49 <trevor_intel_> #topic Yardstick Qtip integration
00:43:06 <kubi001> we will move to IRC
00:43:17 <zhihui> thanks!
00:48:29 <zhihui> kubi, do team member move to IRC? or still GTM?
00:49:24 <kubi001> https://wiki.opnfv.org/display/yardstick/Yardstick-Qtip+integration
00:49:30 <zhihui> About integration, which part yardstick still have questions?
00:49:31 <kubi001> yes, we are here now
00:49:35 <rbbratta> so yardstick will collect logs and then send results to qtip for calculation?
00:49:52 <JingLu> rbbratta: yes, that is the idea
00:50:05 <rbbratta> so the log parsing code will be in yardstick?
00:50:18 <rbbratta> how complex are the calculations
00:50:27 <zhihui> Yes, use api to post results to qtip.
00:50:48 <JingLu> rbbratta: yes, we are considering add a post-test process step in yardstick to handle the log
00:51:29 <mskrocki> will the post-test action be optional?
00:51:46 <kubi001> rbbratta: I guess Qtip have two kinds of calculation. one is  weighted average, other is  geometric mean
00:51:49 <rbbratta> I was just wondering if qtip could be turned into a library and we could just import it
00:51:52 <zhihui> It is not complex for now. we will use simple formula to calculate temporarily
00:52:16 <JingLu> mskrocki: yes, it's optional
00:52:45 <zhihui> For future, next release, we will improve the formula.
00:53:24 <rbbratta> it just seems like a lot of work to just calculate an average, or am I missing something
00:53:37 <Mingjiang> rbbratta: it  seems easier to import a library as you said from my point of view
00:53:42 <zhihui> calculations is a part of qtip agent.
00:54:43 <kubi001> zhihui: so what's the main function with qtip agent?
00:55:00 <rbbratta> do you have example from the source code?
00:55:42 <zhihui> There are two parts for qtip agent. collection and report.
00:56:25 <trevor_intel_> I am confused if Qtip executes the test cases (Qtip-PoC) ... or is it the Yardstick test cases that are executed?
00:57:35 <JingLu> it is the yardstick test case. I think Qtip-Poc is based on our TC.
00:57:37 <zhihui> not qtip executes test case, the runner is yardstick.
00:58:24 <zhihui> In agent mode, yardstick executes test case. And qtip want to use test results of yardstick.
00:59:17 <kubi001> GTM have been occupied by other meeting, It seems that we can discuss in IRC
01:00:14 <zhihui> shall we go on our discussion via email?
01:00:25 <trevor_intel_> Ok Yujun Zhang says Qtip is doing doing "platform performance benchmarking" ... but what I understand is Yardstick is doing benchmarking and Qtip is doing metric analysis?
01:00:26 <kubi001> Qtip could be used as a calculation module for yardstick view
01:00:44 <kubi001> trevor_intel_: good point
01:01:31 <kubi001> I guess there is a misunderstand for "benchmark", from Yujun's view, "benchmark" doesn't include testing.
01:01:35 <zhihui> trevor_intel_, I think yujun has a different point about it.
01:02:20 <trevor_intel_> ok, its not really clear for me yet
01:02:22 <zhihui> benchmark does not only testing.
01:02:23 <kubi001> from my view, "benchmark do includes testing"
01:03:08 <trevor_intel_> I agree with Kubi
01:03:59 <Mingjiang> to my understand, there's some ovelap, testing is part of benchmark, you cant do benchmark without testing
01:04:11 <zhihui> Since yujun is on his vacation, we can continue our discussion next meeting.
01:04:24 <trevor_intel_> I don't think anything wrong but would like to be able to explain the difference between the projects so its clear
01:04:52 <kubi001> trevor_intel_: agree,
01:05:02 <Mingjiang> agree that this should be clarified clear
01:05:03 <kubi001> https://goo.gl/g16hEG
01:05:29 <trevor_intel_> Yes I have looked at the presentation
01:05:50 <trevor_intel_> Unfortunately I have to go to the next meeting :(
01:06:27 <trevor_intel_> Lets keep working and we can sort out the naming / definitions later?
01:06:29 <kubi001> trevor_intel_: sure, thanks for attending today's meting
01:06:50 <trevor_intel_> thanks to you Kubi!
01:07:12 <trevor_intel_> Its not such an easy job
01:07:17 <trevor_intel_> :)
01:07:26 <kubi001> #info since yujun is still on vacation,  some naming / definitions will be discussed later.
01:07:41 <kubi001> trevor_intel_: yes, thanks a lot
01:07:59 <kubi001> OK. any other topics from you.
01:08:54 <kubi001> #info next week meeting will be canceled, due to chinese New Year vacation
01:09:34 <kubi001> see you in week 6.
01:09:37 <kubi001> :)
01:09:45 <kubi001> thanks all for today
01:09:48 <kubi001> #endmeeting