08:30:44 <kubi001> #startmeeting Yardstick Work Meeting
08:30:44 <collabot> Meeting started Mon Feb  6 08:30:44 2017 UTC.  The chair is kubi001. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:30:44 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:30:44 <collabot> The meeting name has been set to 'yardstick_work_meeting'
08:30:54 <kubi001> #topic Roll call
08:30:57 <kubi001> #info kubi
08:30:59 <JingLu> #info Jing
08:31:02 <rbbratta> #info Ross
08:31:03 <JackChan> #info Jack
08:31:11 <Mingjiang> #info Rex
08:31:33 <Kanglin> #info Kanglin
08:31:35 <kubi001> rbbratta: hi, thanks for attending the meeting with a late time :)
08:31:50 <rbbratta> no problem
08:32:37 <rbbratta> well, actually I'm interested in getting Jenkins fixed
08:33:09 <Mingjiang> yes, i've added a topic about it
08:33:15 <kubi001> rbbratta: Ok, Let 's make it as first topic
08:33:39 <kubi001> #topic Yardstick Jenkins job fail fix
08:34:22 <rbbratta> I think we need to merge  https://gerrit.opnfv.org/gerrit/#/c/27479/  to fix the python 3 unittests
08:35:02 <kubi001> rbbratta: got it
08:35:32 <rbbratta> and then I think we need to merge https://gerrit.opnfv.org/gerrit/#/c/28091/  to fix AMQP failures
08:35:48 <kubi001> #infplease review the patch and merge it ASAP  https://gerrit.opnfv.org/gerrit/#/c/27479/ , https://gerrit.opnfv.org/gerrit/#/c/28091/
08:35:58 <kubi001> #info please review the patch and merge it ASAP  https://gerrit.opnfv.org/gerrit/#/c/27479/ , https://gerrit.opnfv.org/gerrit/#/c/28091/
08:36:12 <rbbratta> and then recheck everything and see what else fails.
08:36:24 <kubi001> rbbratta: thanks for fixing the jenkins issue
08:36:38 <JingLu> have seen these patches, will review them ASAP
08:36:57 <Mingjiang> i think this patched can be merged quickly to check ci
08:36:58 <rbbratta> is there a way to re-trigger all failed jobs?
08:37:21 <rbbratta> anyway, those two fixes should hopefully unblock everything
08:38:04 <rbbratta> but also note that Python3 unittests are enabled now, thanks to releng enabling tox.
08:39:01 <JingLu> understood
08:39:01 <rbbratta> that's all I wanted to say on the topic.
08:39:40 <Mingjiang> does it rely on jenkins server to have python3-dev?
08:39:52 <kubi001> #action kubi will re-trigger all fail jobs
08:39:58 <Mingjiang> since we've already enable py3 test
08:40:14 <rbbratta> that was fixed, added back in apt-get install python3-dev before tox
08:41:45 <Mingjiang> so it's fixed in releng or in the jenkins server?
08:42:01 <rbbratta> fixed in releng
08:42:31 <JingLu> #link https://gerrit.opnfv.org/gerrit/#/c/28087/
08:42:34 <Mingjiang> thanks, i see
08:42:48 <rbbratta> I don't know where the Jenkins slaves are configured, I created Jira ticket, we could ask releng about the slave setup.
08:42:56 <rbbratta> but for now we just sudo apt-get install
08:43:21 <rbbratta> https://jira.opnfv.org/browse/RELENG-190
08:45:17 <kubi001> rbbratta: I think that would be OK for now
08:46:01 <Mingjiang> i think each patch should rebase to pass jenkins verify
08:46:26 <Mingjiang> since patch after tox.ini should be rebased
08:47:12 <Mingjiang> or the  verify job cant find tox.ini file
08:47:32 <rbbratta> ah yes, need to be rebased on top of job with tox.ini
08:47:42 <kubi001> Mingjiang: good point
08:48:00 <JingLu> Another thing; KVMFORNFV just added two scenarios in our test suite, once the verify is fixed we can review and merge the patch asap.
08:48:01 <JingLu> 
08:48:36 <kubi001> #info all patch should be rebased for the tox.ini
08:48:44 <rbbratta> It is kinda weird to include tox.ini in the project, but dovetail and others include tox.ini as well.
08:49:39 <JingLu> here is the link of kvm patch
08:49:46 <JingLu> #link: https://gerrit.opnfv.org/gerrit/#/c/28085/
08:50:41 <kubi001> #info KVMFORNFV just added two scenarios in yardstick test suites, please help to review #link: https://gerrit.opnfv.org/gerrit/#/c/28085/
08:50:47 <Mingjiang> rbbratta: can you explan about it?
08:51:01 <Mingjiang> why tox.ini should not be included
08:52:00 <JackChan> https://github.com/openstack/nova
08:52:24 <rbbratta> well, in theory someone could submit a review that disables a tox check and Jenkins would then +1 the commit.
08:52:25 <JackChan> It seems that nova put tox.ini in project.
08:53:04 <rbbratta> we would have to check in code-review that nobody is modifying tox.ini incorrectly.
08:53:28 <rbbratta> but I guess it doesn't matter since run_tests.sh is also in the project.
08:53:31 <JackChan> rbbratta: I see.
08:54:05 <kubi001> rbbratta: good point
08:54:38 <kubi001> #info since tox.ini were included in project, we would have to check in code-review that nobody is modifying tox.ini incorrectly
08:55:29 <JackChan> But where should we put it? It seems in project is the only choise.
08:55:44 <Mingjiang> got it, thanks : )
08:56:26 <JingLu> got it. learned a lot
08:56:45 <rbbratta> in theory we could embed it in releng somehow, like with a <<EOF heredoc.  but then it isn't as flexible.
08:58:01 <JackChan> But if we produce it dynamicly, how to run it locally?
08:58:27 <rbbratta> that's true too, you'd lose that capability.
08:59:18 <rbbratta> or we could include a sample, but then modify releng to use a specific generated file  echo | tox  or something
09:00:14 <JackChan> So if anyone modify it and submit a patch, we should merge it more carefully.
09:00:53 <rbbratta> yes, just check for tox.ini changes
09:02:59 <kubi001> I think that would be a good solution.
09:04:09 <kubi001> #info we could include a sample tox.ini in the project, but then modify releng to use a specific generated file  echo | tox  or something
09:04:41 <kubi001> OK. It seems that we are already over the time, any more comments on this topic?
09:05:31 <kubi001> #topic others
09:05:50 <kubi001> any others topic?
09:06:01 <kubi001> Kanglin: how about you?
09:07:19 <kubi001> It seems that no more topic for toady
09:07:26 <kubi001> OK, thanks all for today
09:07:31 <Kanglin> kubi001: nothing
09:07:53 <kubi001> Kanglin:  will you attend this week HA meeting?
09:08:32 <Kanglin> kubi001: yes, qiujuan and me will attend the meeting , discuss HA test cases on D release.
09:08:58 <kubi001> Kanglin: great, thanks a lot. hope you have a good discussion.
09:09:18 <Kanglin> kubi001: thanks : )
09:09:23 <kubi001> Reminder , Milestone6 should be Feb. 17
09:09:39 <Mingjiang> i can also join the meeting on Wednesday
09:09:50 <kubi001> we should implement the test case before MS6
09:10:36 <Mingjiang> so there's not much of time left..
09:10:55 <kubi001> https://wiki.opnfv.org/display/SWREL/Release+Milestone+Description
09:11:50 <Kanglin> got it.
09:12:01 <kubi001> Kanglin: Thanks a lot
09:12:06 <kubi001> Thanks all for today
09:12:11 <kubi001> #endmeeting