00:32:35 <kubi001> #startmeeting Yardstick Work Meeting
00:32:35 <collabot`> Meeting started Tue Feb 14 00:32:35 2017 UTC.  The chair is kubi001. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:32:35 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
00:32:35 <collabot`> The meeting name has been set to 'yardstick_work_meeting'
00:33:20 <trevor_intel> #info Trevor Cooper
00:33:25 <rbbratta> #info Ross
00:33:28 <kubi001> https://global.gotomeeting.com/join/156176189
00:33:33 <kubi001> #info kubi
00:33:35 <Mingjiang> #info Rex
00:33:37 <JingLu> #info Jing
00:33:47 <kubi001> #chair trevor_intel
00:33:47 <collabot`> Current chairs: kubi001 trevor_intel
00:34:25 <kubi001> today's agenda https://wiki.opnfv.org/display/yardstick/Meetings
00:34:44 <kubi001> #topic Action point follow-up
00:34:57 <kubi001> http://ircbot.wl.linuxfoundation.org/meetings/opnfv-yardstick/2017/opnfv-yardstick.2017-02-07-00.31.html
00:36:05 <kubi001> #AP1 : Ross still working on fixes -> Done
00:36:09 <JackChan> #info Jack
00:36:28 <kubi001> #topic Milestone 6
00:37:03 <kubi001> #info Milestone is Feb. 17
00:37:23 <kubi001> #info MS6 requires "Test Cases and Preliminary Documentation Completed
00:38:03 <kubi001> #info Mingjiang created a JIRA task to trace the Preliminary documentation
00:38:24 <kubi001> #link https://jira.opnfv.org/browse/YARDSTICK-554
00:38:32 <deepak__> kubi001: Sent first versoin of the doc for review.. i will update the jira
00:39:01 <trevor_intel> #info From Ray -> During the recent license scan, we noticed that there were a lot of files that are missing license header information.  If you need help/examples for license headers, please check out https://wiki.opnfv.org/display/DEV/Contribution+Guidelines
00:39:17 <trevor_intel> Just a reminder
00:40:29 <deepak__> kubi0001: ./install.sh
00:40:29 <deepak__> ./yardstick/vTC/apexlake/bin/run_tests.sh
00:40:29 <deepak__> ./fuel-plugin/vagrant/build_fuel_plugin.sh
00:40:29 <deepak__> ./fuel-plugin/deployment_scripts/install.sh
00:40:29 <deepak__> ./vTC/build.sh
00:40:30 <deepak__> ./yardstick/benchmark/scenarios/networking/sfc_server.bash
00:40:31 <deepak__> ./yardstick/benchmark/scenarios/networking/sfc_change_classi.bash
00:40:33 <deepak__> ./yardstick/benchmark/scenarios/networking/sfc_tacker.bash
00:40:35 <deepak__> ./yardstick/benchmark/scenarios/networking/sfc_teardown.bash
00:40:39 <deepak__> ./yardstick/benchmark/scenarios/networking/sfc_compute.bash
00:40:41 <deepak__> ./yardstick/benchmark/scenarios/networking/pktgen_dpdk_latency_benchmark.bash
00:40:43 <deepak__> ./yardstick/benchmark/scenarios/networking/testpmd_fwd.bash
00:40:45 <deepak__> ./yardstick/benchmark/scenarios/networking/sfc_pre_setup.bash
00:40:47 <deepak__> https://gerrit.opnfv.org/gerrit/#/c/28531/
00:41:54 <kubi001> trevor_intel: thanks
00:43:29 <kubi001> #info deepak__ show the list of missing license head file. but only a few, not a lot.
00:44:24 <kubi001> #action kubi will recheck with Ray to find the scan list
00:46:34 <trevor_intel> kubi001: thanks ... yes
00:47:12 <kubi001> trevor_intel: http://ircbot.wl.linuxfoundation.org/meetings/opnfv-release/2017/opnfv-release.2017-02-08-03.24.log.html
00:48:28 <kubi001> #topic Add NSB few test in CI
00:49:04 <trevor_intel> #topic test cases for NSB features
00:49:13 <trevor_intel> #undo
00:49:13 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2187fd0>
00:49:46 <trevor_intel> sorry didn't see Kubi already added topic
00:58:49 <kubi001> Opera meeting start
00:58:55 <trevor_intel> ok
00:59:21 <kubi001> we can discuss with IRC
00:59:28 <trevor_intel> no audio
00:59:44 <deepak__> I think we lost audio
00:59:54 <deepak__> ???
00:59:58 <trevor_intel> deepak__: Can you write up a short description of the test?
01:00:02 <kubi001> yes, It 's time for Opera meeting
01:00:11 <deepak__> Oh, ok
01:00:15 <kubi001> so they start the Gotomeeting
01:00:26 <trevor_intel> Anyway it should be documented
01:00:37 <trevor_intel> To understand the test coverage
01:00:50 <kubi001> the key point is the difference with the current test case
01:00:53 <deepak__> trevor_intel: Sure
01:01:13 <trevor_intel> deepak__: thanks
01:01:26 <kubi001> deepak__: with current test case, we ping between two VMs
01:01:36 <Mingjiang> i think we can try another bridge next time like zoom.us, it's heard Ray has a created a 30 days account for opnfv meeting and subscribe longer if zoom is ok to use.
01:02:06 <kubi001> I guess the test case will be make sense if the test case could verify some function or code
01:02:51 <kubi001> Mingjiang: we can have a try
01:02:55 <deepak__> yes, ping test is to verify the functionality of the code
01:03:35 <kubi001> #action deepak__ will document the new NSB test case
01:04:31 <kubi001> deepak__: add you test case in here
01:04:32 <kubi001> https://gerrit.opnfv.org/gerrit/gitweb?p=yardstick.git;a=tree;f=tests/opnfv/test_cases;h=601f2432108998113e0c106a61f70b8503a6f163;hb=HEAD
01:04:39 <Mingjiang> deepak__: about your ping case, can it possible to be run in current existed ci pods?
01:05:06 <Mingjiang> does it have any requirement about the pod?
01:05:12 <kubi001> deepak__:  add the test case into the test suite https://gerrit.opnfv.org/gerrit/gitweb?p=yardstick.git;a=blob;f=tests/opnfv/test_suites/opnfv_os-nosdn-nofeature-ha_daily.yaml;h=44c8494d17e9e0db963ea77df4797297bd0cea5a;hb=HEAD
01:05:28 <deepak__> Mingjiang: Can you share the details of the ci? i would like to try
01:06:29 <Mingjiang> yes, i can brief about current ci flow.
01:07:11 <Mingjiang> kubi have sent the link about where test suite(yaml) and test case(yaml) locates
01:07:28 <deepak__> how to trigger the ci?
01:07:48 <Mingjiang> it's triggered by jenkins jobs located in releng project
01:07:53 <kubi001> deepak__: we have daliy job https://build.opnfv.org/ci/view/yardstick/
01:08:14 <deepak__> Awesome thanks
01:08:23 <kubi001> run every day with installer, functest ,yardstick
01:08:40 <Mingjiang> for yardstick, we have a jjb(jenkins job builder)  in releng
01:09:00 <kubi001> deepak__: the test case would be run in the CI if you add the test case into test suite
01:09:19 <deepak__> ok.. Thanks kubi001..
01:09:35 <kubi001> most test suites are called by the jenkins
01:10:03 <kubi001> Mingjiang: can you send the JJB link to deepak?
01:10:46 <Mingjiang> #link https://git.opnfv.org/releng/tree/jjb/yardstick
01:10:56 <Mingjiang> this is where yardstick jjb locates
01:11:11 <kubi001> deepak__: there are two thing you need to do if you want to run test case with CI before MS6
01:11:31 <deepak__> kubi001: ok?
01:11:52 <kubi001> deepak__: 1. add "ping test case into here https://gerrit.opnfv.org/gerrit/gitweb?p=yardstick.git;a=tree;f=tests/opnfv/test_cases;h=601f2432108998113e0c106a61f70b8503a6f163;hb=HEAD
01:12:30 <kubi001> 2. add "ping" test case into nosdn-nofeature test suite   https://gerrit.opnfv.org/gerrit/gitweb?p=yardstick.git;a=blob;f=tests/opnfv/test_suites/opnfv_os-nos...
01:13:14 <deepak__> can you resend the link?
01:13:21 <Mingjiang> #link https://wiki.opnfv.org/display/yardstick/How+to+add+a+test+case+into+test+suite
01:13:39 <Mingjiang> this links helps you about how to add a test into test suite
01:13:40 <kubi001> deepak__: Mingjiang's link would be better
01:14:09 <deepak__> ok
01:14:34 <kubi001> please let us know if you have any further question
01:14:47 <kubi001> #topic license issue
01:14:52 <kubi001> we have discussed above
01:14:59 <kubi001> #topic others
01:15:05 <kubi001> no other topics?
01:15:30 <kubi001> Thanks all for today's meeting
01:15:34 <kubi001> #endmeeting