08:32:10 <kubi001> #startmeeting Yardstick Work Meeting
08:32:10 <collabot`> Meeting started Mon Apr 10 08:32:10 2017 UTC.  The chair is kubi001. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:32:10 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:32:10 <collabot`> The meeting name has been set to 'yardstick_work_meeting'
08:32:16 <kubi001> #topic roll call
08:32:19 <JackChan> #info Jack
08:32:31 <rbbratta> #info Ross
08:32:33 <sdeepak001> #info Deepak
08:32:35 <danielmartinbuck> #info danielmartinbuckley
08:32:40 <abhijitsinha> #info Abhijit
08:33:13 <JingLu> #info Jing Lu
08:33:20 <Kanglin> #info Kanglin
08:33:20 <kubi001> hi, everyone. thanks for join the meeting
08:33:27 <kubi001> https://wiki.opnfv.org/display/yardstick/Meetings
08:33:48 <kubi001> here is the today's agenda, please feel free to proposal your topic
08:34:06 <kubi001> #info kubi
08:34:27 <kubi001> #topic Action point follow-up 5'
08:35:19 <kubi001> #info AP1: kubi will add Daniel and Abhijit into Yardstick Contributors List
08:35:49 <Mingjiang> #info Rex
08:35:55 <kubi001> #info AP1: https://wiki.opnfv.org/display/yardstick/People
08:36:04 <kubi001> #info AP1: Done
08:36:15 <kubi001> http://ircbot.wl.linuxfoundation.org/meetings/opnfv-yardstick/2017/opnfv-yardstick.2017-03-27-08.31.html
08:36:19 <kubi001> last minutes
08:36:39 <kubi001> #info AP2: Jing will update the release note this week
08:37:51 <JingLu> release note has been updated for Danube 1.0
08:37:59 <kubi001> #info AP2: Done , and Yardstick Danube 1.0 has been released
08:38:18 <kubi001> JingLu: could you help to send the link of RN
08:38:41 <kubi001> JingLu: I find it now http://docs.opnfv.org/en/stable-danube/submodules/yardstick/docs/release/release-notes/index.html#yardstick-releasenotes
08:38:46 <kubi001> #link http://docs.opnfv.org/en/stable-danube/submodules/yardstick/docs/release/release-notes/index.html#yardstick-releasenotes
08:39:08 <kubi001> #info AP3: kubi will create a etherpad to discuss yardstick beijing summit plan
08:39:49 <kubi001> #info AP3: Done https://etherpad.opnfv.org/p/yardstick_beijing_summit_planning
08:40:30 <kubi001> please feel free to update the etherpad, and As a remind April 10th will be the deadline for OPNFV Summit CFP
08:41:06 <rbbratta> today is April 10th
08:41:49 <kubi001> rbbratta: yes,  April 10, 11:59 PM PT.
08:42:19 <kubi001> rbbratta: so, please proposal your topic as soon as possbile
08:43:48 <kubi001> rbbratta: I proposed a topic about evaluating NFVI performance by leverage yardstick
08:44:38 <rbbratta> that sounds good
08:45:11 <kubi001> #topic CI status
08:45:27 <JingLu> #link: https://build.opnfv.org/ci/view/yardstick/
08:46:20 <kubi001> #info Danube 2.0 would be May 4th.
08:47:06 <rbbratta> are we planning on a breakout session for yardstick for the design summit?
08:47:29 <JingLu> We still have a Jira ticket (YARDSTICK-603) to resolve in 2.0.
08:48:06 <kubi001> rbbratta: not yet, but sounds good.
08:48:48 <Mingjiang> +1
08:49:02 <JingLu> I've sent a  pod access request for ericsson pod to debug this YARDSTICK-603.
08:49:11 <kubi001> JingLu: thanks
08:50:07 <kubi001> rbbratta:  will you attend the beijing summit
08:50:23 <kubi001> by the way, I will attend the plugfest :)
08:50:27 <rbbratta> I hope to
08:50:34 <rbbratta> have to get approved, etc.
08:51:39 <kubi001> It's would be great if we can have a session during the design summit
08:51:47 <rbbratta> kubi001: do you plans for plugfest?  we should meet with deepak
08:52:25 <kubi001> rbbratta: not yet, just approved three days ago :)
08:52:59 <kubi001> rbbratta:  so deepak also will be there?
08:53:11 <rbbratta> kubi001: okay, maybe we should just reserve a room and put down yardstick project update
08:53:32 <rbbratta> kubi001: yes, last I heard deepak got approved
08:53:40 <sdeepak001> kubi001: Waiting for my visa. hopefully i will be there :)
08:54:06 <kubi001> rbbratta: sounds good
08:55:08 <kubi001> #action Kubi will try to book a time slot of room for this plugfest
08:55:48 <kubi001> sdeepak001: I'm also waiting for my visa. :)
08:56:15 <sdeepak001> :)
08:56:43 <kubi001> #topic unit test
08:57:12 <kubi001> danielmartinbuck:  abhijitsinha : will you attend the plugfest?
08:57:38 <Mingjiang> #link https://jira.opnfv.org/browse/YARDSTICK-610
08:57:50 <danielmartinbuck> kubi001# No
08:58:11 <abhijitsinha> kubi001: not attending plugfest
08:58:23 <Mingjiang> Jing from nokia have propose a patch to add a new runner type
08:58:37 <kubi001> danielmartinbuck: abhijitsinhah: got it, thanks
08:58:45 <Mingjiang> she has to add unit test case to pass the ci
08:59:49 <Mingjiang> which lead a problem: for runner and some framework's feature before ci gating, we didn't have unit test in the past
09:00:46 <kubi001> #chair rbbratta Mingjiang
09:00:46 <collabot`> Current chairs: Mingjiang kubi001 rbbratta
09:01:25 <Mingjiang> so what we do in this situation, i think we may need a discussion
09:02:47 <kubi001> good topic rbbratta: what's your opinion?
09:03:34 <rbbratta> normal procedure is to extract functions and unittest those
09:04:28 <rbbratta> or more mocking
09:06:56 <rbbratta> could extract the checking, the iterating from the binary search loop
09:07:06 <rbbratta> it depends what the unittest % threshold is
09:08:19 <Mingjiang> sounds reasonable
09:08:46 <kubi001> the threshold is the 10 extra missing lines
09:11:02 <Mingjiang> rbbratta: can you comment in the JIRA ticket about this?
09:11:16 <rbbratta> I commented in the review
09:11:36 <kubi001> rbbratta: thanks
09:11:48 <kubi001> #topic Aob
09:12:06 <rbbratta> SSH password auth
09:12:06 <kubi001> any topic from you?
09:12:25 <kubi001> rbbratta: go ahead
09:12:28 <rbbratta> https://gerrit.opnfv.org/gerrit/#/c/32931/
09:12:39 <rbbratta> also provider networks, from the SR-IOV patch
09:13:06 <rbbratta> and creating flavors form Heat context
09:13:28 <kubi001> rbbratta: looks good
09:14:10 <rbbratta> for SSH, I created a factory function to handle the common case of creating an ssh connection from a node dict.
09:14:38 <rbbratta> but we have to be careful to default all the paramiko options to None, so that we follow the standard SSH auth methods
09:15:37 <rbbratta> It is still draft because I haven't tested it, our Intel Oregon lab has been offline for most of last week.
09:16:19 <rbbratta> We also have the draft danielmartinbuck about creating flavors in Heat.
09:16:19 <kubi001> any volunteer could help to test it?
09:17:11 <Mingjiang> I think we can use huawei pod in shanghai to have a try.
09:18:09 <rbbratta> ssh will look for pkey string first, then key_filename in ~/.ssh/* and only then fall back to password
09:18:40 <rbbratta> so we don't have to hardcode key_filename = ~/.ssh/id_rsa,  paramiko should already handle that.
09:19:41 <rbbratta> it also requires the ChainMap module, which was added to Python 3.3, but there is a backport.
09:20:04 <rbbratta> ChainMaps are very useful for handling dictionaries with defaults, we should use them whenever possible.
09:20:41 <rbbratta> also looking for feedback on the Heat flavor creation
09:20:42 <JackChan> rbbratta: hardcode? Now the ~/.ssh/id_rsa is default value
09:21:03 <rbbratta> paramiko handles that
09:21:06 <Mingjiang> looks great. what happened in python 27 when using ChainMap
09:21:11 <rbbratta> I think it scans ~/.ssh
09:21:36 <rbbratta> Mingjiang: for python 2.7 use chainmap==1.0.2
09:22:16 <Mingjiang> #action yardstick team to review flavor create in heat context and feedback
09:22:29 <Mingjiang> #link https://gerrit.opnfv.org/gerrit/#/c/33001/
09:23:05 <rbbratta> JackChan: https://github.com/paramiko/paramiko/blob/master/paramiko/client.py#L569
09:23:46 <rbbratta> JackChan: it checks for ~/.ssh/id_rsa, ~/.ssh/id_dsa, ~/.ssh/id_ecdsa
09:24:29 <rbbratta> The last topic are provider networks.  We are trying to figure out the best way to connect Ixia directly to compute node to test traffic while bypassing the neutron router.
09:25:09 <Mingjiang> rbbratta: what happens if the ~/.ssh/id_rsa is not the right key?
09:25:34 <sdeepak001> what is i want to use different key other than is_rsa
09:25:43 <Mingjiang> will it get to next step in the check chain?
09:25:43 <rbbratta> Mingjiang: if you have an actual key, then you can provide a path, or a list of paths and paramiko will use them.
09:26:15 <rbbratta> Mingjiang: the defaults are only when key_filename is None
09:26:51 <rbbratta> Mingjiang: https://github.com/paramiko/paramiko/blob/master/paramiko/client.py#L372
09:27:27 <rbbratta> https://github.com/paramiko/paramiko/blob/master/paramiko/client.py#L239
09:28:13 <JackChan> rbbratta: So it is a chain. If we set it in node, it will use the value in node?
09:28:44 <rbbratta> If node has key_filename that is not None, then we will use that key_filename
09:29:12 <JackChan> rbbratta: got it.
09:30:32 <kubi001> rbbratta:  The last topic are provider networks.  We are trying to figure out the best way to connect Ixia directly to compute node to test traffic while bypassing the neutron router.
09:31:38 <rbbratta> the SR-IOV patch is using provider networks
09:31:59 <rbbratta> has anyone tested provider networks with Fuel or any of the installers?
09:32:32 <JingLu> have tested sr-iov in Apex
09:32:54 <rbbratta> with Heat?
09:33:09 <JingLu> With heat template
09:33:34 <rbbratta> so it should just work?
09:33:56 <JingLu> yes
09:34:15 <Mingjiang> rbbratta: thanks for the clarify, I'll test the ssh patch locally in compass nosdn-nofeature scenario and feedback
09:34:30 <rbbratta> as long as you set it up correctly, which is our current problem.
09:35:16 <rbbratta> so we could connect Ixia or other external TG directly to compute node, create provider network, and then run traffic.
09:36:05 <JingLu> rbbratta yes, we did the same thing in apex, it is ok.
09:38:08 <rbbratta> but we have to hardcode provider network into the test case yaml,   or use an env var like EXTERNAL_NETWORK
09:39:45 <rbbratta> Okay, once I get my lab systems back up, I'll try it out.
09:39:54 <rbbratta> I think that's it for me.
09:40:54 <Ace__> rbbratta: Now we use exiting physics network to create two provider vlan network and use vsperf Moongen to do the same test like Vsperf
09:41:48 <rbbratta> using Heat?
09:42:10 <Ace__> yes.
09:42:58 <rbbratta> I guess we should make a network diagram, or something to add to the docs, if this is going to be somewhat standard VNF characterizaion topology
09:43:01 <Ace__> We use a heat template file to do those things
09:43:11 <rbbratta> do you have an example?
09:44:47 <Ace__> could i send you my template file by email?
09:45:32 <rbbratta> yes
09:45:46 <Ace__> or you need some more information ?
09:45:52 <rbbratta> template is fine
09:46:13 <rbbratta> well, also interested in all the bridge connections.
09:46:47 <rbbratta> can you run plotnetcfg?
09:47:45 <Ace__> never used.
09:48:06 <rbbratta> it is very nice, it dumps a diagram of all your bridges and ports
09:48:52 <Ace__> I will provide some information to you by sending email.
09:48:56 <sdeepak001> Ace__: quick question?
09:49:12 <sdeepak001> are you using 1G or 10G ports for provider network?
09:49:27 <Ace__> only 1Gb
09:49:41 <sdeepak001> hmm ok
09:49:42 <rbbratta> http://redhatstackblog.redhat.com/2015/10/15/troubleshooting-networking-with-rhel-openstack-platform-meet-plotnetcfg/
09:50:00 <sdeepak001> also  assuming we are creating more than 1 bridge right?
09:51:27 <Ace__> Now only use 1 bridge and use the physics is datecentre
09:51:42 <sdeepak001> ok got it
09:51:46 <Ace__> yep
09:53:26 <kubi001> Well, I think we should end the meeting at first, you can feel free to discuss
09:53:31 <kubi001> #endmeeting