08:30:56 <rbbratta> #startmeeting yardstick work meeting
08:30:56 <collabot> Meeting started Mon Jun 26 08:30:56 2017 UTC.  The chair is rbbratta. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:30:56 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:30:56 <collabot> The meeting name has been set to 'yardstick_work_meeting'
08:31:05 <rbbratta> #topic roll call
08:31:10 <rbbratta> #info Ross
08:31:10 <JackChan> #info Jack
08:31:12 <JingLu> #info JingLu
08:31:16 <Ace__> #info Ace
08:31:27 <Kanglin> #info Kanglin
08:31:31 <Mingjiang6> #Mingjiang
08:31:39 <Mingjiang6> #info Rex
08:32:05 <zhihui> #info zhihui
08:32:13 <rbbratta> #topic action items follow up
08:33:45 <rbbratta> #info https://jira.opnfv.org/browse/YARDSTICK-685  new task for Energy Audit aaS
08:34:17 <rbbratta> #info no update on VES agent for collecting KPIs
08:34:34 <rbbratta> #info no update on new meeting time for APAC
08:35:48 <rbbratta> any other action updates?
08:36:06 <abhijitsinha> #info abhijit
08:36:41 <JackChan> hi abhijit
08:36:51 <abhijitsinha> hi Jack
08:36:57 <rbbratta> Mingjiang6: any update on the dovetail docker tag request?
08:37:45 <rbbratta> #info https://jira.opnfv.org/browse/YARDSTICK-644 updated with request to use POD descriptor file for HW info
08:38:34 <Mingjiang6> for yardstick, i think danube would meet their requirement, currently only ha test case included in dovetail test cases
08:39:59 <rbbratta> #info dovetail docker tags: should be able to use Danube tags
08:40:01 <JingLu> HA test cases are ready in Danube 3.0, so I think dovetail will use the 3.0 tag
08:40:28 <rbbratta> okay, next topic Danube 3.0
08:40:41 <rbbratta> #topic Danube 3.0
08:40:55 <rbbratta> #info waiting for new release date for Danube 3.0
08:41:15 <rbbratta> How are the Jenkins jobs?
08:41:55 <rbbratta> I think there was one more fix for ARMBAND they wanted merged.
08:42:00 <JackChan> The release date seems to delay to 27th?
08:42:30 <rbbratta> I think there will be a TSC meeting on the 27th to pick a date
08:43:53 <rbbratta> okay ARMBAND fix was merged already.
08:43:56 <JackChan> OK
08:44:32 <rbbratta> Release notes are mostly done except for dates
08:44:47 <rbbratta> #info Danube 3.0 release notes mostly done except for dates
08:45:22 <rbbratta> it seems like Jenkins was broken for a few days, which is not good, same thing happened for Danube 1.0
08:45:45 <rbbratta> it was partly the releng master problem and then the openstack ${SECURE} issue.
08:46:06 <rbbratta> we need better process around CI
08:46:38 <rbbratta> I would say we need unittests for the scripts, but it is hard to unittest bash scripts
08:47:32 <rbbratta> any ideas?
08:48:31 <JackChan> rbbratta:  do you know any tools to do unittests for scripts?
08:49:07 <rbbratta> I think there are frameworks, but you have to rewrite things to use functions and then mock the functions.
08:49:47 <rbbratta> it is better to re-write in Python, or use ansible and docker containers or something.
08:49:58 <rbbratta> I'll try to figure something out.
08:50:41 <rbbratta> okay, next topic AoB
08:50:53 <rbbratta> #topic AoB
08:52:08 <rbbratta> increasing line length to 99,  are we all agreed?
08:52:28 <JingLu> +2
08:52:31 <JackChan> rbbratta: sure
08:52:56 <Mingjiang6> agree
08:53:27 <OPNFV-Gerrit-Bot> Merged yardstick: increase line length to 99  https://gerrit.opnfv.org/gerrit/36335
08:54:01 <rbbratta> dockerfile offline support
08:54:21 <rbbratta> #info https://gerrit.opnfv.org/gerrit/#/c/36365/ draft for dockerfile offline git support
08:54:42 <rbbratta> we need to add more logic to the Dockerfile so we can clone exact tags or branches for releng and yardstick.
08:55:22 <rbbratta> also do we plan on supporting Ubuntu 16.04 for Dockerfile?
08:55:40 <rbbratta> do we have existing Jira for offline support?
08:56:33 <rbbratta> JackChan: https://jira.opnfv.org/browse/YARDSTICK-597 is for offline support, but it is resolved?
08:57:34 <JackChan> in load_image.sh, we support offline. But in exec_test.sh we have some problem. But it seems you fix it?
08:58:18 <rbbratta> JackChan: exec_tests.sh should work if the git repo was cloned correctly, but we need to change Dockerfile to support releng branch or commit
08:58:26 <JingLu> In long term, we should support Ubuntu 16.04 for Dockerfile. we can create a jira for this in low priority.
08:58:47 <JackChan> rbbratta: agree
08:59:22 <rbbratta> JingLu: okay, please create new Jira
08:59:31 <rbbratta> I will create new Jira for dockerfile changes
09:00:11 <rbbratta> #action Ross create Jira for Dockerfile offline support by git cloning releng branch or commit
09:00:33 <JingLu> rbbratta: sure
09:00:36 <rbbratta> #action JingLu create Jira for Ubuntu 16.04 Dockerfile support
09:00:41 <rbbratta> okay
09:02:58 <rbbratta> AoB?
09:03:17 <rbbratta> if not we can close meeting
09:03:58 <rbbratta> okay, thanks everyone
09:04:02 <rbbratta> #endmeeting