08:30:28 <rbbratta> #startmeeting yardstick work meeting
08:30:28 <collabot> Meeting started Mon Aug 14 08:30:28 2017 UTC.  The chair is rbbratta. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:30:28 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:30:28 <collabot> The meeting name has been set to 'yardstick_work_meeting'
08:30:36 <rbbratta> #topic roll call
08:30:44 <rbbratta> #info Ross
08:30:51 <JingLu> #JingLu
08:30:57 <abhijitsinha> #info Abhijit
08:30:57 <JingLu> #info JingLu
08:31:47 <rbbratta> not a lot of people today
08:31:51 <rbbratta> #topic action item follow up
08:32:30 <rbbratta> #action rbbratta add Jira for provider networks topology for compass4nfv, still needs to be done
08:33:04 <rbbratta> #action rbbratta add LOG.debug to dump Heat template, need to follow up with Sanju
08:33:27 <rbbratta> #action rbbratta figure out how to tag Jira tasks for testcases, still needs to be done
08:34:41 <rbbratta> #info JackChan replace ping 0.2 library due to GPL license issue, done
08:35:01 <rbbratta> I think that's it for action items
08:35:08 <Kanglin> #info Kanglin
08:35:15 <rbbratta> #topic Danube 3.2
08:35:51 <rbbratta> #info https://gerrit.opnfv.org/gerrit/#/c/38955/ was merged to stable/danube
08:36:16 <rbbratta> JackChan has the yardstick.conf fix been tested?
08:36:23 <rbbratta> are we ready to tag and create docker?
08:36:39 <rbbratta> no, we need to update release notes for 3.2
08:37:06 <JingLu> rbbratta yes
08:37:09 <rbbratta> Jack isn't here.
08:37:16 <rbbratta> JingLu: can you update release notes?
08:37:29 <JingLu> rbbratta will do
08:38:02 <rbbratta> okay, so tomorrow EOD maybe we can tag and create docker
08:38:22 <rbbratta> anything else for 3.2?
08:39:01 <rbbratta> #topic YAML
08:39:21 <rbbratta> as a security requirement we are not allowed to use yaml.load() anymore, we have to use yaml.safe_load()
08:39:56 <rbbratta> yaml.load() can execute arbitrary python code, so it isn't safe.  This is something anteater checks.
08:40:09 <Mingjiang> #info Rex
08:40:18 <rbbratta> we also had a bug with YAML loading unicode.
08:40:45 <rbbratta> we were changing the global YAML str constructor to always return unicode for Heat templates.
08:41:00 <rbbratta> we can't be modifying the global YAML loader, it breaks other things.
08:41:34 <rbbratta> #info https://gerrit.opnfv.org/gerrit/#/c/39209/  add yaml_load which calls yaml.safe_load with a non-global YAML loader
08:42:00 <rbbratta> it also isolated the Heat template YAML loader, so that only that loader returns unicode always.
08:42:43 <rbbratta> so going forward everyone should use yaml_load and make sure to check unicode/str encoding
08:43:14 <rbbratta> #info please test https://gerrit.opnfv.org/gerrit/#/c/39209/ for yaml fixes
08:44:04 <rbbratta> any questions about YAML, unicode, etc.
08:44:31 <rbbratta> at some point we will need to start fixing anteater security errors and such.
08:44:56 <rbbratta> I guess I'll add the yaml info to wiki somewhere
08:45:44 <JingLu> Sounds good
08:46:12 <rbbratta> #topic Euphrates MS5 feature freeze
08:47:01 <rbbratta> I need to fix one more patch, for PROX.  We had coverage, but rebase changed coverage numbers
08:47:34 <rbbratta> #info https://gerrit.opnfv.org/gerrit/#/c/38251/  needs coverage, planned for MS5
08:48:28 <rbbratta> Are there any other patches that we priority to review?
08:48:31 <rbbratta> or merge
08:48:56 <JingLu> one from jack
08:49:07 <JingLu> #link https://gerrit.opnfv.org/gerrit/#/c/39217/
08:49:37 <rbbratta> ah, one more thing I forgot to add about YAML.
08:50:07 <JingLu> It is a feature to generate html report for yardstick test
08:50:18 <rbbratta> by default Jinja2 was converting None values to string "None".  I figured out how to have Jinja2 generate '~' for YAML null value.
08:50:53 <rbbratta> I see _generate_reporting is using Jinja2 render(), but I assume not for YAML
08:51:36 <rbbratta> anyway, for Jinja2 render, there is new function finalize_for_yaml, which will convert None to '~' null and also use yaml.dump to dump list and dicts nicely.
08:52:19 <rbbratta> #info https://gerrit.opnfv.org/gerrit/#/c/39217/ looks good
08:53:33 <rbbratta> #info https://gerrit.opnfv.org/gerrit/#/c/35379/  needs more review, Ace Lee had comment
08:53:51 <rbbratta> but he +1 it.
08:54:52 <JingLu> Yes, I think JingC need to fix that error
08:54:55 <rbbratta> okay, well I'll try to look at 35379  vsperf Tgen mode tomorrow
08:55:01 <Ace__> rbbratta: I don't know this error is only occured on my test environment.
08:55:42 <Ace__> I don't know if it's a common question for all environment.
08:56:00 <rbbratta> okay, if we don't here back from JingC by Tuesday I think we can merge for MS5 and fix it later.
08:56:20 <Ace__> yep.
08:56:59 <Mingjiang> agree
08:57:31 <rbbratta> #info https://gerrit.opnfv.org/gerrit/#/c/39107/  add comment openstack operations, needs review
08:58:05 <rbbratta> I wasn't sure what the openstack patches are for
08:58:50 <rbbratta> is this so we can use these scenarios as steps in a test case?
08:59:09 <JingLu> rbbratta yes that's correct
09:00:03 <rbbratta> okay we can do what we can for Euphrates, but for F-release I think we need to start using SNAPS for these things
09:01:14 <rbbratta> maybe we can abstract somewhat, so we don't have to duplicate the OpenStack API by hand.
09:01:35 <rbbratta> okay, anything else for MS5?
09:02:28 <rbbratta> #topic AoB
09:04:01 <rbbratta> okay, looks like we are done.
09:04:07 <rbbratta> thanks everyone
09:04:11 <rbbratta> #endmeeting