16:30:48 <trinaths> #startmeeting ovn4nfv
16:30:48 <collabot`> Meeting started Tue Mar  6 16:30:48 2018 UTC.  The chair is trinaths. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:48 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:30:48 <collabot`> The meeting name has been set to 'ovn4nfv'
16:30:54 <trinaths> #chair trinaths
16:30:54 <collabot`> Current chairs: trinaths
16:31:15 <trinaths> #agenda
16:31:20 <Amir_> Hello Trinaths
16:31:42 <trinaths> Hi Guest34073 - Amir
16:32:05 <trinaths> hi ak_dev_
16:32:12 <ak_dev_> Hello
16:32:54 <trinaths> #agenda https://wiki.opnfv.org/pages/viewpage.action?spaceKey=OV&title=Meeting+Agenda
16:33:08 <trinaths> Hi Amir-m,
16:33:28 <Amir-m> Hi Trinaths
16:33:35 <trinaths> #topic Action items review
16:34:04 <trinaths> Santosh will not be attending the meeting for today.
16:34:24 <trinaths> ak_dev_ : can you detail your action item status
16:34:57 <ak_dev_> trinaths: I had to work on documentation for k8s-ovn
16:35:04 <ak_dev_> which I have made an initial draft for
16:35:12 <trinaths> ok.
16:35:18 <ak_dev_> but have not been able to push due to some port blocking issues at my university
16:35:35 <trinaths> did you receive UOH vPOD details ?
16:35:44 <ak_dev_> trinaths: yeah, was just about to mention that
16:35:51 <ak_dev_> received them late night yesterday
16:35:56 <trinaths> ok cool.
16:36:09 <ak_dev_> will start with the development of ovn-os soon now
16:36:48 <trinaths> ak_dev_ I'm also facing port blocking issues while pushing a commit to gerrit. So as a work around I'm using my home network to submit the commit.
16:37:30 <ak_dev_> trinaths: I too was planning to use my mobile hotspot, but that too is giving poor connection
16:37:31 <trinaths> #action Develop os-ovn-nofeatue-noha scenario for JOID installer.
16:37:50 <trinaths> #action Develop os-ovn-nofeatue-noha scenario for JOID installer.  ak_dev_
16:38:19 <trinaths> ak_dev_ ok. but try to commit the document for review.
16:38:37 <trinaths> March 12th is the deadline for docs - F release
16:38:46 <trinaths> we have 6 days more.
16:38:49 <ak_dev_> oh okay, sure will commit them
16:39:24 <trinaths> I have update for Santosh (salladi) - Started working on OVN - packet path.
16:39:38 <trinaths> My self giving final touches to document.
16:40:08 <trinaths> for diagrams in ascii, use http://asciiflow.com/
16:40:11 <trinaths> #link http://asciiflow.com/
16:40:23 <trinaths> and paste the content in .rst file for all docs.
16:40:38 <trinaths> Amir-m : Hi, Congratulations.
16:40:50 <Amir-m> Trinaths: Thanks
16:40:56 <trinaths> Amir-m: welcome on board for the Intern project
16:41:10 <ak_dev_> Amir-m: congratulations :-)
16:41:19 <Amir-m> Thank you all
16:41:30 <trinaths> Amir-m: got your lab environment ready ?
16:42:23 <Amir-m> Trinaths: We finally got the server and the new HDD, but the server is missing rails and screws for the hard drive enclosure
16:42:39 <trinaths> Amir-m :)
16:42:58 <Amir-m> the missing parts were ordered, expected to arrive soon.
16:43:23 <trinaths> Amir-m as per the project milestones,
16:43:29 <ak_dev_> Amir-m: oh cool, you are setting up your own lab environment?
16:43:33 <Amir-m> wanted to double check the operating system
16:43:40 <trinaths> #link https://wiki.opnfv.org/pages/viewpage.action?pageId=13210692
16:44:16 <trinaths> Amir-m i think ubuntu 16.04 Desktop must be perfect match
16:44:49 <Amir-m> okay
16:45:18 <trinaths> Amir-m for the benefit of the team, can you introduce yourself and share your studies, hobbies etc ...
16:45:36 <Amir-m> ak_dev_: I think it will only a jump server and possibly a compute node on the same host
16:46:05 <Amir-m> Trinaths: you mean now?
16:46:13 <trinaths> yes.
16:46:13 <ak_dev_> Amir-m: oh, so like one beefed up machine with jumpserver and compute as VMs?
16:46:40 <Amir-m> I'm Amir Mohamad
16:46:41 <trinaths> ak_dev_ I have suggested the same plan to Amir-m
16:46:50 <Amir-m> Originally from EGYPT.
16:47:16 <Amir-m> Currently studying PhD at school of computing Queen's University Canada
16:47:47 <trinaths> ok.
16:47:55 <Amir-m> My main Interest is networking, with other interests in Machine learning
16:48:25 <trinaths> Networking with ML is a trending combination today
16:48:37 <ak_dev_> Amir-m: oh great, so in the future, we can probably collaborate in multiple areas ;-) (networking + ML)
16:48:41 <ak_dev_> trinaths: yeah, true
16:49:03 <trinaths> ak_dev_ yes.
16:49:06 <Amir-m> I'm not an expert in ML, but love to be updated with the leaps hapenning in AI and Deep Learning
16:49:20 <trinaths> Amir-m okay.
16:49:29 <ak_dev_> trinaths: Amir-m : As for the lab you are getting, if amir-m is okay with it, then we can try to set up lbaas, so ovn4nfv can benifit from such a lab
16:50:04 <ak_dev_> not lbaas, sorry, lab-as-a-service
16:50:08 <ak_dev_> thats what i meant
16:50:20 <Amir-m> I'm not sure about the rules here at school of computing
16:50:48 <trinaths> ak_dev_ - Amir-m is getting the server for his intern project needs.
16:50:56 <ak_dev_> Amir-m:  yeah, it was just a thought, we can see later about whats possible
16:51:06 <ak_dev_> trinaths: oh, okay
16:51:09 <trinaths> Also, his server might be in a local internet
16:52:05 <trinaths> Amir-m - the scenario PoC to start is - os-ovn-vmvm-sfc-noha - Single Node - PoC
16:52:39 <trinaths> #link https://github.com/doonhammer/ovs/tree/sfc.v30/ovn
16:52:44 <Amir-m> As an update: I've been reading about the scenarios types and life cycle, the scenario file descriptor, etc
16:52:58 <trinaths> Amir-m nice.
16:53:27 <trinaths> #link http://www.openvswitch.org//support/ovscon2016/7/1400-fourie.pdf
16:53:37 <trinaths> #link https://gist.github.com/voyageur/a26943eced3324b302f1ffede45252bd
16:55:40 <Amir-m> Trinaths: OVN supports only SFC via port-pairs and port-pair groups no NSH?
16:56:55 <trinaths> Amir-m the Proof of Concept (PoC) on Apex Installer
16:57:00 <trinaths> yes no NSH.
16:57:35 <Amir-m> okay
16:58:03 <trinaths> Deploy OVN with Apex E release. and work of SFC with the help from above links,
16:58:21 <trinaths> Document the changes required to enable SFC with Apex installer
16:58:50 <trinaths> prepared required .yaml files on scenario for APEX installer
16:59:10 <trinaths> Since APEX installer uses Openstack TripleO
16:59:38 <trinaths> you may want to understand the TripleO templates to work on integrating the new scenario.
17:00:51 <Amir-m> Okay I will start with TripleO templates waiting for the server missing parts, and will keep you posted
17:01:53 <trinaths> Amir-m okay.
17:02:29 <trinaths> Also, for APEX integration you have work with APEX installer team. since the new scenarios must be tested with OPNFV Jenkins CI
17:02:56 <trinaths> And, Required Functional Tests need to updated in opnfv func-test repo.
17:03:20 <trinaths> if you have any queries, mail the OPNFV tech discuss ML
17:03:27 <trinaths> ak_dev_ is our JOID expert
17:03:29 <Amir-m> okay
17:03:41 <trinaths> we are all there to help you.
17:04:10 <trinaths> #topic K8S functional test requirements - k8s-ovn scenarios.
17:04:27 <trinaths> ak_dev_ I have put a mail to functest and yardstick team
17:05:14 <ak_dev_> trinaths: i have not had much time to look at this topic, but I understand that functest now supports JOID installer, so should be straight forward
17:05:14 <trinaths> and david, But there was no reply from them, I will put another request for know-hows on k8s scenarios testing with func-test and yardstick frameworks.
17:05:15 <ak_dev_> I think
17:05:26 <trinaths> ak_dev_ ok.
17:06:01 <ak_dev_> trinaths: oh okay, once they reply, we will have more info to work with
17:06:01 <trinaths> #action Starting working on scenario - os-ovn-vmvm-sfc-noha - Single Node - PoC - (Amir-m)
17:06:13 <trinaths> ak_dev_ yes.
17:06:21 <trinaths> ak_dev_ is narinder in contact ?
17:06:47 <ak_dev_> no, we the last time I talked to him was when I mailed him about the pod
17:07:17 <trinaths> ok. there was no update on JOID scenarios for F release.
17:07:28 <trinaths> #topic open discussion
17:07:45 <trinaths> #action ak_dev_ - to continue scenario documentation
17:08:00 <trinaths> #action trinaths - submit apex scenario documentation
17:08:22 <trinaths> if you any thing to discuss ? else we can end the meeting.
17:08:48 <Amir-m> Trinaths: is there a resource/doc that explains the flow /steps I should follow in realizing a POC
17:09:25 <trinaths> Amir-m : I have shared the links. above for your reference.
17:09:54 <trinaths> Amir-m let me know you need more info.
17:10:19 <trinaths> if you have simple server, with 8GB RAM,
17:10:29 <trinaths> you can try ovn devstack setup.
17:10:44 <trinaths> and understand OVN
17:11:09 <trinaths> #link https://github.com/doonhammer/ovs/blob/sfc.v30/Documentation/tutorials/ovn-openstack.rst#setting-up-devstack
17:11:31 <ak_dev_> Amir-m: one other thing, maybe you already know
17:11:38 <trinaths> but for using APEX based installation we need a bigger one.
17:12:16 <ak_dev_> but to deploy openstack, you will need atleast around 30 GB ram, an SSD, and a processor with atleast 10 or more cores
17:12:27 <ak_dev_> ^ narinder told me this at the plugfest
17:12:57 <trinaths> ak_dev_ for devstack based simple ovn installation to understand the internals and basics of OVN 8GB RAM is sufficient.
17:13:09 <Amir-m> but the server we've got doesn't have any SSDs
17:13:24 <trinaths> Amir-m you have something to discuss more ?
17:13:38 <ak_dev_> trinaths: yeah, for devstack it is, I was talking about openstack, the whole
17:13:47 <Amir-m> Trinaths: no thanls
17:14:07 <Amir-m> *thanks
17:14:09 <trinaths> ak_dev_ : I did not understand openstack ?
17:14:39 <trinaths> devstack itself simulates the complete openstack environment with all required modules.
17:14:41 <ak_dev_> trinaths: what I meant was that if you want to deploy production openstack via APEX or JOID
17:14:48 <ak_dev_> dev stack will definitely work
17:15:30 <trinaths> ak_dev_ : okay. Agree for APEX/JOID/FUEL installers you must have at least 64 RAM and 1 TB HDD etc ..
17:16:25 <trinaths> we have 15 minutes more .
17:17:09 <ak_dev_> I am done from my side, thank you
17:17:22 <Amir-m> same here thanks
17:17:48 <trinaths> thank you all for attending todays meeting. keep up the good work so far and lets proceed on with our action items.
17:17:50 <trinaths> #endmeeting