13:01:40 <bryan_att> #startmeeting Acumos TSC
13:01:40 <collabot`> Meeting started Mon Apr 23 13:01:40 2018 UTC.  The chair is bryan_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:40 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:40 <collabot`> The meeting name has been set to 'acumos_tsc'
13:01:51 <bryan_att> #info Nat TechM
13:02:37 <bryan_att> #info Bryan Sullivan
13:02:39 <ofer> I'm here
13:03:57 <NokMikeR> #info Michael Rooke, Nokia
13:06:40 <valderrv> #info valderrv
13:08:58 <bryan_att> #topic RollCall
13:09:33 <bryan_att> #info Michael Rookke
13:10:36 <aimeeu> Bryan - can you # chair and add me?
13:12:21 <bryan_att> #chair aimeeu
13:12:21 <collabot`> Current chairs: aimeeu bryan_att
13:13:04 <aimeeu> #topic Review Meeting Minutes
13:13:33 <aimeeu> #info - Scott: we don't have a quorum, so minutes approval is moved to next week
13:13:41 <aimeeu> #topic Agenda Bashing
13:14:17 <aimeeu> #info Scott Nichols (LF) reviews agenda
13:14:29 <aimeeu> #topic Status of Open Action Items
13:15:06 <aimeeu> #info Pantelis is absent, so release naming update will be next week
13:16:36 <aimeeu> #info Etherpad update:  Vanessa gives update: installation in about 2 weeks
13:18:30 <aimeeu> #topic Technical Community Document review
13:19:53 <aimeeu> #info document was created and sent to the TSC private list as a way to reach all the TSC members
13:20:09 <aimeeu> #action Aimee will add document and link to TSC page
13:21:21 <aimeeu> #info Scott  reminds everyone where the Acumos Technical Charter can be found #link https://www.acumos.org/wp-content/uploads/sites/61/2018/03/charter_acumos_mar2018.pdf
13:22:22 <aimeeu> #info discussion on whether to have more review discussion
13:22:43 <aimeeu> #info Paul-Andre Raymond suggests sharing the document with the Community for wider input
13:23:10 <aimeeu> #topic Subcommittees
13:23:26 <aimeeu> #info Bryan summarizes subcommittee kickoff call
13:25:02 <aimeeu> #info Bryan reviews where subcommittee pages are located on the wiki
13:26:01 <aimeeu> #info Scott asks if 8 PDT is the regular time for the Architecture subcommittee meeting; Bryan says no and mentions creating Doodle polls to determine optimal times
13:27:29 <aimeeu> #info Scott asks if there are subcommittee members ; Bryan answers that subcommittee members have not stepped forward and the Community is in the process of organizing membership in those committees
13:27:55 <aimeeu> #topic New Agenda Items
13:28:16 <aimeeu> #topic Open discussion with greater TSC on Release
13:28:48 <aimeeu> #info Bryan mentions that this item originated with Pantels
13:28:57 <aimeeu> #info correction: Pantelis
13:30:20 <aimeeu> #info Bryan shows summary of subcommittee kickoff meeting on Architecture page #link https://wiki.acumos.org/display/AR/Meetings
13:30:44 <aimeeu> #info discussion on need to formalize subcommittee mandates and rolls
13:31:53 <aimeeu> #info Scott observes that subcommittee names should be focused on end user experience
13:33:22 <aimeeu> #info Bryan: for Product subcommitte: what do we want the platform to be; Architecture: determines architecture; Product and Architecture committees work together to define release plan
13:33:52 <aimeeu> #info Scott; where are we with formation of the committees; does TSC have requests?
13:34:49 <aimeeu> #info Bryan: review the subcommittee information on the wiki and Community members propose people from their companies to be active subcommittee members
13:35:17 <aimeeu> #link https://wiki.acumos.org/display/TSC/Subcommittees  charters from TSC
13:35:43 <aimeeu> #link https://wiki.acumos.org/display/ACCOM  Acumos.org/Product subcommittee
13:35:59 <aimeeu> #link https://wiki.acumos.org/display/AR  Architecture subcommittee
13:36:12 <aimeeu> #link https://wiki.acumos.org/display/SEC  Security subcommittee
13:36:33 <aimeeu> #topic Update to Project/Repo proposed mapping
13:36:55 <aimeeu> #link https://wiki.acumos.org/display/AC/Acumos+Architecture+Mapping+to+Repos+Jira+etc
13:37:38 <aimeeu> #info Bryan summarizes the need to correctly map the current repos into the approved projects
13:39:17 <aimeeu> #info Bryan: the Community needs to understand the process for shifting component repos between projects
13:39:55 <aimeeu> #info Bryan: the Community needs to have a team approach to finalizing component repos into the Projects
13:41:09 <aimeeu> #info Nat: offline discussion and then a separate meeting to realign and finalize the repos into Projects
13:42:26 <aimeeu> #info Bryan volunteers to lead effort to finalize repos; asks for  which companies will participate in addtion to AT&T and TM
13:42:58 <aimeeu> #action Bryan will organize additional meeting to discuss repos/Projects finalization
13:43:35 <aimeeu> #topic License and Security Check on Models
13:44:41 <aimeeu> #info Bryan: the Community needs TSC input on whether models contributed to the Acumos marketplace need to be scanned for vulnerabilities and also have an appropriate license
13:46:09 <aimeeu> #info Scott: when you look at a model contributed to the platform, what essentially are we looking at? code? documentation?
13:46:15 <aimeeu> #info Bryan: both
13:46:59 <aimeeu> #info Bryan shows the contents of a model downloaded from the portal marketplace
13:47:31 <aimeeu> #info the model could be a combo of code, data, and docs
13:49:27 <aimeeu> #info Scott:  concern with license models; code would fall under Apache 2.0; docs would fall under Creative Commons (see Technical Charter); in other cases, the TSC can approve alternate licenses; approach how models are covered by first looking at the Technical Charter
13:50:06 <aimeeu> #info Ofer: +1 to addressing licensing of contributed models; should be discussed  by the Product subcommittee
13:51:16 <aimeeu> #info  Bryan: assumption that Technical Charter applied to code contributed to the platform, not to models, and asks for clarifictiaon
13:51:54 <aimeeu> #info Scott: applies to models contributed to the public marketplace (the LF instance)
13:53:09 <aimeeu> #info Bryan: are the models that are published to the LF instance are subject to the licenses in the Technical Charter?
13:54:23 <aimeeu> #info that is Scott's understanding; again, if the TSC thinks that's not the right outcome, Community needs to work together to resolve
13:55:40 <aimeeu> #info Paul-Andre: different understanding of contributed models: pieces of code contributed by users may be open source or have a different license; may be imported from federated instance; the user model is very different than contributing code to the platform; point: needs to be more debate on this subject
13:55:47 <aimeeu> #info: Ofer +1
13:56:35 <aimeeu> #info Scott asks how to move conversation forward
13:57:02 <aimeeu> #info Paul-Andre asks if this is for the Product committee to discuss
13:57:30 <aimeeu> #info consensus is to have this discussed in the Product committee
13:58:15 <aimeeu> #info Bryan: do we expect this ecosystem to take steps to NOT propagate malware in models?
13:59:00 <aimeeu> #info Bryan: Product committee should also discuss safety of contributed models
13:59:43 <aimeeu> #action Product committee should discuss the above items
14:00:05 <aimeeu> #topic Planning for Next Meeting
14:00:27 <aimeeu> #info mapping of project to release 1 - this can be discussed by the Product committee
14:01:00 <aimeeu> #info question on if release plan for release 1 has been decided?
14:01:21 <aimeeu> #info this has not occurred yet; this will be discussed in the Product committee
14:01:43 <aimeeu> #info Jamil: asks when the release date is?
14:02:02 <aimeeu> #info release date is scheduled for Nov 7, 2018
14:02:16 <aimeeu> #info Jamil: when will a release plan be finalized?
14:02:58 <aimeeu> #info Community is still at the stage of soliciting input for the next release
14:03:45 <aimeeu> #info we should come to an agreement by next week what components will in release 1
14:04:36 <aimeeu> info: Jamil proposes existing structure/solution for release 1
14:05:08 <aimeeu> #endmeeting