15:08:25 <bryan_att> #startmeeting Acumos OA&M Project
15:08:25 <collabot_> Meeting started Thu Jun 21 15:08:25 2018 UTC.  The chair is bryan_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:08:25 <collabot_> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:08:25 <collabot_> The meeting name has been set to 'acumos_oa_m_project'
15:08:36 <bryan_att> #chairs bryan_att, aimeeu
15:09:50 <aimeeu> #info attendees  Bryan, Krish, Nat, Parichay
15:10:18 <aimeeu> #topic
15:10:27 <aimeeu> #topic Meeting Time
15:11:14 <aimeeu> #info conflicts, so Bryan will send out a doodle poll to determine optimal meeting time
15:12:00 <aimeeu> #topic Agenda Bashing
15:12:20 <aimeeu> #info #link https://wiki.acumos.org/display/OAM/Meetings
15:12:52 <aimeeu> #info Krish: do we need any other repos? or will the existing 2 repos be sufficient?
15:14:02 <aimeeu> #info Bryan: system-integration will be for platform deployment, platform-oam will be for associated tools such as logging
15:15:31 <aimeeu> #info Krish: should reports and/or a reporting tool be part of platform-oam
15:15:49 <aimeeu> #info Parichay: backup and disaster recovery should be part of platform-oam
15:17:02 <aimeeu> #info Bryan: good scope; we will evolve as more items are incoporated
15:17:12 <aimeeu> #topic Jira Items
15:17:54 <aimeeu> #info Bryan shows list of not-closed Jira items for system-integration and platform-oam
15:20:33 <aimeeu> #info Krish: let's focus on prioritizing - let's focus on the High items
15:21:11 <aimeeu> #info Vishnu (vrov) joined the meeting
15:21:59 <aimeeu> #info #link https://jira.acumos.org/browse/ACUMOS-1043
15:23:35 <aimeeu> #info this encompasses back end; different companies may wish to use different DBs; we should provide different options, not exclude, and let operator decide what back-end components to use
15:24:27 <aimeeu> #info Bryan: AIO script has ability to specify pre-existing components, such as database, so database wouldn't be installed
15:24:46 <aimeeu> #info AIO script lacks upgrade/migration
15:25:40 <aimeeu> #info Krish: Parichay - what type of storage do we support, how do we specify different storage types - we need to work through and create a good solution
15:26:16 <aimeeu> #info Bryan: k8s  - important to have data live outside the Docker containers
15:26:31 <aimeeu> #info persistent volumes
15:27:10 <aimeeu> #info Krish: some platforms, like Azure, provide load balancing; Acumos needs to be more generic in how it uses a load balancer
15:28:27 <aimeeu> #info Bryan: need to provide clear guidance; not all load balancers support Kong - need to solve this reverse proxy with different load balancers
15:29:18 <aimeeu> #info Krish: Parichay has been working on kong with k8s
15:29:51 <aimeeu> #info Bryan: problem with kong in k8s cluster is that you can't expose 8080 or 443
15:29:57 <aimeeu> #info Bryan explains
15:30:24 <aimeeu> #info Krish - we've been working on this -  need to sync up
15:30:43 <aimeeu> #info Krish provides details
15:31:54 <aimeeu> #info discussion between Bryan and Krish; implication is that the installation must have a load-balancer
15:33:27 <aimeeu> #info Krish: goal is to provide complete k8s with nothing running outside (on docker ce for example)
15:34:42 <aimeeu> #info Kirsh: for k8s, should we pick a single environment (Azure, bare metal, etc)  and then expand to other environments?
15:34:50 <aimeeu> #undo
15:35:03 <aimeeu> #info Krish: for k8s, should we pick a single environment (Azure, bare metal, etc)  and then expand to other environments?
15:35:44 <aimeeu> #info Bryan: k8s deployment of the platform should not differ based on environment
15:36:14 <aimeeu> #info standing up a load-balancer may be environment dependent but that's out of scope
15:37:01 <aimeeu> #info Krish points out that an environment such as Azure provides a lot already set up compared to bare metal
15:37:52 <aimeeu> #info Bryan: we should be pure cloud native - doesn't matter where it's deployed, process should be the same
15:38:09 <aimeeu> #info Bryan: we will work collaboratively to address these issues
15:38:34 <aimeeu> #info https://jira.acumos.org/browse/ACUMOS-1091
15:38:40 <aimeeu> #undo
15:38:51 <aimeeu> #info #link https://jira.acumos.org/browse/ACUMOS-1091
15:39:29 <aimeeu> #info Krish: we need get some of the ONAP ELK people to take an active role in Acumos
15:39:45 <aimeeu> #info Ken: is this Sponden's area?
15:40:02 <aimeeu> #info Ken Kristiansen joined the meeting
15:40:54 <aimeeu> #info Krish: currently under platform-oam but if it grows, it could be split into a separate project
15:41:18 <aimeeu> #info consensus that Sponden should be involved
15:42:02 <aimeeu> #info Parichay has done a lot of work in this ELK area
15:42:34 <aimeeu> #info Ken: Sponden has been leading the effort between ONAP and Acumos ELK effort
15:43:17 <aimeeu> #info Ken: recommends Bryan have a call with Sponden
15:43:51 <aimeeu> #info Bryan will reach out to Sponden to understand what he's done and how he can help drive ELK in Acumos
15:46:10 <aimeeu> #info Krish: missing from Jira is functionality to query database to build reports; we need to discuss this further
15:46:52 <aimeeu> #info Krish: metrics examples: how many people logged in, how many models uploaded, etc - reports that business managers want
15:47:40 <aimeeu> #info Krish: need to be clear that business metrics are needed and that they aren't based on physical resources
15:48:49 <aimeeu> #info need to enhance logging capabilities to capture what is currently missing, such as IP addresses of users
15:49:04 <aimeeu> #info access logs of client IP addresses
15:50:21 <aimeeu> #info Ken: Parichay is already working on these initiatives and is almost done
15:51:22 <aimeeu> #info Ken: pulling data directly from database is only temporary until a solution is found
15:51:40 <aimeeu> #info Krish: need to set log retention
15:51:55 <aimeeu> #info need to give users choice of retention period
15:53:22 <aimeeu> #info Bryan asks for help prioritizing Jira tickets
15:54:07 <aimeeu> #topic Who Will Focus on What Areas
15:54:17 <aimeeu> #info Bryan asks for who will focus on what
15:54:27 <aimeeu> #info Logging: Parichay
15:56:22 <aimeeu> #info Bryan/Krish: Parichay should be made a committer in system-integration
15:58:06 <aimeeu> #info Question about Amit Mishra's continuing involvement - he will be back the first week in July
16:00:12 <aimeeu> #action Bryan will sent out email about meeting times
16:02:00 <aimeeu> #endmeeting
16:02:16 <bryan_att> #endmeeting