13:04:19 <aimeeu> #startmeeting TSC Weekly Meeting
13:04:19 <collabot> Meeting started Mon Jul 23 13:04:19 2018 UTC.  The chair is aimeeu. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:04:19 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:04:19 <collabot> The meeting name has been set to 'tsc_weekly_meeting'
13:04:27 <aimeeu> #topic Roll Call
13:06:17 <aimeeu> #info TSC Attendees: Ofer (Amdocs), Jack (AT&T), Pantelis (Nokia), Yuxuan (Huawei), Nat (TechM), GuangCong (ZTE)
13:06:53 <aimeeu> #chair bryan_att
13:06:53 <collabot> Current chairs: aimeeu bryan_att
13:07:59 <aimeeu> #topic Review and Agree to Minutes of Previous Meetings
13:08:40 <aimeeu> #info Jack would like to postpone minutes approval to next week
13:08:54 <aimeeu> #topic Agenda Bashing
13:09:34 <aimeeu> #info Nat brings up extending API Freeze (M3) deadline by a week; this will be covered in 7C
13:10:39 <aimeeu> #info Jamil would like to discuss meeting with Microsoft
13:10:57 <aimeeu> #topic Status of Open Action Items
13:12:11 <aimeeu> #info Update from Outreach Committee: Annie sent out a survey last week asking who will be attending Open Source Summit North America to see if TSC meeting can held there
13:12:37 <aimeeu> #info Ofer will be attending; possibly TechM
13:13:35 <aimeeu> #topic Committee Reports
13:14:00 <aimeeu> #info Community Committee: frozen set of requirements for Athena
13:14:47 <aimeeu> #info Ofer: #link https://wiki.acumos.org/display/ACCOM/Meetings
13:16:23 <aimeeu> #info Name for the next release discussed
13:16:43 <aimeeu> #info Ofer motion to call the next release 'Boreas'
13:16:50 <aimeeu> #info Nat seconds
13:17:51 <aimeeu> #info TSC vote on naming the next release Boreas
13:18:12 <aimeeu> #info name passes by TSC voice vote
13:18:53 <aimeeu> #info discussion on names using only Greek gods or expanding to other mythologies
13:19:38 <aimeeu> #info Pantelis: expand to other mythologies
13:20:02 <aimeeu> #info motion to adopt naming convention to be mythical gods, not just Greek gods (Pantelis)
13:20:31 <aimeeu> #info motion seconded; TSC voice vote to expand names from all mythologies
13:21:22 <aimeeu> #info User Stories for next release; ongoing discussion in Community Committee meeting
13:22:14 <aimeeu> #info Ofer discusses items on the list #link https://wiki.acumos.org/display/ACCOM/Meetings under '7/17/18' Meeting
13:28:53 <aimeeu> #info Jamil raises concerns about integrating model creation tools such as Rapid Miner, Jupyter, etc - be aware of licensing issues
13:31:28 <aimeeu> #info Architecture Committee: past 2 weeks the Committee has been reviewing functionality, good progress
13:32:09 <aimeeu> #info Need Nat to report on which projects still need to document APIs
13:32:57 <aimeeu> #info Detailed reviews with AT&T CMLP team for integrating functionality into Athena release
13:33:23 <aimeeu> #info Bring CMLP data sets info Training project
13:35:24 <aimeeu> #info AT&T CMLP (Common Machine Learning Platform) is an internal AT&T project; it is an integrated environment of internally developed code as well as open source code, including Acumos; CMLP will be contributing code  to the Acumos project
13:37:41 <aimeeu> #info Anwar: more items: deploy fix to Federation targeted for first week in August; reviewed OA&M module notification - work for Portal team, need feedback
13:39:50 <bryan_att> #info 7/17 Security Committee minutes are at https://wiki.acumos.org/display/SEC/Meetings
13:40:19 <aimeeu> #info Security Committee summary: see link above; best practices discussed
13:41:02 <aimeeu> #info Nexus-IQ - would like to use this tool, which is part of LF infrastructure; working on process for people to follow
13:41:22 <aimeeu> #info platform security hardening is an ongoing discussion item
13:42:10 <aimeeu> #topic PTL reports or blockers
13:43:14 <aimeeu> #info Nat: most PTLs are behind at this point
13:43:37 <aimeeu> #info PTLs were asked to mark items in Jira that are in jeopardy
13:44:03 <aimeeu> #info biggest blocker/risk is lack of development resources
13:45:13 <aimeeu> #info Jack asks if the RM/PTL report should be before the SubCommittee reports
13:46:39 <aimeeu> #info Nat suggests putting the RM current release report first during active development phases
13:47:58 <aimeeu> #info Jack: need to establish practice/structure for Release Management review to be given to TSC weekly meeting
13:48:58 <aimeeu> #info Jack is looking for breakdown of which requirements are being delivered in this release and status of development cycle
13:49:30 <aimeeu> #action Jack will help Nat contact PTLs for list of finalized list of requirements for this release
13:51:22 <aimeeu> #info Manoop: checklists have been created for M1 and M2 but PTLs were not asked to fill those out; should we ask PTLs to fill those out? Also, there is a wiki template that can be used to display overall status for each release
13:52:17 <aimeeu> #info Nat: suggests leaving M1, M2 checklists for now and incorporate in next release
13:52:49 <aimeeu> #topic New Agenda Items
13:53:12 <aimeeu> #topic Projects without PTLs
13:53:30 <aimeeu> #info still need PTLs to lead 2 projects: Licensing and Deployment
13:54:31 <aimeeu> #info Jack asks for additional companies to come forward and lead those projects
13:55:00 <aimeeu> #info Bryan Sullivan is acting Deployment PTL and will help anyone who would like to take over
13:55:10 <aimeeu> #topic Athena Release Planning
13:55:20 <aimeeu> #info checklists are still a work in progress
13:55:35 <aimeeu> #topic M2 and M3 milestones
13:56:06 <aimeeu> #info need to clearly identify deliverables in M2; we are late in documenting APIs for M3
13:56:36 <aimeeu> #info reason is Release Manager role was filled late; need to drive discussion around M2 and M3
13:57:34 <aimeeu> #info Nat: move M3 to 7/24; M2 was 7/18 but still not complete - should be completed this week
13:57:53 <aimeeu> #topic Survey of standing up instances with member companies
13:58:10 <aimeeu> #info which member companies will stand up instances of Acumos and share models?
13:59:21 <aimeeu> #info Jack: asks for all participating companies to join discussions on standing up local instances
13:59:58 <aimeeu> #info some models from Dev Challenge may be shared
14:00:47 <aimeeu> #info #action Jack  will send out email  and collect data on which companies will stand up instances
14:01:33 <aimeeu> #topic Shared Test Environment
14:02:24 <aimeeu> #info Scott Nichols: $500/month bandwidth; $2-2500/month infra; $33000/yr expense - need to go to governing board
14:02:43 <aimeeu> #info may need to leverage Community
14:03:39 <aimeeu> #info Jack: would like to establish Community labs as alternative or parallel effort to Linux Foundation lab; please reach out to Jack Murray (AT&T) if interested
14:04:58 <aimeeu> #info Need to create wiki content about lab environment; add to TSC agenda for next week
14:06:09 <aimeeu> #info Jack: please add lab infra details to Infrastructure space on wiki (Ken and Chris, AT&T)
14:06:44 <aimeeu> #endmeeting