14:17:29 <talasila> #startmeeting architecture
14:17:29 <collabot> Meeting started Thu Aug  2 14:17:29 2018 UTC.  The chair is talasila. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:17:29 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:17:29 <collabot> The meeting name has been set to 'architecture'
14:17:47 <talasila> #chair bryan_att
14:17:47 <collabot> Current chairs: bryan_att talasila
14:18:51 <talasila> Guy: started discussing the agenda topic "ML Model Interchange Formats support and impacts, ONNX, PFA, PMML".
14:24:31 <talasila> Guy: ONNX is with Apache or MIT license, so should not be an issue from license perspective to include in Acumos.
14:26:55 <talasila> Kazi: ONNX might be only for neural nets. Does it support non-neural nets?;
14:27:24 <talasila> Guy: goal is to incorporate ONNX and onboard models with supporting various formats.
14:28:28 <talasila> #info ONNX is not LF project
14:31:09 <talasila> Anwar: we have to do more evaluation on ONNX and find some ideas on how to integrate in Acumos. So that we can bring in various types of models into Acumos without building support to all different types.
14:32:29 <talasila> Anwar: CMLP support PMML and PFA. Any review on ONNX by CMLP team?
14:32:52 <talasila> Adi: There is no demand for ONNX internally, so did not look at it.
14:33:16 <talasila> Adi: PFA support is upcoming in CMLP.
14:34:22 <talasila> #action Nat to come up with plan for work item started on ONNX integration through CMLP side.
14:35:36 <talasila> Adi: ONNX is not planned right now with CMLP team. Interesting to look into this.
14:36:30 <talasila> #idea definitely put new features into open source gerrit repo rather than as internal work.
14:37:39 <talasila> #action form a small team (Guy, Adi, Kazi etc...) that can work on ONNX integration
14:39:28 <talasila> Nat: updates on release management from Architecture impacts
14:39:45 <talasila> Nat: Log standards will be discussed in OAM meeting today
14:42:01 <talasila> Chris Lott: Most part CDS is ignorant on model formats, so ONNX impact should be less on CDS.
14:44:47 <talasila> Mukesh: started discussing on agenda topic "Portal's personalized user experience with a theme like IOT, wireless, mobile"
14:47:07 <talasila> #action Mukesh to schedule a meeting with Jack on the theme based user experience requirements. #link https://jira.acumos.org/browse/ACUMOS-1431
14:47:59 <talasila> Mukesh: suggested to replace any existing requirement, if 1431 is the highest priority.
14:49:10 <talasila> Mukesh: local federation requirement; kubernetes deployment from Portal perspective; workflow changes; onboarding changes from common services; loggin changes are primary requirements that should be considered to replace with the 1431.
14:50:00 <talasila> Anwar: Are the federation changes or defects taken care?
14:50:14 <talasila> Mukesh: need to check with federation team
14:51:12 <talasila> Chris Lott: federation should be ready today with committed changes; no plan to extend federation to support CMS
14:51:57 <talasila> Anwar: everything work with federation?
14:52:21 <talasila> Chris lott: not everything; items in CMS will not fedaration
14:53:12 <talasila> Bryan: Everything otherthan generated artifacts are in CMS.
14:53:31 <talasila> #idea but these files must be in Nexus not in CMS or CDS
14:54:09 <talasila> Anwar: are there any gaps to federate the models?
14:54:25 <talasila> Chris Lott: Yes, there are gaps in federation of some model artifacts.
14:55:03 <talasila> #action Mukesh to discuss with Chris L on the federation gaps impacting Portal.
14:56:15 <talasila> Mukesh: concerns on storing artifacts on Nexus and accessing them for search from Portal.
14:57:43 <talasila> #action lets decide by Monday on the federation gaps
14:58:28 <talasila> Mukesh: lots of changes on UI, if this has to be suported
15:01:53 <talasila> #action update the architecture diagram for Athena release
15:01:56 <talasila> #endmeeting