14:04:49 <talasila> #startmeeting architecture
14:04:49 <collabot> Meeting started Thu Aug 9 14:04:49 2018 UTC. The chair is talasila. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:49 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:04:49 <collabot> The meeting name has been set to 'architecture'
14:05:02 <talasila> #chair bryan_att
14:05:02 <collabot> Current chairs: bryan_att talasila
14:07:36 <talasila> Chris L: Talks about status on the current federation architecture and its on-going changes/impacts on Portal, CDS and Federation modules.
14:12:55 <talasila> Manoop: Suggested to keep the architecture changes switching from CMS to Nexus for saving the model artifacts.
14:13:10 <talasila> Manoop: Update the Portal architecture at https://wiki.acumos.org/display/AC/Acumos+Portal+Front+End%2C+Back+End%2C+and+Catalog+Architecture
14:13:28 <talasila> Bryan: where are the apis documented for these changes?
14:13:44 <talasila> Chris: Changes are synched in the swagger APIs.
14:14:40 <talasila> Chris: Highlevel change - The content of the model description goes into CDS and the additional attached files to model goes into Nexus (rather than into CMS).
14:15:26 <talasila> Bryan: Previously we used to search for the description of models and the artifacts, how is it achieved with new changes?
14:15:55 <talasila> Chris: Only descriptions will be searched which are saved in CDS, but not able to search on the artifacts saved in Nexus.
14:16:27 <talasila> Anand: Name, metadata will also be searchable.
14:17:41 <talasila> Chris: New topic discussion started about new DesignStudio changes.
14:18:28 <talasila> Chris: Mainly focused on the Probe usage as part of the DesignStudio(DS)
14:19:12 <talasila> #action Chris L to update the architecture changes on federation and CDS.
14:19:56 <talasila> #topic Updates on DesignStudio from Kazi to review the architecture changes
14:20:54 <talasila> Kazi: New changes on splitter and collator in DS are shown on the screen.
14:37:42 <talasila> Manoop: CMLP dataset management integration into DS to bring in DataSources. What is the architecture impact?
14:38:05 <talasila> #action Kazi to review the architecture impact in the next meeting
14:38:28 <talasila> #action Kazi to update the logging changes in DS in the next meeting
14:39:21 <talasila> Adi: status on CMLP - Acumos integration - team is working on the code refactoring analysis.
14:39:54 <talasila> Anwar: plan for the architecture road map for the CMLP - Acumos integration
14:40:31 <talasila> Anwar: Architecture updates from release manager
14:41:15 <talasila> Nat: Preparing the wiki page to show the overall update as dashboard; raised risks on the deployment and federation side;
14:41:31 <talasila> Anwar: ETA for federation changes is next Tuesday
14:42:32 <talasila> Nat: Needs discussion on private federation with Serban in the next meeting
14:43:40 <talasila> Manoop: what is the consensus on logging APIs by PTLs?
14:44:00 <talasila> #action PTLs to provide +1 or concerns
14:44:38 <talasila> Mukesh: today there is meeting to discuss the pending concerns on logging.
14:45:08 <talasila> #topic Acumos AI Model (AIM) Management
14:45:20 <talasila> Jamil: started presenting AIM slides
15:05:10 <talasila> #endmeeting