13:06:11 <aimeeu> #startmeeting Acumos TSC Weekly Meeting
13:06:11 <collabot`> Meeting started Mon Aug 27 13:06:11 2018 UTC.  The chair is aimeeu. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:06:11 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:06:11 <collabot`> The meeting name has been set to 'acumos_tsc_weekly_meeting'
13:06:46 <aimeeu> #topic Roll Call
13:08:43 <aimeeu> #info attendees Daniel Sela (Amdocs), Jack Murray (AT&T), Zheng YuXuan (Huawei), Pantelis Monogioudis (Nokia), Nat Subramanian (TechM), Liu GuangCong (ZTE)
13:09:06 <aimeeu> #topic Previous Minutes Approval
13:09:50 <aimeeu> #info pushed to next meeting
13:09:55 <aimeeu> #topic Agenda Bashing
13:12:15 <aimeeu> #info new item: next week is a holiday in the US so no meeting next week, 3 Sept. The next TSC meeting will be 10 Sept 2018.
13:12:55 <aimeeu> #action aimeeu will send email to TSC list
13:13:06 <aimeeu> #topic Standing Agenda ITems
13:13:25 <aimeeu> #topic Marketing and Outreach
13:14:08 <aimeeu> #info update on Acumos activity at the Open Source Summit North America in Vancouver; over 100 registrants, Bryan Sullivan will be presenting
13:15:24 <aimeeu> #Topic Release Manager Update
13:16:21 <aimeeu> #info Sprint 3 progress completed 24 August;  Jira items 19 closed, 13 delivered, 6 submitted
13:16:48 <aimeeu> #info 7 user stories moved to Sprint 4
13:18:18 <aimeeu> #info Overall progress; code freeze in 3 weeks; 4 user stories are at risk; 44% of requirements are still pending and have to be completed in Sprint 4
13:18:59 <aimeeu> #info Nat shares graphs and summaries
13:19:17 <aimeeu> #info Nat notes that these reports are posted on the PTL wiki page
13:19:36 <aimeeu> #link https://wiki.acumos.org/display/REL/PTL+Meetings
13:19:54 <aimeeu> #info Nat shares Boreas Release calendar
13:20:22 <aimeeu> #link https://wiki.acumos.org/display/REL/Boreas+Release+Draft+Timeline
13:21:37 <aimeeu> #info Nat and Jack encourage feedback on Boreas release timeline
13:23:25 <aimeeu> #info Jack encourages more involvement from all interested parties; Boreas release planning will be discussed in the coming weeks and months
13:26:02 <aimeeu> #info Nat requests PTLs to please keep Jira updated, please be on the lookout for email from Deepti (PM)
13:26:26 <aimeeu> #info Anwar: which component has the most remaining open items for Athena?
13:26:36 <aimeeu> #info Nat: Portal has the most
13:27:31 <aimeeu> #info a lot of functionality in other components impacts the Portal, so Portal has to wait for other components
13:28:00 <aimeeu> #info Anwar: asks if the plan was to have so many items in Sprint 4
13:28:20 <aimeeu> #info Nat: due to a late start, many items were pushed back
13:29:08 <aimeeu> #info Jack: going forward, we need to plan a bit better, break up user stories across multiple sprints
13:30:00 <aimeeu> #info Nat: Athena is a learning experience; many lessons learned that will be applied going forward; also, new requirements came in late in the development cycle
13:30:37 <aimeeu> #info Anwar asks for a review in the next PTL call to determine items that cannot be delivered in Athena
13:32:45 <aimeeu> #info The next TSC meeting will be the week of the code freeze, so important for Release Manager to continue moving forward with PTLs
13:34:22 <aimeeu> #topic PTL reports
13:34:57 <aimeeu> #info no PTLs have input at this time
13:35:40 <aimeeu> #info Jack reiterates this is the time for PTLs to bring any issues to the TSC
13:36:42 <aimeeu> #info Guy Jacobson:  Sonar doesn't pick up PowerMockito tests, so how to deal with Sonar not counting tests in its unit test coverage calculation
13:37:13 <aimeeu> #info Who is the right person to look into this Sonar issue?
13:37:38 <aimeeu> #info Jack asks Chris Lott to track this item so we can discuss who should own this issue
13:38:00 <aimeeu> #action Chris Lott will track the Sonar/Powermockito issue
13:38:14 <aimeeu> #topic Test & Integration Planning
13:39:18 <aimeeu> #info Chris Lott is standing in for Ken Kristiansen
13:39:32 <aimeeu> #info Chris reads out the testing report
13:40:31 <aimeeu> #info  TLAB test set up is in progress and on target to be completed during Test Sprint 3
13:41:06 <aimeeu> #info code coverage: some components are above 40%, a few remain significantly below
13:41:40 <aimeeu> #info Sonar code coverage is not accurate due to the open source code used in Portal
13:42:11 <aimeeu> #info Jack asks for follow up with teams who are below the 40%
13:42:41 <aimeeu> #info Jacks asks for the list or a link to be sent to the TSC mailing list
13:42:53 <aimeeu> #action Chris will send the email
13:44:05 <aimeeu> #topic Community Subcommittee
13:45:09 <aimeeu> #info Ofer is on vacation
13:45:17 <aimeeu> #topic Architecture Subcommittee
13:45:33 <aimeeu> #info primarily focusing on B release
13:46:19 <aimeeu> #info working with Community committee on Onyx requirements
13:46:42 <aimeeu> #info discussions on white box deployment; working with Deployment team on where changes need to be made
13:47:29 <aimeeu> #info working on architecture and documentation updates
13:47:36 <aimeeu> #info component reviews start this week
13:48:05 <aimeeu> #info Bryan created a Jira ticket for white box deployment
13:48:27 <aimeeu> #info Anwar: Licensing piece has not yet made it to the Architecture committee
13:48:49 <aimeeu> #info Jack emphasizes that licensing needs to be a focus point in Boreas
13:48:56 <bryan_att> #info On whitebox support: https://jira.acumos.org/browse/ACUMOS-1640
13:49:16 <aimeeu> #topic Security Subcomittee
13:49:40 <aimeeu> #info getting ready to start analyzing Nexus IQ reports for platform code
13:50:01 <aimeeu> #info will be creating Jira tickets for PTLs to address critical issues
13:50:43 <aimeeu> #info model scanning: trying to gather community needs and practices through both Security and Community committees
13:51:47 <aimeeu> #topic New Agenda Items
13:52:00 <aimeeu> #topic Training project scope and name change
13:52:29 <aimeeu> #info Pantelis agrees to postpone to the next TSC meeting (Pantelis has been on vacation)
13:52:58 <aimeeu> #topic Planning for next meeting
13:53:29 <aimeeu> #info reminder: next meeting is 10 Sept 2018; focus will be dev cycle approaching code freeze
13:54:47 <aimeeu> #info discussion will take place on what the release means - branch and trunk management
13:55:06 <aimeeu> #info more discussion will take place around Boreas release planning
13:56:18 <aimeeu> #info Jack asks everyone to review Boreas timeline for country-specific holidays as well as anything else that could impact the schedule
13:56:43 <aimeeu> #topic Any other business
13:57:01 <aimeeu> #info Jamil (Orange) asks if there will be an Acumos planning event after the release
13:57:25 <aimeeu> #info Jack: needs further discussion
13:57:38 <aimeeu> #info discussion has been started with LF
13:58:02 <aimeeu> #info Scott: Acumos Day is planned for 7 Nov
13:58:43 <aimeeu> #info Jack: add discussion around an Acumos face to face event to the 10 Sept TSC agenda
14:00:34 <aimeeu> #endmeeting