14:06:56 <talasila> #startmeeting architecture
14:06:56 <collabot> Meeting started Thu Aug 30 14:06:56 2018 UTC.  The chair is talasila. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:56 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:06:56 <collabot> The meeting name has been set to 'architecture'
14:08:11 <talasila> #chair farheen
14:08:11 <collabot> Current chairs: farheen talasila
14:09:04 <farheen> Ofer insure Michelle is on the Tuesday call
14:11:22 <farheen> @bryan_att: Shared the docs.acumos.org deployment diagram.
14:11:22 <collabot> farheen: Error: "bryan_att:" is not a valid command.
14:13:24 <talasila> bryan_att discussed #link https://docs.acumos.org/en/latest/submodules/kubernetes-client/docs/deploy-in-private-k8s.html#architecture
14:20:33 <farheen> bryan_att work with Chris Lott for model connector.
14:21:12 <farheen> How is the solution zip file created?  Kubernetes client will create the zip file on demand and is not stored anywhere in the portal
14:21:51 <farheen> On what action is it triggered?  You pick a solution and deploy to private kubernetes that will bring up click here to download the solution package.
14:22:28 <farheen> When the user clicks that action the zip file is downloaded in the users web browser
14:22:49 <farheen> Can we deploy a single model with the same process?
14:23:11 <farheen> Exact same process but only deploys .yml using kubectl.
14:24:35 <farheen> single model single solution.yml file is fronted by a single kubernetes service.
14:24:45 <farheen> Did we talk through aspects of scalability?
14:28:25 <farheen> We can scale models.  It is assumed there will be one replica of each ms.
14:29:03 <farheen> weakness in design.  What if there is a kubernetes cluster that I am not an admin for?
14:30:30 <farheen> it would not require any admin access.  You are getting probe from docker registr.
14:30:58 <farheen> bryan_att will add another docker container in enginex.
14:32:16 <farheen> Where is the design document?
14:33:12 <farheen> #action farheen get the power point slide deck from mukesh and put it on docs.acumos.org
14:34:13 <farheen> #action entire team please keep documentation up to date.  Currently it is out of date.
14:35:42 <farheen> We are going to accomodate the current design on the deployment calls and design studio calls
14:36:02 <farheen> Get Chris Lott involved he is the dev lead on that
14:36:30 <talasila> #action Mukesh to update docs.acumos.org about nginx design change in probe.
14:36:59 <farheen> Architecture Design Studio Athena Release
14:37:57 <farheen> Kazi Farooqui (ATT) shared a power point deck that will placed under the ds
14:38:05 <farheen> on the wiki
14:39:01 <farheen> We found that we have a gap.  We didnt support graph topology.  In Athena we will have this support
14:40:08 <farheen> The major architecture changes will be support for split and join and support for databroker
14:40:50 <farheen> We will support both file and data base data brokers
14:42:57 <farheen> If a new developer wants to join where would the developer go for the design studio athena release?
14:45:21 <farheen> #action kazi put the architecture files in RST in documentation.
14:46:46 <farheen> #action kazi update the design studio architecture deck for the athena release.
14:48:51 <farheen> #action kazi work with aimeeu or farheen to update the wiki.  Prepare for next weeks call.
14:49:14 <farheen> Portal Team will provide the latest changes with core architecture next week.
14:49:40 <farheen> Going forward please let the team know prior to the call to modify the agenda.
14:50:12 <farheen> Portal Team: API was published some time back.  Portal IOT changes major functionality.
14:50:21 <farheen> We are introducing the workflow.
14:50:49 <farheen> Account verification on/off link.
14:51:12 <farheen> We replaced the jwtoken with a smaller.
14:52:00 <farheen> #action mukesh get approval.  We need a programatic solution.
14:53:08 <farheen> white box deployment is in progress.
14:53:56 <farheen> Deployment team discussed deployment to white box.  We are pursuing that design if it is a deployment to a local environment
14:54:21 <farheen> Portal team will deliver cms in nexus to move artifacts with federation
14:55:01 <farheen> Release Manager Arch updates
14:55:47 <farheen> Chris Lott is working on workflow1 and mentioned that he may be able to complete it but portal team needs time.
14:56:21 <farheen> Support from CDS.  Holding back merge to master until next Tuesday.
14:56:34 <farheen> This involves the dbase upgrade to 1.18.
14:56:52 <farheen> this is a major change from portal perspective.
14:57:33 <farheen> 14 out of 18 issue are still open.  We will ciculate an email alert.
14:58:00 <farheen> Next week we will not have a TSC meeting.  Send an email out for the outstanding items you need an update on.
14:58:12 <farheen> Send it to TSC and dev list.
14:58:51 <farheen> #action Nat-TechM send email to TSC and devdis.
14:59:16 <farheen> Can we schedule an arch review for the on-boarding component?
15:00:06 <farheen> #action common services and onboarding teams/PTLs will present.
15:02:32 <farheen> didn't have time for jamil's presentation.  The plan is to go ahead with the ONXX.
15:04:22 <farheen> #endmeeting