13:57:46 <farheen> #startmeeting architecture weekly
13:57:47 <collabot> Meeting started Thu Sep  6 13:57:46 2018 UTC.  The chair is farheen. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:57:47 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:57:47 <collabot> The meeting name has been set to 'architecture_weekly'
14:04:51 <farheen> #topic Code freeze checklist (Bryan/Manoop)
14:05:37 <farheen> #topic Design Studio Athena release (Kazi)
14:13:46 <farheen> #info Kazi Farooqui reviewed his work in progress DS developer and user guides.  Available on #link https://docs.acumos.org/en/latest/submodules/design-studio/docs/developer-guide.html#read-complete-solution-graph-from-nexus
14:14:53 <farheen> #info this is a very detailed design studio developer guide includes API.
14:17:00 <farheen> #info 0.0.36 version of DS has improved the performance of the cache of the matching models
14:17:48 <farheen> #info if there is a delay then inform the user that DS is retrieving matching model.
14:18:34 <farheen> #action farheen add DS composite solution deployment in future agenda.
14:19:41 <farheen> #info The data broker will be in the ds user guide. Yet to be added.
14:20:42 <farheen> #action Kazi add data broker and probe instructions in the DS user guide.  Work with Chris Lott.
14:23:17 <farheen> #action kazi schedule the data broker and probe next week.
14:25:03 <farheen> #action kazi concentrate on documenting the data broker and probe and apis.
14:26:05 <farheen> #info intial target of this integration is to bring in clean code into acumos repositories.  Integrate thos pieces into des
14:27:28 <farheen> #info there is no architecture impact in Athena release in DS.
14:28:10 <farheen> #action Manoop forward CMLP calls to Bryan.  For Athena release scan code then allow CMLP to contribute.
14:29:16 <farheen> #info however the CMLP discussion and design is starting now but will not be included in the Athena release.
14:29:36 <farheen> #chair talasila
14:29:36 <collabot> Current chairs: farheen talasila
14:31:49 <farheen> #topic Portal Marketplace review.  Used a power point deck.
14:39:58 <farheen> #info Mukesh covered the architecture of the approver role and the workflow of a user moving her model from private to public.
14:45:44 <farheen> #action Mukesh send slides to Manoop and Anwar.  Aimee will assist with placing on the wiki.
14:46:37 <farheen> #info you touched upon federation and the publisher role.  Are you on track with that?
14:47:42 <farheen> #info yes it will be in this release.  Regarding white box deployment it will be ready for next release.
14:49:46 <farheen> #info Bryan we need a goal for message flows documentation.  We want this to be automated.
14:50:41 <farheen> #info Bryan: I'm not talking about components.  When I do an architectural design on key design tool is to understand the flows across the platform.
14:52:54 <farheen> #action Anwar and Bryan spend time reviewing documentation of message flow documentation.
14:53:44 <farheen> #info next week we will go over remaining items.
14:54:37 <farheen> #action Chris, Guy, and Phillipe prepare to present probe, data broker, CDS, Onboarding, Common Services, Federation and Catalog.
14:56:32 <farheen> #topic Ofer discussed 9/21/18 face to face meeting.
14:57:00 <farheen> #info we are planning a full or half day workshop in Bedminster.  We will also broadcast in zoom.
14:57:25 <farheen> #info goal is to review the different requirements for the Boreas release and discuss amongst ourselve the scope for the next release.
14:58:00 <farheen> #info when can we share a high level agenda?  Start working on it tomorrow.
14:58:25 <farheen> #action Ofer prepare an agenda for the 9/21 meeting.
14:58:42 <farheen> #topic Code Freeze checklist
14:59:09 <farheen> #info bryan prepared it for the deployment project.  Will have discussions on questions.
14:59:36 <farheen> #info you can mark questions as not applicable if they dont pertain to your project.
14:59:50 <farheen> #info be sure to put comments for better communications.
15:00:21 <farheen> #info Ken reminded that all critical and high defects have to be closed.
15:01:22 <farheen> #action Nat can not guarantee that the critical and high defects are going to be closed.  It is up to the PTL.
15:01:57 <farheen> #action  Nat bring up the topic specifically on the PTL call.
15:02:43 <farheen> #info the request was sent to the PTLs and is waiting for a response.
15:03:19 <farheen> #topic We have a new component for licensing.  PTL will be Michelle.
15:03:43 <farheen> #info Ofer tried to contact Michelle on the product call and she is out for the next two weeks.
15:04:10 <farheen> #endmeeting