14:02:43 <farheen_att> #startmeeting Acumos Architecture Committee
14:02:43 <collabot> Meeting started Thu Oct 11 14:02:43 2018 UTC.  The chair is farheen_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:43 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:43 <collabot> The meeting name has been set to 'acumos_architecture_committee'
14:06:23 <farheen_att> #topic Acumos CMLP Predictor
14:08:29 <farheen_att> #info Ryan Hull presenting slides
14:10:36 <farheen_att> #info Model Runner does the prediction calls the Model Manager and the manager will download the model and store it.
14:11:46 <farheen_att> #info Ryan drawing on Paint white board.
14:12:29 <farheen_att> #info bryan: question: It seems like your goal is to have acumos play the role of the lifecycle manager.
14:12:51 <farheen_att> #info Not really training.
14:13:05 <farheen_att> #info Bryan: production is a better description.
14:13:49 <farheen_att> #info bryan: retrieving things from source is not covered by Acumos.
14:14:16 <farheen_att> #info bryan: what's covered is building a ms but not to building from source.
14:14:59 <farheen_att> #info bryan: model runner stored in nexus in acumos.
14:15:38 <farheen_att> #info ryan: is the model trained?
14:17:09 <farheen_att> #info anwar: What is the best place to store or integrate?
14:17:39 <farheen_att> #info bryan: Provide access to repo and source code and use that as a process of creating a ms in acumos platform.
14:19:03 <farheen_att> #info ryan: Model manager pushes and pulls from Nexus.  My question is where should we put it?
14:19:30 <farheen_att> #info anwar: if he current model manager also takes care of the source code then that is something acumos doesn't provide.
14:20:01 <farheen_att> #info ryan: CMLP doesn't store source of the model
14:20:37 <farheen_att> #info ryan: Model manager updates a new version of the model and model history primarily used by the model runner.
14:22:13 <farheen_att> #info this functionality resides within CMLP so please meet with the team to do a deep dive into model runner.
14:23:38 <farheen_att> #info bryan: sounds like to me what you're talking about are things Acumos already does.
14:25:27 <farheen_att> #info ryan: yes, that sounds like there is a lot of similarities
14:26:14 <farheen_att> #info guy: We support many different types of toolkits.
14:26:48 <farheen_att> #info ryan: in the cmlp world there is a one to one relationship between the model runner and the model.
14:27:19 <farheen_att> #info mukesh: isn't updating a model training the model?
14:27:44 <farheen_att> #info ryan: user gets a key to run the model runner again.
14:28:15 <farheen_att> #info mukesh: Does the key update the model?
14:28:21 <farheen_att> #info ryan: yes
14:28:46 <farheen_att> #info ryan: two different approaches Model Manager and Model Runner
14:29:40 <farheen_att> #action ryan, bryan, guy and Phillipe get together this week and do a deep dive.  What and How
14:30:06 <farheen_att> #info bring it back next week so we can review your results.
14:30:30 <farheen_att> #topic Documentation
14:31:07 <farheen_att> #info bryan presenting docs.acumos.org: No open reviews to the documentation project.
14:31:16 <farheen_att> #info bryan: looking for commits.
14:31:57 <farheen_att> #info I have updated diagrams from the wiki.  The scope is adequate.
14:33:10 <farheen_att> #info bryan: We need descriptions of the E interfaces from the PTLs.
14:34:42 <farheen_att> We need people to step up and add a sections to architecture.
14:37:13 <farheen_att> #action bryan will take the lead on getting the gaps filled in
14:37:39 <farheen_att> #topic Licensing
14:38:20 <farheen_att> #info michelle presenting model licensing slide.
14:39:10 <farheen_att> #info License Artifact responsibility falls into the data scientist and data analyst.
14:39:43 <farheen_att> #info All of the user personas we have identified will be using License Tracking.
14:40:16 <farheen_att> #info We need a way to gather tracking information and then
14:40:39 <farheen_att> #info report on it through metrics and analytics.
14:41:44 <farheen_att> #info We've identified the user personas and the key actions.  Now we have to trace it through and who.
14:43:05 <farheen_att> #action we need to put a team together for the 18 features because we will be getting started with the boreas work.
14:44:21 <farheen_att> #info michelle we have been talking with deployment and training.
14:45:02 <farheen_att> #info anwar: Portal will be central to ux/ui.  Although I suggest we develop the ux outside of the development team.
14:46:09 <farheen_att> #info question: Does the model tracker receive information?
14:46:24 <farheen_att> #info we are not going to be policing but we are reporting on the use of the models.
14:46:33 <farheen_att> #info we are not proposing to take action.
14:47:40 <farheen_att> #info anand: take the burden off the user to maintain the licenses.
14:49:49 <farheen_att> #info AT&T will have Ericsson on site for next week on 17th 9AM morning have the TSC memebers join.
14:50:28 <farheen_att> #action if you are interested cotact Larry Uno morning 9AM October 17 with Ericsson at AT&T Bedminster location.
14:51:24 <farheen_att> #topic Roundtable
14:52:11 <farheen_att> #info bryan: Kubeflow has 1/10th of the developers on the project and if acumos was supporting kubeflow it may give us an opportunity bring technology to this project.
14:52:35 <farheen_att> #info anwar: I agree if we join hands with them it will but acumos in high gear.
14:52:57 <farheen_att> #info hopefully something good will come out of the partnership with Kubeflow.
14:54:37 <farheen_att> #info Chris Lott: Kubeflow seems to do the deployment and training.
14:57:05 <farheen_att> #info farheen: acumos needs in the model building aspect.
14:57:29 <farheen_att> #info: guy: kubeflow is good for compound deployments.
14:58:24 <farheen_att> #info kazi: It is purely a deployment tool.
14:59:09 <farheen_att> #info kazi: They are deploying all components from data ingestion to output of the ML model.
14:59:25 <farheen_att> #info The output of our DS would be feeding into their deployment engine.
15:02:06 <farheen_att> #info michelle: I liked that he was interested in data rights management.  I liked that there was somebody interested in license management.
15:02:35 <farheen_att> #topic Release
15:03:54 <farheen_att> #info one critical defect in an open state.  Bryan is looking into it.
15:05:15 <farheen_att> #topic Major things due
15:05:29 <farheen_att> #info make sure the documentation and athena is fully tested.
15:05:33 <farheen_att> #endmeeting