14:01:58 <farheen> #startmeeting Architecture Committee
14:01:58 <collabot`> Meeting started Thu Oct 18 14:01:58 2018 UTC.  The chair is farheen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:58 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:58 <collabot`> The meeting name has been set to 'architecture_committee'
14:02:18 <farheen> #topic Agenda
14:04:25 <farheen> #info Security and Validation and CMLP code review request.
14:04:56 <farheen> #topic Security and Validation by Bryan Sullivan
14:06:47 <farheen> #link https://wiki.acumos.org/display/SEC/Security+Scanning
14:07:53 <farheen> #info Community Policies covers things that we address through federation.
14:09:40 <farheen> #info Admin will have the ability to establish gates thru the portal front end to flow.  Those gates will determine whether a user can share, download, deploy.  This is post onboarding.  This is the first 5 workflows that will be covered.  You must have licensed models.  This also includes vetting of incoming models.  There is a holding area while assessment for incoming is done.
14:10:27 <farheen> #info For each model there will be an ability have licenses and security checks have been processed.
14:10:50 <farheen> #info Lastly the portal fe will implement control per Admin.  Manual Administered control of models.
14:12:17 <farheen> #info The second part depends on FTE support.  Integrated scanning tool in the platform.  We are still looking at solving issues with technology and a falsehood of security.  If we do this we're going to have to do this well and automate into workflows.  There is a design on the table for doing that.  I need to make it java centered.
14:12:49 <farheen> #info Anwar: Since this is related to how licensing will work I want to make sure the other PTLs are carefully reviewing this plan.
14:13:09 <farheen> #action PTLs review this plan carefully
14:14:19 <farheen> #action Mukesh and Chris Lott please review plan and comments and feedback.
14:15:27 <farheen> #info Mukesh: We have implemented publish to pubic marketplace.  Will that be impacted?  Bryan: No we will incorporate into existing.
14:16:18 <farheen> #info Bryan: I am going to turn this into user stories for actual functions.  And how best to fit into the java models.
14:17:35 <farheen> #info We have a design at the admin level and others at a model level.  In principle does that sound reasonable to you?
14:17:59 <farheen> #info Chris Lott: Yes, I am creating an epic for CDS Boreas tasks.
14:18:55 <farheen> #info Phillippe and Guy don't see this as an impact for on-boarding.  It seems OK of how it will be invoked.
14:20:22 <farheen> #info Bryans: flow diagram.
14:20:26 <farheen> #link https://docs.acumos.org/en/latest/submodules/security-verification/docs/design.html#architecture
14:20:43 <farheen> #info Bryan reviewed the diagram above.
14:22:03 <farheen> #info Bryan: Portal FE will direct users whether their model passed or failed the checks.
14:22:33 <farheen> #info Anwar: We have a go ahead to continue with this design
14:22:46 <farheen> #topic CMLP
14:23:00 <farheen> #topic CMLP renaming of repos
14:24:09 <farheen> #info Manoop: Based on email conversations we want onboarding, designstudio, and portal renaming.  We got the OK from Kazi for DS.  We need the OK from Phillippe, and Mukesh.
14:24:43 <farheen> #info Adi: I had a data pipeline check in that is not on the list here.  I only see two of them.
14:25:28 <farheen> #info Gaurav sharing INTTEST/Acumos+subrepos
14:25:46 <farheen> #info we want to open up to a common library.
14:26:21 <farheen> #info Phillippe: We are not agreeable to name a python repo.  It is only for CMLP.  I would prefer a name like CMLP.
14:27:19 <farheen> #info Gaurav: I wanted to keep model runner.
14:27:41 <farheen> #info Bryan: We don't want to use the name CMLP in open source.
14:28:06 <farheen> #info Gaurav: Can we name it model-runner common.
14:28:24 <farheen> #info Adi: I don't know why this is a problem.
14:28:44 <farheen> #info The library has nothing to do with CMLP.  What is CMLP about it?
14:28:58 <farheen> #info Adi: If there is a common area maybe we should use that.
14:29:52 <farheen> #info Phillippe: Where would you like to have it?
14:31:07 <farheen> #info Phillippe: We have a common model runner repo.   My objection was to avoid confusion between two model runner repos one for CMLP and one for Acumos.
14:31:58 <farheen> #info Manoop: Re: cmlp-model-runner: will cmlp merge their model runner with the acumos model-runner.
14:32:19 <farheen> #info Gaurav: We need to have the technical discussion.
14:33:07 <farheen> #info Manoop: Phillippe until we get strong guidance of how it will be merged until then can we have another name besides cmlp.
14:33:16 <farheen> #info Phillippe: I don't know.
14:33:51 <farheen> #info Manoop: Adi Gaurav can you id a different name?
14:34:14 <farheen> #info Guy: Model runner stands up a rest service that has incorporated the protobuf conversion.
14:34:33 <farheen> #info Kazi: It is the marshalling and un-marshalling the rest service.
14:35:30 <farheen> #info Manoop: Can Adi or Gaurav give a short explanation of what their model runner?
14:36:32 <farheen> #info Gaurav: It is not tightly integrated with python and I didn't want to keep it on the top repo to confuse people.
14:37:03 <farheen> #info Gaurav: We want to have a common code and not duplicate and remove the redundancies.
14:37:22 <farheen> #info Manoop: Can we rename it as python utilities?
14:37:30 <farheen> #info Gaurav: Yes
14:38:05 <farheen> #info Phillippe: For me why not.
14:39:01 <farheen> #info Chris Lott: I don't agree because python runner and python utility are too similar.
14:39:37 <farheen> #info Chris Lott: May I suggest we come back with a proposal?
14:40:37 <farheen> #info Manoop: My vote is to stick to python-common and we are adding acumos-python-common
14:41:22 <farheen> #info Manoop: Is acumos-common-utility OK with you Phillippe?
14:41:59 <farheen> #info Phillippe: This repo is used by CMLP.  For now it's only used by CMLP going forward it can be used by other components also.
14:42:12 <farheen> #info Phillippe: OK why not?
14:42:31 <farheen> #info Manoop Kazi do you have an issue with this name?
14:42:48 <farheen> #info Adi: We should also ask Pantellis.
14:43:08 <farheen> #info Kazi: it is OK with Kazi.
14:43:25 <farheen> #info Anwar: Do we have a separate repo for training?
14:43:43 <farheen> #info Manoop: There is a training repo in acumos.
14:44:08 <farheen> #info Anwar: Training should have it's own repo.
14:45:38 <farheen> #info Anwar: Let's not move training into design studio.  Because most of this code is going to come from CMLP or other open contributors.
14:46:34 <farheen> #info Manoop: The components databroker/datapipeline.  The repo doesn't need to be tagged either DS.
14:47:05 <farheen> #info Kazi: I agree it's fine.
14:47:32 <farheen> #info Manoop: Kazi and Pantellis should decide who should lead training.
14:48:21 <farheen> #link https://wiki.acumos.org/display/ACCOM/Meetings
14:49:41 <farheen> #info Manoop: If we tag it with the training repo it will only be for training vs. if we change the name.
14:50:05 <farheen> #info Kazi: Data pipeline will have many components.
14:50:19 <farheen> #info Anwar: Where would the code reside?
14:50:29 <farheen> #info Kazi: We haven't made a decision for that.
14:52:49 <farheen> #info Adi: As far as the discussion with Pantellis he was on board with the design.  Kazi was OK.
14:53:12 <farheen> #info Kazi: We said we'd have 3 pipelines and now we're discussing the repo.
14:53:35 <farheen> #info Anwar: I am now hearing separate repo for each of these pipelines.
14:54:01 <farheen> #info Adi: Datapipeline is a component.
14:55:18 <farheen> #action Adi set up a call with Pantellis, Kazi, Manoop, and take offline and bring back to the team.
14:55:36 <farheen> #info Manoop: Was this last repo discussed?  Mukesh?
14:56:05 <farheen> #action Mukesh review with Gaurav.
14:57:39 <farheen> #info Gaurav it can be re-used by anyone.
14:58:43 <farheen> #action Abishek send an email to Manoop, Mukesh, to capture and we can bring back by Friday.
14:59:01 <farheen> #info Manoop: We are requesting renaming.
14:59:30 <farheen> #info Manoop: We are going to ask LF and make a decision based on that.
15:00:34 <farheen> #info Ken: We've received 2 builds this week.  We have done our complete round of testing.  The instance with the MS generator is looking good.
15:01:03 <farheen> #info the only high issue is cobranding.
15:01:45 <farheen> #info Anwar: Do you have any critical or high open?  Ken: just cobranding.
15:02:12 <farheen> #info Nat: That is the final build from the athena release.  Right now more than 50% have branched their code.
15:02:43 <farheen> #info Nat: Sharing an email table.
15:03:43 <farheen> #action Nat get the portal ui/ux items reviewed.  Please work with Ken and Farheen so we have a plan for implementing we'll talk later today.
15:04:59 <farheen> #info Nat: Sai is tracking all the people to branch.  Deepti please make sure it is reviewed in the afternoon.
15:05:11 <farheen> #endmeeting