14:02:37 <farheen_att> #startmeeting Architecture Committee
14:02:37 <collabot`> Meeting started Thu Nov  1 14:02:37 2018 UTC.  The chair is farheen_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:37 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:37 <collabot`> The meeting name has been set to 'architecture_committee'
14:03:24 <farheen_att> #topic Athena architecture - Anwar
14:05:11 <farheen_att> #info Portal components: Mukesh in design and architecture where are we?
14:06:42 <farheen_att> #info Mukesh: All design and architecture are complete.  There are two issues.  Search and Theme pop up will be delivered in the Athena maintenance release.
14:08:37 <farheen_att> #info We had a discussion with test team and Mukesh the plan is to go with the current build that the test team has agreed to continue to work on the two issues and put it as a possible plan for the athena release.
14:09:47 <farheen_att> #info Ken: We want all of the components to be in release form.
14:10:21 <farheen_att> #info Ken: we have the staging ready to go but are waiting for one components.
14:20:10 <farheen_att> #info Ken: We want a code drop with only the theme or the theme and the search.  Keep them separate.
14:21:19 <farheen_att> #action: Ken get on a call with Mukesh.
14:21:37 <farheen_att> #info Anwar: We have to get better at our test release process.
14:21:51 <farheen_att> #info Having one build per fix is going to slow down everything.
14:22:44 <farheen_att> #action Anwar: Take the triage of CI/CD process offline with Ken and Mukesh.
14:23:44 <farheen_att> #info Mukesh: Scoped 43 user stories tied to the epics.  The initial step has been made.  20% on the design part.
14:24:26 <farheen_att> #info Phillippe: From my point of view for Athena release is 100% complete.  Documentation change has been made.
14:24:46 <farheen_att> #info Anwar: For Boreas release?
14:25:55 <farheen_att> #info Phillippe: Working on Onboarding user stories.  Code coverage.  First feasibility of first release of boreas then how to enrich the code coverage.
14:26:13 <farheen_att> #info Anwar: So what percentage of design?
14:27:02 <farheen_att> #info Phillippe: Architecture and design for Boreas is 10% for the moment.
14:27:17 <farheen_att> #info: Anwar: other than onnyx what is onboarding team looking at?
14:28:33 <farheen_att> #info Phillippe: Possible to onboard a model that has already been saved.  Data scientist creates and saves a model.  We study the possibility to onboard a model directly into acumos
14:29:23 <farheen_att> #info: CDS: Chris Lott. I can't speak to the score card.  Boreas we have 10 user stories defined and more to come.
14:29:54 <farheen_att> #info Chris I don't see any new changes.  We'll be using the CRUD operations.
14:31:13 <farheen_att> #info Anwar: Chris what is the name of your component?  Catalog Data Model.
14:31:30 <farheen_att> #info Chris: A restricted federation feature will be done in Boreas.
14:31:59 <farheen_att> #info Anwar: Federation training is coming in Boreas.
14:32:43 <farheen_att> #info Chris: 10% for portal.
14:34:17 <farheen_att> #info Training: Pantellis: Architectural design is 0%.  I was hoping we would be able to get together the second meeting in November?
14:35:43 <farheen_att> #action Anwar a need to set up a lockdown for training.
14:36:37 <farheen_att> #info Definitely all the PTLs will be required.
14:37:14 <farheen_att> #action Ofer targeting for second week of November.  Have a one day and possibly two.
14:38:23 <farheen_att> #info What would be the environment for the development of the pipeline?
14:38:36 <farheen_att> #info How will approach?
14:38:59 <farheen_att> #info Bryan: Scope out the specs and make a suggestion to the community.
14:40:03 <farheen_att> #action Pantellis come up with a proposal for how we are going to use an environment.
14:40:34 <farheen_att> #info We want to make sure that the CMLP seed code is included in the training user stories.
14:42:54 <farheen_att> #action Kazi between 12 and 13 set up a call with CMLP.
14:43:31 <farheen_att> #info Bryan system integration.  Whatever gets done by Saturday night will be in the release.  For Boreas nothing has been created user stories.
14:47:57 <farheen_att> #info for deployment we have 10%
14:48:12 <farheen_att> #link https://wiki.acumos.org/display/AR/Architecture+Reviews+Score+Card
14:49:24 <farheen_att> #info Design Studio: Athena: we are complete.  No open items.  Documentation has been completed.  For Boreas we are working on mulitple fronts now.  1. Jupyter and CMLP with acumos. 2. how the pipelines and training projects will effect DS.
14:49:53 <farheen_att> #info Kazi: There will be a need for more discussion involving more people.
14:51:00 <farheen_att> #info: We are talking about integrating the CMLP Rapid Miner with it's training components.  We want to identify what is the impact of training on DS.
14:51:18 <farheen_att> #info Adi: There is some work around the pipeline we had one session and we have to do more.
14:52:06 <farheen_att> #info Kazi: 10% from DS.
14:52:46 <farheen_att> #info Guy: We have a lot of things planned such as supporting NXP types of builds for other architectures.  We are 10% done with creating user stories.
14:53:26 <farheen_att> #info there is a lot of work for supporting onnyx.  last one is enriching and standardizing the client libraries model runner uniformity.
14:54:33 <farheen_att> #info want the model runner to offer a heartbeat service are you alive at a standard location.  To give the meta data protobuf descriptions of the services they offer.  We want them to have a standard swagger description.
14:55:13 <farheen_att> #info challenge is meeting with the stake holders and composition and deployment teams.
14:55:54 <farheen_att> #info license: Michelle we've gathere requirements and high level apis.  We have drafted picture for that.
14:56:30 <farheen_att> #info we have to put together user stories.
14:57:33 <farheen_att> #info Anwar: Have close working partners can validate that license feature supports their needs and look to them to contribute.
14:58:48 <farheen_att> #info is there seed code?  We are going to recommend some open source licensing processes that we can propose.
14:59:59 <farheen_att> #info Anwar: in summary we are going take 5 minutes to go through this score card.  I want to utilize the time of this call for discussions.
15:00:50 <farheen_att> #info Pantellis: I am concerned about rapid miner on this project.  It is not open source.  Why are we referring to it.  I also see table white box deployment.  Is there a spec for the white box?
15:02:17 <farheen_att> #info Anwar: White box refers to your plain vanilla servers that run Linux and don't use the std. intel chip.  The whole idea is to use these rather than commodity.  Had a meeting with a vendor called NXV and their arm white boxes that can be used on the edge and easily managable scalable.
15:02:51 <farheen_att> #info more details when we meet for the lockdown.
15:04:17 <farheen_att> #info What about rapid miner?  There is a github project for that.  They GNU Afero license.  That is a big concern.  You can't put a GNU license for acumos.
15:05:33 <farheen_att> #action Kazi check with Scott if we can use rapid miner and discuss with Adi.
15:05:38 <farheen_att> #endmeeting