15:05:38 <farheen_att> #startmeeting Architecture Committee weekly
15:05:38 <collabot`> Meeting started Thu Nov 29 15:05:38 2018 UTC.  The chair is farheen_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:38 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:05:38 <collabot`> The meeting name has been set to 'architecture_committee_weekly'
15:06:12 <farheen_att> #info Michelle for Licensing and Bryan for Deployment
15:10:06 <farheen_att> #info Michelle Martens reviewed architecture diagram.
15:10:59 <farheen_att> #info Find the latest deck on the License management wiki page.
15:13:15 <farheen_att> #info One of the recommendations from Orange was to re-use ISO standards 19772-3 as licensing artifacts.  The license artifact is the license terms and agreements for using the model.  When they publish their model to the catalog they will attach a license artifact.  That artifact states how you can use that model.  That contains a subset of fields in ONAP.  We will go through the license management artifact that the pu
15:14:48 <farheen_att> #info In the security verification workflow there are different checkpoints that check points call out to the license manager before we move on to the next step.  The license manager will verify all relevant systems to check for entitlements.  It will do all the decision making on the license facts.
15:16:34 <farheen_att> #info should license be bundled inside the platform our outside the platform?  Issues arise:  If it's external the users of the model can combine and have one inventory application.  Example.  Using ONAP they can combine  VNF + model entitlements.  However if it's internal we have a package license solution.  We are still discussing.
15:18:06 <farheen_att> #info Other types of Boreas release.  Different types of entitlements. We are starting with one type of license entitlement.  But suppliers said they want to see some limited entitlements in the boreas release.  At least track entitlements.
15:18:45 <farheen_att> #info We have gotten feedback from Hwawei and Ericsson but not...
15:18:56 <farheen_att> #action Michelle reach out to Pantellis
15:19:59 <farheen_att> #info when you spin up VNF software you have to enter a key.  That has been expressed by Hwawei and Ericsson to provide keys.  There are a variety of tracking.  It's a matter of what we can deliver within a release.
15:20:40 <farheen_att> #info Security Verification Workflow:  Key impact to publishing and federation.  The license artifact should be federated along with the model.
15:22:25 <farheen_att> #info Work Items and issues: Loading up the license entitlement inventory system has to be set up represent the actual model and the second step is to load up the reference or key identifiers and load up the actual entitlement of the model you are going to use.  The process has to be worked out.  There are APIs but we have to figure out what those steps are.  We feel we want to load up the entitlements or placeholders f
15:22:47 <farheen_att> #info Anwar: What other major components have impacts in the Boreas release?
15:23:27 <farheen_att> #action Michelle contact interfacing PTLs with requirements.
15:24:47 <farheen_att> #info download, deploy, and federate.  I took the Mukesh's diagram and overlaid licensing component. see slide
15:26:45 <farheen_att> #info Michelle: Publishing, Downloading, Deploying, and Federation
15:27:18 <farheen_att> #info Guy: During onboarding time we can build in a tool to onboard the model with the license.
15:27:32 <farheen_att> #info Bryan: We should give them an option.
15:28:48 <farheen_att> #info Guy: Microservice creation.  If you want to enforce license at run time talk to Guy Jacobson.
15:29:15 <farheen_att> #info Bryan: Yes, there are a variety of licensing features.
15:29:32 <farheen_att> #info Guy: Someone has to build the code.
15:30:29 <farheen_att> #info Michelle: If you look at the user story a license manager is going to go in and check that the entitlement exists in the microservice.
15:31:11 <farheen_att> #info Guy: It can also be done during the run time itself.  If you want to do additional licensing restrictions then you can do that during run time itself.
15:32:11 <farheen_att> #info Guy: We don't have java run times in all of our code.  They vary alot.  The most useful is to write something into a binary to make a decision to proceed or not.  That is something that needs to be implemented.
15:32:37 <farheen_att> #link https://wiki.acumos.org/display/LM/Release+Planning
15:33:14 <farheen_att> #info Bryan: There is likely something that can be built into the ms.
15:33:50 <farheen_att> #action Michelle: work with onboardind, Chris Lott  for CDS, and deployment.
15:34:27 <farheen_att> #info Anwar: In light of the use case.  Once we have a model identified it is better to make this use case as an example.
15:34:46 <farheen_att> #topic Bryan Security
15:37:00 <farheen_att> #info We've been having discussions around do we have to do level indication or not.  There have been red face issues.  We have resource issues.  The existing approach is deployable and secure enough but people are insisting on user level authentication.
15:37:09 <farheen_att> #info Bryan: not an option
15:38:10 <farheen_att> #info diagree download is traceable.
15:39:14 <farheen_att> #info Bryan: There will be user level authentication.
15:40:22 <farheen_att> #info Bryan: Heads up K8 will be a part of deployment.
15:42:42 <farheen_att> #info Bryan: we talked about logging.  We need to put on the architecture table.  We need to bring in a portal plugin framework.  We have a very tightly coupled and we need to move away from restful into a message bus asynchronous piece.  If I want to bring in a new componkrkent I can't do it without massive disruption to the other components.  CMLP suggested looking into Omni framewor
15:43:15 <farheen_att> #action Mukesh review Omni-framework
15:43:48 <farheen_att> #info Bryan: you can use restful apis across message bus.
15:44:24 <farheen_att> #action Bryan: Come up with what components be effected by message bus architecture.
15:44:54 <farheen_att> #info Bryan: Most difficult part will be migrating away from synchronous.
15:46:38 <farheen_att> #info Can we put in an architectural change for logging?
15:47:00 <farheen_att> #action Ken put a jira item for logging issue
15:48:08 <farheen_att> #info Is message bus effect the overall platform or can it be done over time?  It can be done over time.  Will the data be persistent?  Everything on the message bus gets logged.
15:51:09 <farheen_att> #info Bryan: I am working on the kubeflow and it's impact for deployment.  Right now we have 3 different approaches for deployment.  Whatever we have to do with NXV and kubeflow everything is aligning under kubernetes.  While we will continue to support openstack and azure, we're not going to take it forward.  Kubeflow are pipelines for kubernetes.  It's looking like a abstracted
15:51:47 <farheen_att> #topic Review of progress
15:52:47 <farheen_att> #info Mukesh: I started on high level design around security validation and CDS changes.
15:53:01 <farheen_att> #action Mukesh look into omni frame work we are talking about.
15:53:21 <farheen_att> #info Nat: Mukesh have you started looking into training.
15:53:45 <farheen_att> #info two major things are training and licensing.
15:54:40 <farheen_att> #info model onboarding.  We are not planning to create Pytorch and Cafe.  We have to show some use case models that are pytorch and cafe.
15:55:58 <farheen_att> #info worked with licensing team regarding onboarding a model.  We will also work ask the user if they want to create a microservice.  We also have some work on the user experience.  Regarding the epics and user stories look at the matrix.
15:56:11 <farheen_att> #info We have completed 30%
15:58:18 <farheen_att> #info Chris L. Improvements to page loading.  Architecture and design work is 20%.
15:59:03 <farheen_att> #action Pantellis update your percentage on the architecture community score care.
16:03:50 <farheen_att> #action Gaurav prepare a presentation of workflow architecture.
16:04:45 <farheen_att> #action Nat ML workbench needs TSC approval.  Adi brought it up and wanted to work with Kazi to write it up in a wiki page.
16:06:54 <farheen_att> #endmeeting