15:04:11 <farheen_att> #startmeeting Architecture Committee
15:04:11 <collabot`> Meeting started Thu Dec  6 15:04:11 2018 UTC.  The chair is farheen_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:11 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:04:11 <collabot`> The meeting name has been set to 'architecture_committee'
15:05:23 <farheen_att> #topic Onboarding
15:07:16 <farheen_att> #info Philippe: I modified the architecture diagram for Athena release with the objective that we want to add to Boreas.
15:07:39 <farheen_att> #info for a pre-dockerized model user option to onboard an pre-dockerized model.
15:07:52 <farheen_att> #info we want to give them ONNX and TSX formats.
15:09:24 <farheen_att> #info Philippe: We offer both CLI and web onboarding.  On the first page is not like the legacy onboarding.  We create an artifact starting with nexus and at the end we will ask the user if he wants to create the MS from it. IF yes, it will trigger the microservice generation.  The complexity is not finished.  I will ask the question to the user to trigger the microservice generation.
15:09:50 <farheen_att> #info Philippe: I will allow the user to onboard the ONNX and TSX.
15:10:25 <farheen_att> #info Adi: It would be good to work with you on PFA.  Do you have a concept of plugability or very tightly coupled with Acumos?
15:11:12 <farheen_att> #info Adi: I left it open but let me share plugability: 1. Microservices.  2.Omni or web component. Is this a part of the view?
15:11:41 <farheen_att> #info Philippe: First we plan to onboard the model without treating protobuf.
15:11:56 <farheen_att> #info Adi: So it's more like and application instead of a service right now?
15:13:16 <farheen_att> #info Manoop: What is an AT&T framework.  Just this week we had a session where people started using Omni.  We don't have a choice within CMLP it is a front end standard.
15:13:58 <farheen_att> #info Jason: It is bringing the ability to plug components together in a single UI or with other plug-able micro-UIs.
15:14:33 <farheen_att> #info Bryan: That sounds like a fundamental architecture.  Sounds like openstack plug and play. Yes.
15:15:12 <farheen_att> #info Bryan: I sent last week to the list a more flexible way to plug.
15:15:36 <farheen_att> #info Manoop: We want to de-couple the portal front end presentation.
15:15:51 <farheen_att> #info Bryan:  There is a lot of backend that is point to point and hard wired today.
15:16:05 <farheen_att> #info Manoop: Yes, getting there in one night is a huge impact.
15:16:22 <farheen_att> #info Bryan: First we have to understand and agree that we want to discuss.
15:16:54 <farheen_att> #info Manoop: Yes, we asked the teams to review their architecture with community.
15:17:16 <farheen_att> #info Manoop: To start understanding we have to ask about Omni.
15:18:00 <farheen_att> #info Adi: It is not AT&T except for a few customizations.
15:18:30 <farheen_att> #info Manoop:  Are there other open source tools that can solve this problem.
15:18:53 <farheen_att> #info Mukesh: Bryan is talking about some customization such as CSP.
15:19:34 <farheen_att> #info Manoop: Mukesh this will be a disruptive change.  We have seen pros using Omni in building UIs in isolation instead on one component.
15:19:48 <farheen_att> #info Manoop: I can pull in resources to align with you.
15:20:12 <farheen_att> #action Manoop take the omni topic to the portal meetings.
15:20:24 <farheen_att> #info Manoop: Who will be experts using Omni?
15:20:34 <farheen_att> #info Adi: Yes, we have a few.
15:21:08 <farheen_att> #action Adi send Manoop the names of Yusen Istoc and Jason Tadros.
15:21:27 <farheen_att> #action Bryan set up a call with Adi for a deep dive.
15:21:59 <farheen_att> #info Manoop: Regarding onboarding we don't have license artifact.
15:22:17 <farheen_att> #info Philippe: Yes, we will give the opportunity to the user to onboard a license along with the model.
15:22:38 <farheen_att> #info Bryan: All we need to do is give advice to the people who build the docker images what to place where.
15:22:52 <farheen_att> #info Michelle: Yes, it would be a separate artifact.
15:23:07 <farheen_att> #info Bryan: I was talking about the license being a part of the docker itself.
15:23:57 <farheen_att> #info Philippe: I spoke about the external license.  From my point of user will have an option to onboard a model that has already been licensed.  I think a lot of models will not have models.
15:24:31 <farheen_att> #info Bryan: It is clear as an artifact.  We will have a security verification.
15:25:06 <farheen_att> #info Bryan: I am referring to the structure of the docker image when it's built.
15:25:56 <farheen_att> #info Guy: We will feature model runner that will deliver protobuf and meta-data and we can include the license along with the protobuf.
15:26:34 <farheen_att> #info Jason: Where would you see PFA as a part of this flow.
15:26:57 <farheen_att> #info Guy: In terms of delivering run time for PFA and ONNX I will get to that as a part of MS generation.
15:27:21 <farheen_att> #info Guy: We will let people write whatever they want and let them use this process here.
15:27:44 <farheen_att> #info Jason: We have a target of standardizing the portable format.
15:28:27 <farheen_att> #info Jason: we can do conversions with avaro.
15:29:14 <farheen_att> #action Philippe: I will add the license artifact and the question to the user if they want to add a license.
15:29:37 <farheen_att> #info Manoop: Do you have the impacted component?  What is your requirement and what you need from them?
15:30:01 <farheen_att> #info Yes, I tried to list in the Onboarding process in the wiki.
15:30:46 <farheen_att> #info Philippe: I will be talking to onboarding and Chris for CDS and regarding Documentation I have been writing.
15:31:36 <farheen_att> #info Philippe: There is not reliance on DS.
15:31:54 <farheen_att> #info Bryan: Do we document how the dockers are created?
15:32:44 <farheen_att> #info Guy: We should allow them to upload protobuf.
15:33:19 <farheen_att> #info Guy: We have a system called Argus so that people can find it but it doesn't fit our ms model.
15:34:30 <farheen_att> #info Guy: We should think about adding these extra artifacts by hand.  Crafting the protobuf file is not that hard.  Reuben: Many are not ms but will be running in a cloud somewhere and we have to be able to make a psuedo-ms.
15:35:00 <farheen_att> #info Reuben: We cant assume that everything is going to be onboarded as source and shrink wrapped.
15:36:21 <farheen_att> #info Bryan: We should allow them the opportunity to upload protobuf. We need to understand why we are enabling to onboard things other than MS design models.
15:36:57 <farheen_att> #info Bryan: I propose if a model proto and meta-data is present then we should create a tgix file for DS.
15:38:29 <farheen_att> #info Guy: Let's say you have something written in C++ but can create your own docker image.  If people are willing to do that then they could construct a valid ms along with protobuf and metadata file to get them all into the system.
15:40:01 <farheen_att> #info Guy: You should be able to manually do what we've automated.  We also don't support multi-language models.  We could use the existing Python models runner and do your docker build.  You'd have your docker and protobuf file and you could get them all together and upload them.  You would have to understand the internals.
15:40:35 <farheen_att> #info Reuben: Since everything we're doing is in sourcecode it can be done in ant.  There is no documentation explaining that.
15:40:54 <farheen_att> #action Philippe: Include onboarding.
15:41:21 <farheen_att> #info Manoop: Why would DS not be impacted?  We should have a bigger plan of how to address.
15:42:48 <farheen_att> #info Guy: MS generation has a significant impacts to DS.
15:43:24 <farheen_att> #info Manoop: We have to get down to what is aligned with themes.
15:44:46 <farheen_att> #topic Log Standards
15:50:55 <farheen_att> #info Parichay: We will not be generating 4 logs instead we will be generating one log file.
15:51:30 <farheen_att> #action Kazi: Provide question through devdiscuss email list.
15:55:47 <farheen_att> #info Parichay: Earlier there were 30 fields and reduced it to these.
15:56:06 <farheen_att> #action Mukesh: Take the discussion around log standards to the devdiscuss.
15:57:09 <farheen_att> #link https://wiki.acumos.org/display/OAM/Acumos+Log+Standards
15:57:42 <farheen_att> #action Chris I will reach out to Parichay.
15:58:02 <farheen_att> #topic Release Management Ofer
15:58:21 <farheen_att> #info Sharing the 85 epic list.
15:59:50 <farheen_att> #info Nat: Ofer will lay out the community meeting.  The community went over all the requirements and give their commitment.  If the epics are marked as high they are committed.  These 88 epics need to be prioritized and aligned with the teams.
16:01:39 <farheen_att> #info Ofer: We are trying to get commitments although not M1 we want to get the TSC approval.  My understanding is out of these 88 there are only 40 mapped to the themes.  The top 6 are already in a high rank and all of these themes are listed out according to priority.
16:02:39 <farheen_att> #info Manoop: If PTLs already mapped some of these epics with themes that means they are mapped.  They have not put it as a high they are in good shape knowing that teams are looking into it.  If we spend time on the ones that are not mapped.
16:03:12 <farheen_att> #info Nat: Out of the 88 49 are labeled.
16:03:35 <farheen_att> #info Bryan: How do you want us to indicate the priority?
16:04:04 <farheen_att> #info: Bryan: What did you mean by none of them are prioritized.
16:04:55 <farheen_att> #info Bryan: How are you looking at the prioritization?
16:05:18 <farheen_att> #info Nat: they are prioritized according to themes.
16:06:08 <farheen_att> #info Bryan: Previously you said the epics have not been prioritized.  Now you are talking about this list.  I have ignored any suggestion about priority.
16:07:06 <farheen_att> #info Nat: Ofer please step in.  18 themes have been prioritized according to the list.  Was there an intent to layer on this list priority?
16:07:43 <farheen_att> #info The top theme should be the top priority.
16:08:18 <farheen_att> #info Bryan: It has not been explained to PTLs of their understanding of this list.
16:08:47 <farheen_att> #info Mukesh: I have put them into high medium according to the sprint plan.
16:09:26 <farheen_att> #info Manoop: These themes are prioritized.  What is important to companies and then we moved them to the top level.
16:10:40 <farheen_att> #info: Manoop: People have to work with how many of those top themes?  Reuben agrees.  These four guidelines not for the work but for the themes.  They are all important.
16:11:37 <farheen_att> #info Bryan: That's what I said. PTLs have to prioritize their epics.  Nat there are jira items that have been prioritized.  Maybe we can start and go through that list.
16:13:08 <farheen_att> #info Ofer: I think it will be good to work on those that are already prioritized.  Bryan: Just ask the PTL. Ofer: I think this is my suggestion.  I think we should work PTL take one PTL or managed to do it already.  Work on his or her epics and move on to the next one.  Bryan I assume you have done all of your prioritization?  Bryan: Do you want to start with deployment?
16:13:27 <farheen_att> #topic Deployment Epic Prioritization
16:14:08 <farheen_att> #info Bryan: Go to he deployment project.  Go to Boreas release planning.  Scroll down.  That is everything that has been defined.
16:16:45 <farheen_att> #info Bryan: Here you have the prioritization and labels.  From the deployment we have this set of issues that are all high priority.  Ofer: Can you review them quickly and get agreement with everyone.  Bryan: Deploy model in Azure Kubernetes.  So that basically is last release we supported deployment into kubernetes environment.  There will be changes to the screens some minor discussions.  We will link those stories to t
16:17:02 <farheen_att> #info We are going to do deployment of models into Azure.
16:17:28 <farheen_att> #info Ken: How do I know which themes these epics are linked to?  They are labeled.
16:18:35 <farheen_att> #info Deepti: In jira we have almost 12 issues that comes under model deployment.  B: I need to update the query there.  Manoop: you need to line up with the PTLs.  Deepti: I see 12 items here and 3 are not matching.
16:19:51 <farheen_att> #info Bryan: What you're looking at is openstack, kubernetes, docker proxy.  these epics are associated with their components.
16:21:44 <farheen_att> #info Bryan: kubernetes we're dploying models under openshift.  There are a variety of enhancements to the deployment process that are going to improve the reliabiliy.  We have deployment of models to white boxes that is a medium priority because we are unclear on edge cloud deployment.  Next is model lifecycle management of kubernetes.  We don't have a lot of detail around what the ask is.  Reuben: Are you talking about e
16:23:56 <farheen_att> #info Bryan: Lifecycle management is scale up, down.  R: Properties management.  You're talking about the lifecycle of the ms.  I have to reconfigure.  It's one thing to say you need to be cloud native.  This is medium because it is unclear and we don't have resources.  We're also going to do user level authorization to download a model.  That is not supported by the portal yet.  I will follow up and that is high priority.
16:26:03 <farheen_att> #info for the high priorities?  B: Yes. Only the high priority ones are committed.  B: Yes, I think we have resources to support.  M: In case you don't have resources you should get them done.  IF they are a high priority and you don't have the resources raise this as a jeopardy to get support  from other companies.  B: We know deployment to google and AWS is a lower priority because the goal is not defined.  The 3 lower p
16:28:02 <farheen_att> #info Manoop: We should raise a concern. B: yes, that is why it is a low priority.  M: Does anybody have resources for the low priority items?
16:28:37 <farheen_att> #info: Ying from Ericsson will check to see if she has resources.
16:29:16 <farheen_att> #info Bryan: We can deploy a model in any machine environment.  If people have expertise in the kubernetes stacks.
16:29:45 <farheen_att> #info Bryan: For GPU deployment are going to require custom work.
16:30:06 <farheen_att> #info Ofer: Yes, this is what we wanted to get from deployment lets move on.
16:30:52 <farheen_att> #topic Onboarding
16:33:09 <farheen_att> #info Philippe: I have two Epics.  I have not prioritized them.  Ofer: Do you know what your resources are and can you commit?  P: Yes.  P:2106 and the other one is related to UX.  We will ask the user if he wants to let Acumos create the MS docker image. In my point of view it is a medium.  O: These are the two epics?  OK the first one will be high and next is medium and you will commit both of them.  We will start with t
16:35:15 <farheen_att> #info It could be linked to model interoperability and model type.  P:Also 2107.
16:38:24 <farheen_att> #topic OAM
16:41:13 <farheen_att> #info Bryan: 2004 is a medium epic.  It is difficult to implement clean up tools.  This is a medium priority.  We may not deliver everything that people want.  The next item is upgrading of the openstack.  High priority.  Sonar coverage is high priority.  It doesn't fit one of the themes.  I don't know that the themes address the sum total.  There is no theme to improve the test process.  In system integrtation the epics a
16:44:06 <farheen_att> #info we need to  roadmap this.  We need people to scope the things we're going to deliver.  System integration tools are a high priority.  It is improved.  Deployment and lifecycle management for openshift is a high priority for kubernetes.  It's going to help us test out the platform managed around the tenant focused.  Enhance the testing and the all in one tool set will be a key enabler in doing that.  We need to design
16:44:42 <farheen_att> #info All will be committed but are not high priority.  Deepti: you are missing some theme labels.
16:46:08 <farheen_att> #topic Portal
16:49:19 <farheen_att> #info Mukesh: I put it under Boreas release called Boreas Tasks.  We have around 21 epics that are floating into 3 or 4 user stories.   these are tied to 45 user stories.  The ones that I am able to filter now is deployment changes.  I am working with Bryan.  there is restricted federation.  Migration of the logs standards.  Managing private models. Enhance screens for federation.  Reuben: The three you just covered can be
16:50:47 <farheen_att> #info M: yes, global searches for Acumos.  Portal Enhancement for CDS.  There are 8 or 9 user stories.  We have the portal license.  This is a critical feature.  Portal UI changes are high.
16:53:15 <farheen_att> #info These are pretty complex.  Then we have the medium set.  R: Wasn't one of the key elements was rearchitecting the UI so it is plugable.  I don't see anyting called out for that design.  M: I kept them up to the components.  R: So you will try this new design on a couple of use cases before restructuring the system.  M: We give the requirements and the PTLs will take it to their teams to plug together.  There are a co
16:53:31 <farheen_att> #info M: I provided priority based on the resources that I have.
16:54:14 <farheen_att> #info M: I am committing to all the high epics.
16:55:42 <farheen_att> #topic Security Verification prioritization of epics
16:56:11 <farheen_att> #info Bryan there is only one epic and it's a high priority and committed.
16:58:35 <farheen_att> #info Ofer: We reviewed 4 out of 9 projects.  Security verfication was moved from common services to licensing.  Portal we have reviewed and Onboarding and OAM. Ofer: Let's try to have a review next week.  Nat: My suggestion is to take the high ones.
16:59:26 <farheen_att> #info Guy: be sensitive to end of year vacations.  I will not be here.  Nat: Mark your epic in jira as a high.
16:59:39 <farheen_att> #info Philippe can review.
17:00:56 <farheen_att> #action Deepti: Prepare a report that highlights the epics that are in the top 6 themes that are not a high priority.
17:01:56 <farheen_att> #info O: Break down the list you reviewed today on TSC and then the epics that are not a high priority and label with themes.
17:03:04 <farheen_att> #action Deepti join the TSC on Monday and share your report to have the discussion.  M: should we send out a communication so TSC knows and ask Licensing PTLs like Michelle to remind them that 12/10 is a deadline.
17:03:38 <farheen_att> #action Ofer reach out message to the remaining PTLs.
17:03:55 <farheen_att> #endmeeting