15:07:05 <talasila> #startmeeting acumos-architecture
15:07:05 <collabot`> Meeting started Thu Dec 13 15:07:05 2018 UTC.  The chair is talasila. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:05 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:07:05 <collabot`> The meeting name has been set to 'acumos_architecture'
15:07:36 <talasila> #topic DesignStudio - Jupiter notebook integration
15:08:19 <talasila> #Bryan - suggests that the Jupiter notebook must get TSC approval.
15:11:48 <talasila> Concerns are BSD 3 license and could not be modified - if modified then we may need to go through legal review.
15:12:57 <talasila> #action Kazi to follow up on the license concerns
15:15:12 <talasila> Jupiter at moment does not provide the feature of saving the files into server and should use it as is that comes out of box.
15:16:04 <talasila> Out of Scope - no enhancements to Jupiter by acumos team
15:18:28 <talasila> Jupiter hub as a service will be hosted and accessible to Acumos Portal Users
15:21:10 <talasila> Manoop - What are other alternative notebooks? - For example like zeppelin, rapidminor, niffy; for first release Jupiter notebook; DS will become as model composer under ML workbench;
15:22:41 <talasila> #action Kazi to upload the design document reviewed today for Jupiter note book integraton.
15:25:56 <talasila> Jupiter hub will be deployed as part of Kubeflow
15:30:13 <talasila> #action Kazi - 1) Design Doc in wiki?; 2) Impacts to other teams - Portal for authentication; Onboarding for packaging the docker?, Deployment?, CDS?; 3) APIs defined?
15:37:13 <talasila> #action Kazi - update the acumos architecture showing the links and references to jupiter services or components.
15:39:43 <talasila> Concern - Jupiter note boob is for only to create python files; This is not sufficient - it require flow to create end model.
15:39:51 <talasila> *book
15:40:50 <talasila> Manoop - why would user user Acumos hested Jupiter if he have to train the model again in his local?
15:43:16 <talasila> Longterm goal is to put the notebooks integrated with the training pipeline, so that modeller can train it after model is created.
15:44:33 <talasila> Chris's concern - what about data requires for training the model?
15:45:04 <talasila> Bryan - Jupiter allows the data reference
15:45:18 <talasila> Adi - Niffy solves some of these concerns
15:51:43 <talasila> #topic - status on the components
16:03:26 <talasila> #action Mukesh to prepare the proposal or plan on portal architecture choice with respect to OMNI/Polymer/React kind of tools for building standalone web components.
16:03:29 <talasila> #endmeeting