#acumos-meeting: architecture committee

Meeting started by farheen_att at 15:07:22 UTC (full logs).

Meeting summary

  1. Polymer or Angular and Omni-framework (farheen_att, 15:08:14)
    1. Anwar: What advantages do you get by wrapping using Omni. Sayee: Advantage whatever we call as omni will wrap AAF and other components of Acumos as well as CMLP. That will allow us to promote and build faster widgets. We are hoping the community will build more widgets. If someone wants to take a plugin and BI or IA tool they use will use it's own container. Manoop: How is that advantageous compared with Ang (farheen_att, 15:10:53)
    2. were used for years. How is that advantage when we use AAS support? Sayee: Any adoption is going to take time. This is a suggestion not one and done deal. Manoop: Direct support with framework then the UI would rely on login mech. Bryan: Yes, but how does the authentication effect UI work? It does not effect. What are the advantages of omni framework? Our customer is using this framework. We have to harmo (farheen_att, 15:13:19)
    3. Anwar: The question we have to ask ourselves is what benefits does Omni provide? Bryan: Technically are a wide set of developers are using out there. Anwar: How would you convince a developer? Sayee: I will show you tomorrow. Elevator pitch. The new version of omni will have multiple js support where you can have a faster widget and web component development. Bryan: Consider ongoing support for the framewor (farheen_att, 15:15:41)
    4. we going to support as a community? Sayee: As of now MS catalog is using it. We will have an internal advantage as well. We are taking ownership with DTV. Anwar: This is not DS2 or an extension. (farheen_att, 15:17:00)
    5. ACTION: Sayee: By end of day tomorrow lets get an agreement between Sayee, Manoop, and Bryan have a joined agreement on this topic. (farheen_att, 15:18:22)

  2. internal team had a discussion with Reuben and identified a good catalog new idea (farheen_att, 15:19:02)
    1. Manoop: Rather than having one single catalog of model. Can we have multiple catalogs that can be shared with a company privately instead of publicly. This is shared or virtual catalogs. This addresses the themes based catalog. If an ML user with health theme catalog can have a subset of catalog. Mukesh: This was not tasked under Boreas. Anwar: You have been asked to help with Training module release. Mukes (farheen_att, 15:21:39)
    2. Anwar: This is a high priority. (farheen_att, 15:21:54)

  3. Design Studio (farheen_att, 15:22:05)
    1. Manoop: What is the Boreas scope for Training? What are we doing with training ML workbench and Jupyter integration. What is the scope? Anwar: Let's do a recap of training module for Boreas as of yesterdays call. Bryan: On the training project page on the wiki under release planning you can see a section of Boreas design notes. That gives you a quick outline of the plan. USinng Nifi and jupyter hub. We're a (farheen_att, 15:24:15)
    2. workbench. Ability to create pipelines using nifi and create models using jupyter. We are looking at zeppelin. This is a tool box. Anwar: IF the integration work on jupyter hub is along the same line as zeppelin. Bryan: we want to have both. The third is acu-compose (new name for design studio) will create a blueprint that will deploy into k8. We'll have a robust toolset to deploy models and train them. On (farheen_att, 15:27:14)
    3. you will be able to test your design in your jupyter hub container. YOu can implement a pipeline first. As you're developing a pipeline you'll be able to feed that data. You'll be able to test with a real model. There are a few other details we have to work on. The wrapping of all of this in a new data model which takes our current set of artifacts and tools and frames into a project view. These are new we h (farheen_att, 15:28:57)
    4. in the third week of development please get together with Kazi and Pantellis. Although Pantellis will not be available for Boreas. Do we have jira stories? Anwar: No I will start adding those but we need a lead preferably other members. Anwar: For the scrums to get started we have folks. Sayee and Adi will be heavily involved. Getting the jira items is the first thing. Kazi why do we need separate scrum cal (farheen_att, 15:31:25)
    5. of the ML workbench. Bryan just mentioned is under the umbrella of workbench. Yesterday we started the API specs. We focused on design of ML workbench. We will create some user stories in jira from the minimal viable product. Then we will create the actionable items for the development team and track them. I'm assuming Sayee will assist. Anwar: The ML workbench calls? K: The daily calls are not scrum calls t (farheen_att, 15:33:36)
    6. call for the community? Nobody else from the community are not attending. Anwar: Are you OK to continue your design calls to cover your design exercise? Bryan is this the right plan? Bryan: As they continue the detailed discussion of ML workbench we need a tactical plan of what they need in Boreas. It's best if that happens daily. (farheen_att, 15:35:40)
    7. ACTION: Kazi: have Adi or Sayee to set up the daily scrum call? (farheen_att, 15:36:34)
    8. ACTION: bryan: add this to the jira dashboard under training. (farheen_att, 15:37:19)

  4. Status (farheen_att, 15:37:43)
    1. Mukesh: Based on my assessment the ONNX and PFM model functionality. This impacts portal. Mukesh: One of the requirements was to create a MS on the fly. We want to create a MS for ONNX and PFA models. We never evaluated the impact. Do we go with this requirement of creating a MS it is system wide impact. Anwar: If we don't then what? Mukesh: If you drop and ML file or artifact then it will cause system wide (farheen_att, 15:40:36)
    2. without UI. Anwar: Go through your web socket or web server. Mukesh: There will be an input output issues with performance. Bryan: Its straight forward. Anwar: when you onboard a PFA or ONNX model will it be in their original format? Phillippe: It is only planned to only upload the ONNX PFA. A: Does it matter what language? P: No we don't care about the language. A: That's good. When you do dockerization d (farheen_att, 15:43:02)
    3. Phillippe: I don't know how that will work with ONNX or PFA. Manoop: I believe they choose one type of language. Going forward they will open it up if you provide the targeted environment then it will build. If not there is a default format. (farheen_att, 15:44:47)
    4. Phillippe: I added some description on API regarding dependencies. We are at 90%. No issues or blockers. Anwar: Data management catalog? Chris; Finished everything that is in jira. A: Based on discussions on training now that we have a clear laid out plan. Getting started with that is a number one priority. There will be new artifact types. I'll bring it down to 50. (farheen_att, 15:46:24)
    5. Anwar: Training? Bryan: 10% (farheen_att, 15:46:49)
    6. Design studio is under ML workbench. I don't think this is updated. Kubeflow is out of Boreas. CMLP Rapid Miner will not be integrated. We should say nifi. From Arnaud Braud / Orange to Everyone: (10:43 AM)For ONNX you need to know the "target" deployment target
when generating the microservice
 From Manoop Talasila to Everyone: (10:46 AM) 
That’s right, we need to know the target env. So, the UI in P (farheen_att, 15:48:21)
    7. choose the target env details, which will be then passed on to micro service generation. Until such screens are developed, I believe team is planning to default to one target environment that they want to test the models.
 From Arnaud Braud / Orange to Everyone: (10:47 AM) 
Sounds good.
 (farheen_att, 15:48:42)
    8. Bryan: Deployment we just started the whitebox design so leave it at 80. YOu can replace kubeflow and seldon with nifi. Anwar: This whole thing has to come together at the end. How do we realize the value? Bryan: The deployment part is business as usual. The white box is going to be architectural Edge scale client. It looks liek the edge scale API is pretty simple. Security? We started Sprint 1 the wrapper. I (farheen_att, 15:51:26)
    9. License Mangement: Michelle: We're discussing design. Alex is the AT&T who is contributing code. Are you working with Ericsson, Nokia, Hwawei, and Orange? Yes, they are all involved and Alex is coming up the design. It is different then what was originally planned. we're going to update pictures to see what. Anwar: What is the end product. Michelle: We're going to define the default license and store it out (farheen_att, 15:53:45)
    10. And there is going to be an entitlement defined. When the use purchases the licenses the description would be viewable. Offline the decison making offline with an API talking to security verification. Anwar: Will you track deployments? M: You must check to see if you have entitled to deploy the model. As far as tracking Ericsson is going to track so a future release we will control but for now we want to track (farheen_att, 15:56:37)
    11. Manoop: We are at a stage we know the design. Should we work with the test team to open up test cases? Yes. Every time we meet we keep talking about it. (farheen_att, 15:57:25)
    12. ACTION: Ken Licensing and Training test cases can be created for sprint 2. (farheen_att, 15:58:28)
    13. training MVP scope for boreas - https://wiki.acumos.org/display/TRAIN/Boreas+design+notes (talasila, 15:59:20)
    14. Anwar: Make sure you have the test cases. Ken PTL meeting we approved the test cases. We sent out the report to Deepti. (farheen_att, 15:59:59)
    15. Bryan: Platform OAM maintenance of the logs. Like many things we're going to start accumulating a lot of stuff. We're looking to snapshot. There will be a new component called the ELK client. Ability to retrieve snapshot. New APIs One to invoke backups and one for the schedule. So the admin can have (farheen_att, 16:02:00)
    16. Anwar: I see gaps escalate with TSC where you finds gaps. We are clearly not at the point where we should be for the second and third week of development. We have made some progress what we need to do for training and there are a lot of gaps. Michelle: My M2 checklist says it's in progress. Deepti: We are setting up a dashboard. Anwar: Be proactive and clear and it's your job to bring any gaps to our attentio (farheen_att, 16:04:12)
    17. Consisteny. Training is an example. Manoop: Should we change the dates? This should be at 100% or close to 100 and architecture work needs to be done. Nat: We are at least one and half to two weeks behind. We were supposed to have this completed in the next two weeks. (farheen_att, 16:06:07)
    18. ACTION: Nat use email to send status next Monday. Anwar: Mukesh ensure that implementation that you Bryan and Kazi are planning to do. Manoop: If we are not at a stage of unable to catch up then we should change the dates. I propose sprint 1 will be pushed to 1/25. Anwar: We have adjusted by removing kubeflow. Let's see the report from Deepti and Nat so we can have demos. (farheen_att, 16:08:20)
    19. Thank you! (farheen_att, 16:08:29)


Meeting ended at 16:09:12 UTC (full logs).

Action items

  1. Sayee: By end of day tomorrow lets get an agreement between Sayee, Manoop, and Bryan have a joined agreement on this topic.
  2. Kazi: have Adi or Sayee to set up the daily scrum call?
  3. bryan: add this to the jira dashboard under training.
  4. Ken Licensing and Training test cases can be created for sprint 2.
  5. Nat use email to send status next Monday. Anwar: Mukesh ensure that implementation that you Bryan and Kazi are planning to do. Manoop: If we are not at a stage of unable to catch up then we should change the dates. I propose sprint 1 will be pushed to 1/25. Anwar: We have adjusted by removing kubeflow. Let's see the report from Deepti and Nat so we can have demos.


People present (lines said)

  1. farheen_att (40)
  2. collabot` (3)
  3. talasila (1)


Generated by MeetBot 0.1.4.