#acumos-meeting: architecture committee

Meeting started by farheen_cefalu_a at 14:59:44 UTC (full logs).

Meeting summary

  1. Agenda Licensing and Training. (farheen_cefalu_a, 15:05:12)
    1. ACTION: PTLs assign user stories to sprint 2 (farheen_cefalu_a, 15:05:27)
    2. ACTION: Adi and Sayee provide user stories and scope (farheen_cefalu_a, 15:07:04)
    3. Add federation to the agenda and add independent ms generation. Ken wants federation, Guy wants independent user and Bryan wants K8 from platform deployment and system integration. Ken what is the fed topic? The federation of catalogs and fucntionality of the gateway is blocking federation. (farheen_cefalu_a, 15:09:22)

  2. Licensing Michelle Martens AT&T (farheen_cefalu_a, 15:09:43)
    1. M: I'm review MVP with boreas. We put in the jira user stories. A few may need to be tweeked. I'm going to go through the table for impact. From a model owner perspective we are enabling association of model license when onboarding or publishing a model. A human readable text file. There is ability to upload the license. The publisher will be able to check for license before publishing to public. Compo (farheen_cefalu_a, 15:12:12)
    2. not mixed licenses for composite solutions. When federating the license will be included. LUM License usage manager won't be ready for Boreas but will be delivered in Clio. Reviewed LUM diagram. Manoop: If LUM is not available or will the ETE flow be functional? Yes, we will have ETE flow functional but will have minimal complexity. From supplier perspective the publisher approves the model license exist (farheen_cefalu_a, 15:15:33)
    3. license is what the model owner uses for the model. A user that wants to use the model they will find a model and review the terms and conditions for that model and will purchase the entitlement It's a text file that gets communicated through the catatlog. From user perspective they find a model they will have to go through their existing asset management and purchase the license in order to use the model. (farheen_cefalu_a, 15:17:26)
    4. details for use with model. We're going to support a presence of that entitlement. Security verfication will check that license exists in order to download or deploy the model. Security verification will handle the actions requested. They will call LUM. Right to use will be a list stored in CVS. LUM will call the API does this license exist. If it does exist allow download or deploy to exist. Question: (farheen_cefalu_a, 15:19:57)
    5. will not allow a limit to the entitlements. For Boreas we are only validating the exists or not. There are jira user stories already established for these. Manoop: Download and deploy jira issues have to be assigned to a sprint. That will help release management plan for demos. Is this impact to security deployment team committed? and portal? Michelle: we are targeting for sprint 2. We're having meetin (farheen_cefalu_a, 15:22:07)
    6. ELK logging will be tracking. There is no impact from the License management team. Bryan: That will be an item we will put in jira. Michelle: Next item Ericsson is providing API tracking of their model. We are looking for Orange contribution to define the text file for the model license and entitlements and user stories. (farheen_cefalu_a, 15:23:54)
    7. Anwar: is API specific to model or generic? They will come up with any model. We are going to be talking about those details today and tomorrow with Guy. Manoop: Wen Ting may be on the call will they be using the 5G use case? Yes but I don't know the details yet. Bryan: We support the ability to onboard docker images so the vendors have opportunity to embed models for tracking. (farheen_cefalu_a, 15:25:43)
    8. Michelle: Showing the wiki.acumos.org Boreas MVP Outline shows the details of getting started. Bryan: There is no api we are going to build in this release. Just an interface between lum and security library. The only API will be the usage tracking api and we haven't figured out which component will deliver this. (farheen_cefalu_a, 15:28:03)
    9. Anwar: MVP is listed as set points for the main features? Yes plus the onboarding text file for the catalog. The other thing that's missing is the actual creation of the license manager library. Bryan: that's implied. Michelle: This should map to the table I was just showing. (farheen_cefalu_a, 15:29:47)
    10. Michelle: Allowing for the model license to be associated with the model and the right to use associated with user and the right to download and deploy. (farheen_cefalu_a, 15:30:31)
    11. Michelle: Everyone should have their internal procurement process. Supplier Mgmt. processes is outside the scope of acumos. Asset mgmt happen outside of acumos. Anwar: Let's make sure that we can display a use case that shows how it works when it is working. We don't have sprint plans for this development cycle. We're having meetings today and tomorrow. Manoop: I see under release planning you have sprint (farheen_cefalu_a, 15:34:09)

  3. Training (farheen_cefalu_a, 15:34:28)
    1. Manoop: We captured users stories that have been committed for Boreas. There are user stories mapped to sprint two. (farheen_cefalu_a, 15:34:52)
    2. ACTION: Kazi and Mukesh start mapping your user stories to sprints. Are you still working on finding the resources. Mukesh we are going to review the wireframes. Committed resources? My management will get back to Anwar. (farheen_cefalu_a, 15:35:51)
    3. Bryan: We have a plan and we're starting in this sprint with the integration of components. Some aspects are unsettled. for example how do you manage the artifacts? We have to test out the space of options to find what's feasible in this release. That's where I am. (farheen_cefalu_a, 15:36:43)
    4. Manoop: any serious blockers on training. (farheen_cefalu_a, 15:37:01)
    5. ACTION: Nat get resources re-allocated from other components to the training models on the TechM side. We all agree in terms of priority and associate the resources there first. There are 40 resources on TechM side. AT&T can assist to reallocate. Mukesh: there was an internal discussion and my mgmt will get back to them. (farheen_cefalu_a, 15:38:23)
    6. CMLP side will have resources on the training module and there are already resources that will assist. (farheen_cefalu_a, 15:39:12)
    7. Kazi: ML workbench UI and the ML workbench backend. When the call is made what is the implementation details of that call. Each of the API calls is what I am doing now. Right now I am working on the implementation action business logic. Just as I have documented for DS earlier. I am working on create update delete project, notebook, and pipeline. I have found hickups that I have to review with the CMLP a (farheen_cefalu_a, 15:41:22)
    8. L workbench. Manoop: As long as your user stories are components, epics, and sprints. My concern is I know your team has done development but is now showing up here in the release management list. (farheen_cefalu_a, 15:42:28)
    9. ACTION: Nat update release notes to reflect. (farheen_cefalu_a, 15:43:13)

  4. Status (farheen_cefalu_a, 15:44:53)
    1. Portal keep at 85% Onboarding is on track and 100% including dependencies. (farheen_cefalu_a, 15:45:27)
    2. ACTION: PTLs review APIs that are provided by other PTLs. (farheen_cefalu_a, 15:45:56)
    3. Chris Lott: I have no update to the percentage Kazi's team have identified the licensing needs. Michelle's team has not defined the data needs. Michelle: I hope to discuss it today or tomorrow. Chris: No progress. (farheen_cefalu_a, 15:47:08)
    4. Manoop: For training we have the functionality that has been covered for MVP? Are we still trying to close gaps. We are clear on what can be developed. functionality has been extensively discussed. Manoop: We can increase to 50% because we have MVP functionality and design. (farheen_cefalu_a, 15:49:06)
    5. Bryan: If we restrict this measure to what we know we are committed to delivereing it's somewhere in the realm of 50%. If we still have ambitions that include the project teams it gets fuzzier. Are we going to accomodate the new workbench under the existing CDS model or are we going to create a new super set data model? IF we don't settle on that question I'm less confident that its 50%. (farheen_cefalu_a, 15:50:42)
    6. Kazi: What are the backend artifacts that manage their lifecycles. We will be able to incorporate the project, pipeline, and notebook. Data sources data sets and predictors no. It requires a lot of changes in the nifi UI. Project, pipeline, notebook is MVP. Only projects owned by a different user. We have a little bit of dta model work. If it's a slight enhancement to the data model. (farheen_cefalu_a, 15:53:13)
    7. Anwar: I'm assuming the design work is in progress and should not be checked off. Notebooks and Nifi are not designed yet. We are in the design state we have done the design of the data model and apis. Now we are doing the design behavior and business logic. I will keep it at 60%. (farheen_cefalu_a, 15:55:31)
    8. For deployment the design is there. The dependencies have to be worked out with Mukesh and Chris. At the moment the white box is looking less possible in this release. I don't have committed resources. I'm less confident. Model lifecycle management is a medium. Not a high priority. Deploy start, stop we don't have a set of goals. That's been dropped down. Kubeflow is clio. Security is the same. (farheen_cefalu_a, 15:57:49)
    9. Guy: 90% Dependencies are left. We have a few jira items that are going to be done in the later sprints. (farheen_cefalu_a, 15:58:24)
    10. We reviewed MVP for licensing. Michelle: Keep it at 80. Do we know the overall design. M: I want it confirmed. APIs are being defined at this point. (farheen_cefalu_a, 16:00:06)
    11. #info https://wiki.acumos.org/display/CS/Impacts+of+Independent+Microservice+Creation (talasila, 16:03:00)
    12. Guy: Sharing Impacts of Independent MS creation (wiki.acumos.org). I've listed the biggest changes to portal. I have place holders for jira items. I'm wondering if the component owners want to build them. We need to replace the build for ONAP button with build for MS button. Design Studio needs to be able to deal with the fact that not everything is composable. Currently DS requires the URL that will be i (farheen_cefalu_a, 16:03:05)
    13. This lives under boreas release under common services. Component owners may be happier. I posted this link in the meeting. (farheen_cefalu_a, 16:04:39)
    14. https://wiki.acumos.org/display/OAM/Supported+Platform+Deployment+Approaches (talasila, 16:05:03)
    15. https://wiki.acumos.org/display/OAM/Supported+Platform+Deployment+Approaches (farheen_cefalu_a, 16:05:04)


Meeting ended at 16:05:08 UTC (full logs).

Action items

  1. PTLs assign user stories to sprint 2
  2. Adi and Sayee provide user stories and scope
  3. Kazi and Mukesh start mapping your user stories to sprints. Are you still working on finding the resources. Mukesh we are going to review the wireframes. Committed resources? My management will get back to Anwar.
  4. Nat get resources re-allocated from other components to the training models on the TechM side. We all agree in terms of priority and associate the resources there first. There are 40 resources on TechM side. AT&T can assist to reallocate. Mukesh: there was an internal discussion and my mgmt will get back to them.
  5. Nat update release notes to reflect.
  6. PTLs review APIs that are provided by other PTLs.


People present (lines said)

  1. farheen_cefalu_a (42)
  2. collabot` (3)
  3. talasila (2)


Generated by MeetBot 0.1.4.