15:02:55 <farheen_cefalu_a> #startmeeting Architecture Committee
15:02:55 <collabot`> Meeting started Thu Feb  7 15:02:55 2019 UTC.  The chair is farheen_cefalu_a. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:55 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:55 <collabot`> The meeting name has been set to 'architecture_committee'
15:09:17 <farheen_cefalu_a> #topic Project status
15:10:05 <farheen_cefalu_a> #info Michelle: Licensing team needs a java developer. We need a java devloper to create the library.
15:10:46 <farheen_cefalu_a> #action Michelle post the gap on the acumos developer community mailing list.  Call for java developer.
15:12:05 <farheen_cefalu_a> #info Bryan: It doesn't have to be java.  They can be Python, C++, Go. Anwar: Can Alex take care of that?  He is busy with LUM developing.
15:13:01 <farheen_cefalu_a> #action Nat Make the TSC aware of this gap in Licensing.
15:14:06 <farheen_cefalu_a> #info Michelle: The tracking will probably start in Sprint 2 but Ericsson is not confident they will get a lot in Sprint 2 but more in sprint 3.  We are defining the text file that gets associated with the model and the catalog.  I am not sure.
15:14:49 <farheen_cefalu_a> #info Bryan: Definition of the text file is done.  It's business as usual.
15:15:15 <farheen_cefalu_a> #info Bryan: Security verification is a work in progress.  Making a skeleton in sprint 2.
15:20:14 <farheen_cefalu_a> #topic Mukesh: We will be implementing catalog sharing in Boreas.  Manoop: APIs? Mukesh: Everything will be consumed.  Catalog sharing may not be in Boreas release.  Manoop: Reduce the scope to the simple creation of a catalog screens because the backend work has been done by CDS.  Mukesh: We have resource constraints and will have to drop something.  We are pretty much done with ONNX.  We are at 95%.
15:23:40 <farheen_cefalu_a> #info Manoop: What about dependencies?  Mukesh: Keep it open for now.  Manoop: Model onboarding Philippe.  Philippe: Regarding white box and kubeflow in my opinion this should be moved out of the model onboarding. Manoop:  We put support for White Box support during the time of onboarding.  Bryan: It's an ARM target. Manoop: Is there support we need from onboarding?  Bryan: no.  Bryan: Deployment to white box is at
15:25:37 <farheen_cefalu_a> #info CDS Anand: We are behind and waiting for Training user stories.  Kazi's team will be sending a wiki page requirements.  Bryan: the design is still in discussions.  ETA: ASAP.
15:32:24 <farheen_cefalu_a> #info Training: Wireframes will be provided on Friday.  Kazi: Training will remain at 40% the wireframes will be reviewed on Friday.  Bryan: We are not near the completion of the design.  Ken: we have one more week left of the sprint.  Will we get the code for the Design Studio. Sayee: By the end of next week we will have a high level plan.  Bryan: There will be no code to test for Sprint 2.
15:35:26 <farheen_cefalu_a> #info Bryan: Deployment: No code and 0 contribution.  Openshift I have not yet started.  kubeflow no work.  Openstack code has been delivered on sprint 1.  We have progress on the legacy client.  There is no plan for whitebox.  It is at risk.  Model lifecycle management has zero definition of what the goal is.  NXP there is a page on the wiki which says exactly where we are.  This is not a good use of this time.  S
15:36:26 <farheen_cefalu_a> #info in this sprint.  Manoop: Are the APIs defined? Bryan: complete and published on docs.acumos.org.
15:37:14 <farheen_cefalu_a> #info Guy: Common services.  No APIs.  We are not at 100% yet.  There is a model runner that needs to be finalized and that's it.  Let me finish that next week.
15:38:07 <farheen_cefalu_a> #info Licensing: Michelle: Design is done but there are still open dependencies.  We may tweek the design.
15:41:06 <farheen_cefalu_a> #info Adi: Go with Mongo and everything is done open source.  Bryan: ATT would never approve non open source licenses.
15:42:31 <farheen_cefalu_a> #info Adi: When you build ms one of the design choices you make you manage the data with the ms.  Anand: Apart from the licensing issue we have a star schema is a concern.
15:44:23 <farheen_cefalu_a> #info Manoop: As long as you don't replicate the nosql database you should be fine.  Adi: We are going to stay away from your monolith database to this ms database.  Manoop: That means we are saying that we will not support requirements of the user roles and the level of security they need.  The moment you say the user needs that then based on their roles they will have to replicate the data model.  Adi: Why can't
15:46:50 <farheen_cefalu_a> #info then each ms will be going to two databases.  Adi: Be specific. Bryan: AcuCompose will need it.  Adi: Why can't it be looked up?  You are doing document based lookup.  You're not doing multi-table joins.  The main thing you are dependent upon are the lookups.  Bryan: Notebook models and Nifi pipelines is information that has to be looked up on the backend databases.  The other thing is that there are joins in
15:48:31 <farheen_cefalu_a> #info Joins for right to use licensing.  The data for those artifacts will be split across these two databases.  Adi: I hear you Bryan.  Sayee: Pros and cons even if we go with the language.  NoSQL is good.  Better to go there and away from MariaDB.  Bryan: I would support you if it is self contained.
15:51:23 <farheen_cefalu_a> #info Kazi: It's a good thing to add couch or Mongo db.  Bryan: The user table is used in joins.  I'll leave it to the experts.  There are philosophical and technical arguments and we need Chris Lott (PTL).
15:54:19 <farheen_cefalu_a> #info Manoop: Adi can you point out in short what is your strong argument.  Adi: My sense that Chris was in agreement.  Chris is important.  Bryan: If we have the PTLs concurrence we need to understand the rationale.  Adi: To the other point my strong opinion.  The key constraint we have from CMLP is kubernetes.  I think it is a good thing but it comes with problems.  K8 doesn't share with database.  When you choos
15:56:37 <farheen_cefalu_a> #info function stay together.  The pros and cons should append only one thing in the architecture.  It does lead to complicated deployments but that comes with the territory.  When you go to a horizontally paradigm.  Two styles asset and caps style of asset management.  Non asset follow the cap theorem. AWS cloud is CAP compliant.  Microdatabases for ms.
15:57:48 <farheen_cefalu_a> #info Manoop: Schedule a call with chris lott and adi about core database and tranactional issues.  If we don't want to couple the platform db with couch db then we need to agree.
15:58:31 <farheen_cefalu_a> #action Manoop: Set up a call with Adi and Chris Lott regarding coupling platform and couch dbs.
16:00:46 <farheen_cefalu_a> #info Bryan: Some other member of acumos is going to bring in their own database.  We need to have a facade.  Manoop: Let's take this to the design call for Monday.  Mukesh: That will add to the implementation timeline.  Manoop: I will move the rest of the topics for next week.
16:01:11 <farheen_cefalu_a> #endmeeting