15:11:05 <farheen_cefalu_a> #startmeeting Architecture Committee
15:11:05 <collabot`> Meeting started Thu Feb 14 15:11:05 2019 UTC.  The chair is farheen_cefalu_a. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:11:05 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:11:05 <collabot`> The meeting name has been set to 'architecture_committee'
15:11:23 <farheen_cefalu_a> #topic status
15:13:11 <farheen_cefalu_a> #info Michelle: We have resources from Ericsson fro License manager library.  We started talking about the development yesterday to help them understand what is involved.  Developers will start next week. We have sufficient resources Nimish: Ericsson will be taking the development lead with the licensing.
15:14:37 <farheen_cefalu_a> #info Sayee: Can we consolidate ML workbench resources: Kazi: We have 3 techM resources.
15:16:45 <farheen_cefalu_a> #info Ken: We had meetings about federation wireframes. How should should the receiving catalog get received?  In private, company, or public. Anwar: this has to be designed and discussed.  Chris is the lead on this.  Work with Chris.
15:17:50 <farheen_cefalu_a> #action Farheen, Ken, and Chris get together over the federation. Anwar: Jack has talked to TechM to provide resources for this and have it on Boreas.  Mukesh: No we didn't meet after Raj's discussion.
15:18:43 <farheen_cefalu_a> #action Nat get an update on how many resources TechM can provide for Federation later today.
15:21:11 <farheen_cefalu_a> #topic We have portal platform concerns.  Bryan: This is a discussion point I raised.  We can't scale the variety of ways to deploy this platform.  The current things that people do right now component, hand editing configuration files, we need to move beyond that.  We can support kubernetes and openshift.  We have needs to establish a process of how these platforms are maintained.
15:22:02 <farheen_cefalu_a> #info Anwar: Do you have developers for deployment, security?  Bryan: Amit, Santosh.  Anwar: I heard that you don't have dev resources.
15:23:15 <farheen_cefalu_a> #info Bryan: I would benefit from additional support with the scalability of the way you assume how you deploy this platform.  They are to me a critical enabler to adopt this platform.
15:24:18 <farheen_cefalu_a> #info Bryan: Certain features may not be deployable in a docker environment vs. kubernetes.
15:24:46 <farheen_cefalu_a> #info Anwar: that is definitely a critical area we need to make progress on.
15:26:19 <farheen_cefalu_a> #action Team: Any requirements discussions should be brought to the Product Committee.  Any design technical api work has to be reviewed by the Architecture committee.  Let's define and agree on all the requirements in the product committee and architecture committee.
15:30:44 <farheen_cefalu_a> #info Chris Lott will lead decisions about databases. Chris: We analyzed the licenses.  Picking couch is an easy the harder decision is how much goes into couch and how much goes into CDS.  If they need to do things into the existing Acumos they could.  this is a workable solution to have a workbench integrated with acumos and not have them affect the other components.  Anwar: We don't want to distribute the databa
15:32:44 <farheen_cefalu_a> Sayee: I agree with Chris with nosql and was able to create a few records and a change of attributes and data elements.  I would recommend to go with NoSQL.  Anwar: And you know that in light that MariaDB has NoSQL support?  S: MariaDB is not supporting.  We are not supporting long term.  Meaning ATT TSS standard is not emerging techonolgy.
15:34:04 <farheen_cefalu_a> #info Adi: Couch based. Bryan: I am OK as long as there are clear instructions on how it is deployed and configured.  Bryan: We will have to see what are the constraints and resource.
15:35:29 <farheen_cefalu_a> #info Have you looked into deploying couchdb.  Chris: No I have not.  It will another docker container.  Bryan: there are configuration, security tasks that have to be though through.  I am not going to do the research for them.
15:37:34 <farheen_cefalu_a> #action Chris ensure that deployment team is OK with the deployment team.  Bryan: I thought CMLP team as taking this on.  Anwar: This has fall under the overall data layer that Chris owns.  I didn't think that Chris has signed up for the couchdb data extraction.  A: It's not one person who is going to do but the PTL has to oversee.  I don't want ML Workbench to create their own silo.
15:38:23 <farheen_cefalu_a> #info Nat: There is a legal issue with couch_base is not Apache 2.0.
15:41:26 <farheen_cefalu_a> #action Nat: Confirm with Ibrahim that couch-base is OK.  A: Tell him to let us know by today or tomorrow.  Couchbase community.  There are two 1. couchdb and 2. couchbase.  Adi is suggesting the couchbase community edition it is Apache 2.0.  Adi: Look at the website.  I don't think we need high performance query execution not required.  If you bring up the site there is nothing in the comm. edition that is lacking
15:44:11 <farheen_cefalu_a> #info Adi we don't need it for incremental backups.  Bryan: What about security?  There is no standalone couchdb container.  Adi: I said in a deployment we are not going to have an integrated couchbase.  Adi: One way we do couchbase is couple it with the container services and dbs.  B: Do you mean a pod or an individual docker?  Adi: A deployment contains a pod.  Bryan:  Will it be a separate pod?  Either it's a co
15:45:41 <farheen_cefalu_a> #info deployments over name spaces, or a route.  It needs to be defined.
15:46:33 <farheen_cefalu_a> #action Nat work with Ibrahim who on the LF side is able to tell us yes/no couchbase community edition from LF point of view.
15:48:03 <farheen_cefalu_a> #info Anwar; We will check with ATT legal team.  Bryan: couchbase comm. edition does not support deployment on openshift.  That will not work.  Bryan: caveat if we can figure out if we can make this work that's another thing.
15:49:20 <farheen_cefalu_a> #info Kazi: Both are Apache 2.0 license.  Recommendation from AT&T architects to use couchbase.  Couchdb is apache 2.0.
15:50:29 <farheen_cefalu_a> #info Anwar: The team has to keep both options open.  Adi: The difference is couchbase includes memory in cache.  They combined couchdb and couchbase to make it faster.
15:51:28 <farheen_cefalu_a> #info Bryan: We have to test the constraints that it has.  We need to id how we intend to deploy this as part of the platform and those need to be recommendations of the people who depend upon it for their components.  Anwar: Our deadline is tomorrow to get this decision finalized but I want to nail it today.
15:51:43 <farheen_cefalu_a> #action Nat check the licensing issue with ibrahim.
15:53:13 <farheen_cefalu_a> #action Farheen check with Umesh whether or not there is an issue with using couchdb or couchbase
15:53:55 <farheen_cefalu_a> #info couchbase.  Chris and Adi and Sayee collectively spend time on this today.  If we want to make progress or make a decision everything is going to fall back to Mariadb.
15:54:57 <farheen_cefalu_a> #action Adi Sayee Bryan deployment issues between couchdb and couchbase community edition both are Apache 2.0 license.
15:57:02 <farheen_cefalu_a> #info Bryan: In the future we have to have the research done prior to designing the system.
15:57:37 <farheen_cefalu_a> #info Nat: there is no weekly meeting on Friday.
15:58:08 <farheen_cefalu_a> #action Nat: Can you put 30 minutes tomorrow so we can circle back and know where we are.
15:58:12 <farheen_cefalu_a> #endmeeting