15:06:47 <farheen_cefalu_a> #startmeeting Architecture Committee
15:06:47 <collabot`> Meeting started Thu Feb 21 15:06:47 2019 UTC.  The chair is farheen_cefalu_a. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:47 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:06:47 <collabot`> The meeting name has been set to 'architecture_committee'
15:07:07 <farheen_cefalu_a> #topic Change of database for Design Studio
15:07:52 <farheen_cefalu_a> #info Bryan: we want to use Mariadb for delivering the training and ds features.
15:08:39 <farheen_cefalu_a> #topic update score card
15:09:09 <farheen_cefalu_a> #topic Model Onboarding
15:13:11 <farheen_cefalu_a> #info Phillippe: We will have an api  for productized model.  Will be implemented on the portal side.  ONNX and PFA backend is done we are working on wireframes of the portal.  I am working with Vinaik from TechM.  Licensing and ms creation are working on to create the ms after onboarding.  The onboarding api is ready and left with modification of the client and wireframes
15:13:50 <farheen_cefalu_a> #info Bryan: I don't have time to work on kubeFlow.
15:14:01 <farheen_cefalu_a> #topic Data Management
15:14:50 <farheen_cefalu_a> #info Chris: working with Kazi for their CDS needs.  Licensing is implemented and delivered and running.
15:14:56 <farheen_cefalu_a> #topic Training
15:16:13 <farheen_cefalu_a> #info Bryan: Making progress on Jupytr Zeppeliln and starting with Nifi.  I'm still waiting for the training team to flush out the UX.  I've created demonstrations that notebooks can be onboarded quite easily.  Ready to give demos.
15:17:16 <farheen_cefalu_a> #info Anwar: removal of user stories?  The team is saying they are not doing Zeppelin we have to get the TSC approval to drop from Boreas.  They need to give a review.
15:19:27 <farheen_cefalu_a> #info Sayee: With respect to training.  We did the initial design on star schema and now we have redesigned.  We decided to go with one database approach that's Mariadb for now.  Flattening of tables to level 1 and level 2 to help us long term.  WRT development we have a UI approach finalized and how UI can be developed as a dev component.  We are talking through the path of UI to finalize by tomorrow.   Chris will
15:20:12 <farheen_cefalu_a> #info S: Zeppelin is there from CMLP perspective.  Bryan: I know how to deploy it but I don't know how much backend work has to be done.
15:21:57 <farheen_cefalu_a> #info Bryan: It's a little bit more then risk at this point. I need someone who understands the spawner for Zeppelin containers.  We may have to take a simpler approach.  There are still open questions.  Anwar: I heard we don't have MVP for training.  We have listed on the product call.  It has not been voted and confirmed by the product committee.
15:22:26 <farheen_cefalu_a> #info Nat: Kazi went through the review and will be voted for on Monday's TSC.
15:24:14 <farheen_cefalu_a> #info Nat: It was finalized on yesterdays meeting and Ofer will bring it to TSC.
15:24:34 <farheen_cefalu_a> #action Sayee: Review wireframes with the product committee team.
15:24:42 <farheen_cefalu_a> #topic Deployment
15:26:47 <farheen_cefalu_a> #info Bryan: We don't have an openstack environment where it can be tested.  Our lab team is no longer maintaining the open stack environment.  Anwar: Will the vendor manage now?  Who is going to manage?  My understanding is that the vendor openstack is working on this  We are working with redhat in tlab.  There are VMs allocated for running open stack environments in the azure vms.  Mukesh and Santosh are not expe
15:27:02 <farheen_cefalu_a> #info to take on responsibility.  I don't have time.
15:27:05 <farheen_cefalu_a> #topic Security
15:27:18 <farheen_cefalu_a> #info: making progress and on track.
15:27:26 <farheen_cefalu_a> #topic Common Services
15:28:11 <farheen_cefalu_a> #info Guy: I would say we're at 100% now.  We had the new model runner and it's on the wiki.  Now it's just a matter of martialing the troops.
15:28:17 <farheen_cefalu_a> #topic Training
15:29:08 <farheen_cefalu_a> #info Anwar: where are we with design.  Sayee: With the db design change we will have to rewrite.  We are at 60%.
15:29:25 <farheen_cefalu_a> #topic License
15:30:57 <farheen_cefalu_a> #info Bryan: We reviewed license in the security meeting and agreed it addresses the needs of the stakeholders.  We have the models logging in a running environment.  Guy has a plan to implement the model runner part of it.  We have the implementation of the license manager library.   We should be delivering in sprint 3 the initial user stories.
15:34:17 <farheen_cefalu_a> #info Bryan: For sys-integration we have to have a discussion with Chris.  We're starting to work from a bash based to a helm based.  Does this mean that people that are starting with docker are going to be shut out?   No they will still be supported but lower priority.  Bryan: In the end it will be much more easy to use.  Chris: External community is using docker.  Docker based seems to be popular.  Bryan: We are
15:35:10 <farheen_cefalu_a> #info Jupyter does not do docker as a platform.  We are going to do our best to support the Docker community as much as possible but we are putting our support on kubernetes and helm.
15:35:32 <farheen_cefalu_a> #topic Federation Catalogs vs. current design.
15:38:21 <farheen_cefalu_a> #info Nat do you have the plan for partner catalogs?  Nat: We are waiting for the MVP.  Can you put that on the agenda?
15:39:16 <farheen_cefalu_a> #action Farheen Get the MVP for Partner catalogs.
15:39:34 <farheen_cefalu_a> #endmeeting