15:15:07 <farheen_att> #startmeeting Architecture Committee
15:15:07 <collabot> Meeting started Thu Mar  7 15:15:07 2019 UTC.  The chair is farheen_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:15:07 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:15:07 <collabot> The meeting name has been set to 'architecture_committee'
15:15:56 <farheen_att> #topic Onboarding (Phillippe)
15:18:48 <farheen_att> #info Predockerized model.  Question Do you think it's possible for Boreas?  Mukesh: Was there a design?  Is this a pull or a manual upload of a docker image?  Best way is to use the docker push to push the image to Acumos.  If somebody has a dockerized image they can onboard we can simply upload that.  The problem is about authentication on Nexus.  Mukesh: Loading from UI is tricky.  http does not scale.  Use a docker
15:27:01 <farheen_att> #info artifacts id and uuid.  I don't know what naming convention to give.  Need to discuss and evaluate.  If you create a local docker registry then you have two repos.  The user has to know two there are two repos.  That presents a challenge to user acceptance.  There is a docker pull option as well.  Pulling from private docker registry into Acumos registry?  We don't want the portal storing credentials.  That's a de
15:28:25 <farheen_att> #info You need to do a docker login.  You need to give credentials to push.  Yes, like you deploy today the user is going to need to use their credentials to push or pull from / to the portal.
15:30:12 <farheen_att> #info We need to decide what is more intuitive and secure and inline with our current implementation.
15:32:26 <farheen_att> #info the design for our catalog is not virtual links.  Our catalog has to have the physical model in the catalog.  So we are talking about having the docker image. Anwar: Has the team decided?  Mukesh: There are credentials issues if we pull that image.  We have to provide a URL.  It is not scalable.  Docker push or pull with credentials and connectivity.  Guy: Either the push or pull approach there is a potential for
15:34:35 <farheen_att> #info layers.  It determines what it has to transfer and pushes an easier faster process.  Vs. Uploading and Downloading there will be a price to pay.  There is a potential for speeding up but Docker potentially reduces the amounts of bytes that go back and forth.  Phillippe: Do we include the third use case in Boreas?  Guy: For the second use case it's useful to know what state the proxy is in time.  Will the poxy be a
15:38:15 <farheen_att> #info in sprint 4.  Basic authentication will be in sprint 4.  So if docker proxy is available in sprint 4 we will not have enough time to code one of those use cases.  Why?   Docker proxy is one thing but we have to wireframe.  Not enough time with the workload.
15:38:33 <farheen_att> #info Anwar: At least one of the three have to demonstrated as a part  of the boreas release.
15:39:15 <farheen_att> #topic Partner Catalog
15:40:43 <farheen_att> #action Farheen bring Mukesh up to date wireframes.
15:40:53 <farheen_att> #topic License Management (Michelle)
15:43:42 <farheen_att> #info Michelle: We are not creating any new apis.  I want to show what is happening.  Justin is supporting (Ericsson).  We've created a new license manager component.  License manager will call the CDS API.  Chris already implemented this.  We are going to call the CDS API and provide back to security verification.  The other thing is the model activity tracking.  We're going to be leveraging the logging and apis suppor
15:44:01 <farheen_att> #info api's from license manager team for this release.
15:45:44 <farheen_att> #info Anwar:  Was this the last item that you had or is this going on in parallel with code development?  This is all happening now and it will be across sprint 3 and sprint 4.  Have we started entitlements, rtu. That is complete.  In the next sprint we will be using CDS.  The license component is in sprint 3 and the rest is in sprint 4.
15:46:16 <farheen_att> #topic Training
15:48:31 <farheen_att> #info Mukesh: We finalized the microservices and UI in the backend and have been named.
15:48:38 <farheen_att> #topic Scorecard review
15:50:50 <farheen_att> #info Portal Mukesh: De-scoping of user stories.  I need time to tie them to the epics.  Anwar: There are some that we have to keep.
15:57:04 <farheen_att> #info: Chris: I have the training teams requirements.  They have to test.  I am comfortable with the partner catalog requirements.
15:58:52 <farheen_att> #info Mukesh: Training omni components complete.  Have them running next week.  Is the ETE sprint planning available for review.  We haven't seen user stories added to sprint 5 yet.  We have 100+ for sprint 4 but none for sprint 5.  For all the sprints what will reviewed and demonstrated.
15:59:22 <farheen_att> #action Ken work with Deepti and Nat for an ETE workflow.
15:59:54 <farheen_att> #info Ken: There are 9 user stories for training.
16:01:06 <farheen_att> #action Kazi work with Ken.  When is the next demo?  Next Tuesday on the Community call.  Due to partial delivery he will be moving all of the user stories to sprint 4.  We have the code checked in but can't demonstrate it next Tuesday.
16:01:56 <farheen_att> #info
16:03:12 <farheen_att> #info DS wireframes.  Looking to Sayee.
16:03:56 <farheen_att> #info Bryan: We apply a lot of dicipline to push things to sprint 5.  We need to use sprint 5 as not open but a high priority.
16:04:32 <farheen_att> #endmeeting