#acumos-meeting: Architecture Committee

Meeting started by farheen_cefalu at 14:02:33 UTC (full logs).

Meeting summary

  1. Licensing Architecture review (farheen_cefalu, 14:14:17)
    1. Mukesh: Wireframes are a work in process for Licensing. Had a design discussion with Michelle and Bryan. Licensing onboarding is planned to be delivered in Sprint 4. (farheen_cefalu, 14:15:51)
    2. Michelle: We have to discuss adding a new tab on the model screen so you can view the model license where the signature tab is. Another tab will be added for license so you can view the artifact. We did use the license.txt in dev challenge. The design has changed and it is now a json file (artifact). (farheen_cefalu, 14:17:51)

  2. Bryan reviewing overall Architecture Roadmap for Clio (farheen_cefalu, 14:18:56)
    1. Bryan reviewed roadmap (farheen_cefalu, 14:20:25)
    2. https://wiki.acumos.org/display/AR/Boreas+Architecture (farheen_cefalu, 14:20:29)
    3. Bryan: We have three deployments which will collapse into templates of how models are built and deployed. #action Team update the description field of #link https://wiki.acumos.org/display/AR/Boreas+Architecture (farheen_cefalu, 14:21:39)
    4. Bryan: We have an opportunity in Clio to hand jobs off to jenkins (CI process). #action Team we need to start having discussions about these. (farheen_cefalu, 14:22:48)
    5. Bryan: I recommend people start putting your components as they evolve. Anwar: Concern that the team will have bandwidth to get started with Clio discussions. What are the main top features in Clio? Bryan: For AT&T it's to merge with CMLP. Deploying a run time view and much more CI/CD design. We use jenkins to manage the pipelines. That is the number one feature for the deployment project and I recommend i (farheen_cefalu, 14:25:42)
    6. effort is large and the ci will improve. Anwar: CMLP is the internal Ai platform that is merging with Acumos. This will bring many more features to Acumos that will improve the user ability to create and share models. There are some other things that were targeted for Clio. The extensions of how we are going to do the data, deployment pipelines. We have to review our original plans and see if we should rev (farheen_cefalu, 14:28:24)
    7. Design studio which is a java component. Interactions will be over the network vs. inside the box. These features are coming and we need to start having those discussions. (farheen_cefalu, 14:29:14)

  3. Feedback from PTLs (farheen_cefalu, 14:29:25)
    1. Anwar: What would PTLs like to see in terms of gaps and improvements. (farheen_cefalu, 14:30:09)
    2. Phillippe: No major gaps I can see. Perhaps next week. (farheen_cefalu, 14:30:38)
    3. Guy: I'm happy with the common services. I prefer we use jenkins. I would make ms generation tightly coupled with the onboarding app. Bryan: There's a dependency in their spring configuration that's why. Guy: The biggest most costly thing we do processing. The bottleneck needs to be cleared up by jenkins. I am in favor of jenkins and we have to make this work. We don't pull things out of the source repo t (farheen_cefalu, 14:33:08)
    4. Anwar: Enhancements besides jenkins? Guy: we need to expand to different kind of ms to build. Separating the ms build environment into more sophisticated. We still haven't gotten the test harness that will do code generation for you in using ms if they exists. Between deployment of ms generation we need to be better coordinate. Bryan: That will be addressed in rapid miner and nifi in Boreas and Clio. (farheen_cefalu, 14:35:09)
    5. Kazi: Design Studio. We will have nifi cluster that will give us a nifi environment for a single user. Do we have a nifi cluster? Bryan: Not clearly defined. How we are going to manage the single user container for nifi is not clear. Also we don't have the back end integration. In Boreas we have a lite integration. User is involved in onboarding of artifacts. Kazi: Kubeflow. In my humble opinion we shoul (farheen_cefalu, 14:38:00)
    6. chance. Sayee Training. We should do a good CI/CD. With respect to workbench we will have all he assets. We don't have a running model in Acumos today. That will help users connect nifi. This will help developers. Bryan: The run time view of models running will be a key feature in Clio. They will help developers to accomplish their goals. Nat: Sayee and Bryan do you mean run time embedded in Acumos or (farheen_cefalu, 14:40:48)
    7. run time extends beyond design time. Nat: So it is going to be connecting to a run time environment? Correct. (farheen_cefalu, 14:41:15)
    8. Nat: The point I was making is that every company has their own unique run environment. The model run time is unique case by case. We should give an option to connect to any of their run times then fine. Sayee: If I run a predictor in my enterprise I want to connect it. Both are feasible. The open source is contribution driven so we will focus on the common ground kubernetes. (farheen_cefalu, 14:42:58)
    9. Nat: We have azure openstack and k8. What is the intent for others? The process engine is jenkins and the recipe is a see template. Rather than encoding in java we develop it using jenkins job builder scripts. Will you duplicate that feature? We will go thru a deprication cycle. (farheen_cefalu, 14:44:52)
    10. Licensing Michelle: Major upgrades for Clio. Data Services Chris Lott: CMLP integration work. (farheen_cefalu, 14:45:51)
    11. Anwar: Let's finish Boreas strong. (farheen_cefalu, 14:46:40)

  4. PTL Score card (farheen_cefalu, 14:46:47)
    1. Portal Marketplace: Mukesh: We are on track. We have taken one story out and replaced it with Catalog Management. Anwar: In terms of completion for sprint 4 and 5. any gaps? (farheen_cefalu, 14:48:14)
    2. Mukesh: Instead of global search we've replaced it with global search. (farheen_cefalu, 14:48:50)
    3. Anwar: the demos for sprint 4 should cover 80% or more in Sprint 4. If we don't show that we will be behind. (farheen_cefalu, 14:49:37)
    4. Phillippe Onboarding: We met with Bryan, Mukesh, and Vinayak. We agreed to use what Bryan suggested. I have created jira onboarding for docker proxy. (farheen_cefalu, 14:51:08)
    5. CDS Chris Lott: I put out a draft version of CDS for workbench and training team. Please look at it and give me feedback now. Since I started asking two and half weeks ago I haven't heard anything. Anwar: Does any PTL anticipate change in their database layer? No. Anwar: For any changes that come up set up a deadline and share with the PTLs. (farheen_cefalu, 14:53:23)
    6. Training Kayee: I am working on use case. Mukesh is working on the nifi integration with the ML workbench. We have Bryan working on Jupyter integration. I also did a little POC on the pipeline and workbench. That will help in deploy in pipeline. I am working on the deploy pipeline. Anwar: Where are we with finishing up the design? Kazi: Mukesh (farheen_cefalu, 14:55:25)
    7. Mukesh's team has not defined how the nifi will be integrated with the workbench. Bryan: How do we manage single user containers for nifi and zeppelin. Mukesh: We will give a demo tomorrow. We have not chalked out about nifi instances per user. Are we going to show one notebook? It is in the critical path. Sayee: We want to loosly integrate. Anwar: At least the team knows the bare minimum way. Sayee: We (farheen_cefalu, 14:57:44)
    8. for Clio. Anwar: Concern that we are still at 60%. We are at 80%. Kazi: On design studio is 90 - 95% but training we will keep at 60% because we don't know how to integrate with nifi and jupyter. Bryan: We have an option to have these services work on the workstation. Anwar: At least bare minimum we should do what the CMLP team has done for nifi and zeppelin. If we can make it better than that should be t (farheen_cefalu, 15:00:36)
    9. Anwar: Keeping it at 60%. Mukesh: issue with proxy. (farheen_cefalu, 15:01:41)
    10. ACTION: Nat: Focus on Training deliverables. (farheen_cefalu, 15:02:00)
    11. Bryan: Security Kazi did a POC of a program in a nifi container. That is to be worked out as a design for the kubernetes client. We have the framework we have to make the template modifications. The other is flinc kafka etc including filebeat. There are at least 3 significant thing that has to be done. That is an open area for deployment. Security verification is coming together. We have the design persp (farheen_cefalu, 15:03:49)
    12. but we have something. Licensing: Michelle: We should keep it as is. (farheen_cefalu, 15:04:28)


Meeting ended at 15:04:33 UTC (full logs).

Action items

  1. Nat: Focus on Training deliverables.


People present (lines said)

  1. farheen_cefalu (38)
  2. collabot (3)


Generated by MeetBot 0.1.4.