14:00:39 <farheen_cefalu_A> #startmeeting Architecture Committee
14:00:39 <collabot> Meeting started Thu Apr 25 14:00:39 2019 UTC.  The chair is farheen_cefalu_A. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:39 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:39 <collabot> The meeting name has been set to 'architecture_committee'
14:04:17 <farheen_cefalu_A> #agenda ML Workbench demo (Kazi/Bryan/Sayee) Jupyter and Zeppelin Notebooks and integrated with Acumos, allowing the creation and training of AI/ML models.  Portal demo (Mukesh) security verification support. new licensing pages and support.
14:05:50 <farheen_cefalu_A> #info ML Workbench will be demonstrated on Tuesday 4/30 on the Community Committee call.  Nat unable to get a hold of Mukesh.
14:08:06 <farheen_cefalu_A> #info we don't have a quarom of PTLs.  Waiting 10 minutes to start.
14:12:16 <farheen_cefalu_A> #info Security verification pending few issues.  installation was done recently and requires test.
14:13:21 <farheen_cefalu_A> #info security verification calls licensing apis and they are tightly coupled.  security verification work in progress.
14:17:23 <farheen_cefalu_A> #info regarding left over issues for publisher role and federation in partner catalogs.  These are a work in progress and can not be demonstrated at this time.
14:18:14 <farheen_cefalu_A> #topic ML Workbench issues
14:19:49 <farheen_cefalu_A> #info Kazi: Bryan is on vacation and is dead locked with the authentication using Kong.  Handed off to Jackie. Jackie is abandoning Kong and trying to use Apache.
14:22:05 <farheen_cefalu_A> #info the blocker is integration issue with NiFi (deploying individual authenticated containers for users-finalize the design.  Kazi hopes that Jackie will be able to come up with a concrete solution by the end of next week.  Jackie is suggesting to create a proxy server.  Mukesh we need to have a working session to figure out what are the best dates to deliver.  Manoop: Estimated time?  We are in the ETE and have
14:23:20 <farheen_cefalu_A> #info can cover and get to the test team.  Nat: Plan is to work on kubernetes beta along with Docker compose with unauthenticated user.  Planning to bundle it in the maintenance release.  The team has to work on and see if they can make it to the maintenance release on 7/10.
14:24:23 <farheen_cefalu_A> #info two blockers.  K8 deployment is also a blocker.
14:24:50 <farheen_cefalu_A> #info Manoop: concerned that the test team does not have clear guidance of what to test when.
14:26:07 <farheen_cefalu_A> #info Nat: The docker compose build release for June 5th.  Mukesh will continue to work on All in One, Jupyter hub, and NiFi that will be released as beta.
14:26:54 <farheen_cefalu_A> #info Vaibhav: What is the plan for Jupyter hub plan?  There are no jenkins jobs.  How do we do it for environments like IST as a docker based jupyter hub.
14:27:22 <farheen_cefalu_A> #info Jupyter hub is not checked into gerrit.  Mukesh: Can we get it in the gerrit repo and do a gitclone.
14:27:48 <farheen_cefalu_A> #action Vaibhav check in the Jupyter hub into gerrit.
14:28:27 <farheen_cefalu_A> #info Vaibhav has a valid point that jupyter hub should be included for docker compose environment.
14:30:37 <farheen_cefalu_A> #info Nat: releasing K8 as beta in the boreas release.  maintenance release the team will try to bundle the nifi with authentication.
14:31:40 <farheen_cefalu_A> #topic Acumos ONAP integration
14:32:03 <farheen_cefalu_A> #info once materialized I will bring to the table.
14:32:26 <farheen_cefalu_A> #topic CMLP integration.
14:32:52 <farheen_cefalu_A> #info we will be focusing on these topics in the future calls.
14:33:47 <farheen_cefalu_A> #endmeeting