14:05:31 <farheen_cefalu_a> #startmeeting Architecture Committee
14:05:31 <collabot> Meeting started Thu May  2 14:05:31 2019 UTC.  The chair is farheen_cefalu_a. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:31 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:05:31 <collabot> The meeting name has been set to 'architecture_committee'
14:06:01 <farheen_cefalu_a> #topic Security Verification
14:07:36 <farheen_cefalu_a> #info Michelle: Justin will assist Ken with security blocker while Bryan is out.  #action Michelle: Inform Jack that Justin will be working with Ken for Security.
14:12:06 <farheen_cefalu_a> #topic Acumos-CMLP
14:12:18 <farheen_cefalu_a> #info Sayee is not present.  If he joins we will discuss the topics.
14:12:26 <farheen_cefalu_a> #topic AI for EU
14:15:29 <farheen_cefalu_a> #info AI4EU is a project.  A European project like Linux Foundation project.  The European commission launched the project and asked European companies to form this project.  AI4EU is to build an AI platform for European companies.  They chose Acumos as the platform.  They wanted to onboard a developed model with C C++ language.  Phillippe has colleagues that participate to the AIf4EU project.  Ai4EU is C, C++ clie
14:15:56 <farheen_cefalu_a> #info repo for client library for C, C++.
14:17:07 <farheen_cefalu_a> #info There is a formal process to creating repos.  Best approach is to ask for a separate repo like acumos-r, and java, python.
14:18:24 <farheen_cefalu_a> #info We should create a wiki page with this request for the onboarding project.  Send an email to TSC list pointing to the wiki page and they will decide.
14:19:18 <farheen_cefalu_a> #info The PTL of the project should create the wiki page.  #action Manoop send Phillippe the process to create the wiki page and submit your request.
14:19:40 <farheen_cefalu_a> #link https://wiki.acumos.org/display/INTTEST/Acumos+subrepos+for+CMLP+integration
14:21:08 <farheen_cefalu_a> This is an example of how to request a repo.  Be sure to mention that the teams are all in agreement.  Before we submit this request do we impact any of the onboarding processes?  This is on strong impact I see.
14:21:30 <farheen_cefalu_a> #info It impacts onboarding and microservice generation.
14:29:08 <farheen_cefalu_a> #info Guy: We discussed how to create a new client library and work with model runner.  Technical challenges: C++ we don't have CI/CD process to build and run scans to see those repos.  Work with LF that needs to be planned for.  Come up with tools and tool chains we need.  It is not as straight forward as java.  Where to host the library?  Is it Nexus Maven.  LF will accept / reject the request.
14:29:26 <farheen_cefalu_a> #info help desk is https://docs.releng.linuxfoundation.org/en/latest/helpdesk.html
14:30:25 <farheen_cefalu_a> #info Bryan is returning to office 5/6/19.
14:34:24 <farheen_cefalu_a> #topic ML Workbench
14:34:57 <farheen_cefalu_a> #info Guy has created steps to do a soup to nuts ML workbench.
14:36:37 <farheen_cefalu_a> #info Guy: It does what it needs to train and dump a simple model.  All of that will be incorporated into the new soup to nuts video.  There is a whole backend.
14:37:57 <farheen_cefalu_a> #action Guy share findings with Vaibhav.
14:40:01 <farheen_cefalu_a> #info There was an issue with returning to a notebook after leaving.  Vaibhav: Once we launch the notebook we can not control the notebook.  Manoop: We should put our own config file to disable them.  Vaibhav: Currently it's left to default. That frees up a lot of resources.
14:41:49 <farheen_cefalu_a> #info We are in good shape for ML Workbench and Training.  Ken and team are struggling to deploy Jupyterhub and modules.
14:45:44 <farheen_cefalu_a> #info Bryan was trying to launch Jupyterhub with Kubernetes.  Ken: We want a shell script.  This goes beyond jupyter notebooks.  Package would be nice.  ML workbench team.  Do you see this as a temporary.  Yes, Bryan said one click install will handle.
14:48:26 <farheen_cefalu_a> #info Are we planning to jupyterhub or all in one?  jupyterhub will be on docker compose.  Boreas release will have only jupyterhub.  If so then there should be a streamlined way of installing it.  There are well documented steps but you have to create files, certificates, drop them in directories.  There is a lot of moving stuff around.
14:51:02 <farheen_cefalu_a> #info Nat: We are moving towards Kubernetes.  This is the MVP.  Vaibhav: The moment I sent the script I was waiting for a ground level person to work with.
14:55:29 <farheen_cefalu_a> #info Viabhav we need admin user to be created the ssl, oauth variable.  How do we move from one to another?  One configuration file.
14:55:48 <farheen_cefalu_a> #action Vaibhav we can do a working session and streamline to make it better.
14:59:23 <farheen_cefalu_a> #info improving the installation will help.  #action Manoop, Guy work with Vaibhav.  Priya is out this week.  She should be back.  #action Ken schedule the call during the ms services meeting.
15:01:17 <farheen_cefalu_a> #info Manoop will work with Ting Lu to add ONAP Acumos integration.
15:01:56 <farheen_cefalu_a> #action Manoop: Michelle started the model activity tracking and wants to show a demo how we are tracking reporting through federation as well.
15:02:12 <farheen_cefalu_a> #action Manoop add Michelles topic to next weeks architecture call.
15:02:16 <farheen_cefalu_a> #endmeeting