#acumos-meeting: Architecture Committee

Meeting started by farheen at 14:03:45 UTC (full logs).

Meeting summary

  1. Agenda (farheen, 14:07:16)
    1. Design review for License Management: Any issues with design? Michelle: I have reached out to other PTLs so they are aware of who will be impacted by licensing. I have reached out to PTLs. Manoop: If the PTLs have issues with your design have them discuss in this forum. Or if there are no issues then we can review your design when you are (farheen, 14:10:03)
    2. ACTION: Michelle prepare for a design review discussion next week. (farheen, 14:10:25)

  2. Portal Team Design (farheen, 14:11:24)
    1. Mukesh: we had a discussion with Michelle around licensing. OA&M Vinayak was working on wireframe resources for the system. (farheen, 14:12:02)
    2. ACTION: Mukesh make a list by the end of this week for the changes for licensing. With the new template you should be able to respond to a template error or not. It is a new requirement. There is a requirement for templating. A template is for the license profile and have a generic template instead of a web form. Stored in glum or CDS. Simila (farheen, 14:18:58)
    3. ACTION: Mukesh update Bryans matrix about security verfication. (farheen, 14:20:08)
    4. OA&M is a house keeping step. BE process is ready but the FE UI needs to be developed. Manoop: Backup and purge will run weekly or monthly? Mukesh: Is it a cron job, syncrhonous, asynch. call? It is a threshold monitored call. Manoop: Is the BE service for backup and purge. Is it yes/no? Or are you looking for a UI? Parichay: Cronjob (farheen, 14:26:38)
    5. In sprint we are planning for improving the search design. I reviewed in the wiki. (farheen, 14:28:09)
    6. https://wiki.acumos.org/display/MOB/Clio+Release (farheen, 14:28:12)
    7. locality / internationalization and design has been done also. #action Manoop send Mukesh an email regarding locality and internationalization. #action Manoop target design reviews for localization / internationalization on the next meeting. (farheen, 14:31:06)
    8. Nat we should lower the priority of this item. We should be reviewing the design of the higher priority items. Keep this design review as a lower priority. (farheen, 14:32:30)

  3. Security Verification and Deployment Bryan Sullivan (farheen, 14:33:02)
    1. reviewed #link https://wiki.acumos.org/display/DEP (farheen, 14:34:24)
    2. Bryan Back to sharing deployment-clio.xml. Why do we need multiple clusters? Under shared services certain things have to be separated for security or resource management systems. Nifi and jupyterhub containers. Asked by stake holders not to be deployed just for the Acumos platorm. We have a VM in this release. I have deployed jenkins (farheen, 14:42:24)
    3. You may spin up a jenkins container for every job you want to execute. Likely use case. The amount of resources can vary widely depending on volume. Separate them out of the cluster support is an architectural design. We can break this further apart using K8 it's easier. That will be an explicit object to demon that I can across several (farheen, 14:45:57)
    4. Present: Bryan, Vaibhav, Santosh, Raman, Phillipe, Senthil, EugenGoal for sprint 1: deploy a simple model using Jenkins driven by Java APIs/client functions added to the k8s-client, per a seed that is patterned on those used by the AT&T platform.What is a seed: a seed is a set of files (e.g. as you would find in a git repo), that contains at (farheen, 14:46:52)
    5. Bryan: For this first week we will deploy a simple solution and connecting pipes together in an end to end flow. By the end of the sprint we will do this with an actual seed with the AT&T platform. We'll have a see with a sprint repo. We have to figure out where these seeds live. They can be further developed therefor needs a repo. We ca (farheen, 14:51:22)
    6. Manoop Sprint 2? Bryan: It's dependent on he outcome from the AT&T team. Right now deployment client doesn't plan anything to Azure or Openstack. Critical item is getting input from Sayee's team about what are the use cases? We have a deployment of a solution and a deployment of training features. Such as nifi, kafka, lynx. Then we have (farheen, 15:00:54)
    7. Nat - we are looking at k8 for clio so we have to have IST and development environments. Bryan: We have two VMs that are hosting on what we are doing right now. Nat - this needs to be communicated to the team and coordinate. (farheen, 15:02:13)
    8. ACTION: Michelle have a design review ready for the next meeting. (farheen, 15:02:35)
    9. ACTION: Mukesh have a design review for UI design in the next meeting (farheen, 15:02:57)
    10. Michelle we are not sure whether we will use CDS for licensing (farheen, 15:04:28)
    11. Chris Lott: For CDS not more than a few items for Clio. eNum value support. Manoop: is the enum value impacting other components. Chris: no. The caveat is anyone who wants to start using the eNum value. If they are in agreement fine. (farheen, 15:06:18)


Meeting ended at 15:06:23 UTC (full logs).

Action items

  1. Michelle prepare for a design review discussion next week.
  2. Mukesh make a list by the end of this week for the changes for licensing. With the new template you should be able to respond to a template error or not. It is a new requirement. There is a requirement for templating. A template is for the license profile and have a generic template instead of a web form. Stored in glum or CDS. Simila
  3. Mukesh update Bryans matrix about security verfication.
  4. Michelle have a design review ready for the next meeting.
  5. Mukesh have a design review for UI design in the next meeting


People present (lines said)

  1. farheen (46)
  2. collabot` (3)


Generated by MeetBot 0.1.4.