14:03:45 <farheen_cefalu> #startmeeting Architecture Committee
14:03:45 <collabot`> Meeting started Wed Jul 17 14:03:45 2019 UTC.  The chair is farheen_cefalu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:45 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:03:45 <collabot`> The meeting name has been set to 'architecture_committee'
14:04:06 <farheen_cefalu> #topic agenda
14:07:08 <farheen_cefalu> #info we will have to discuss the security verification.  Ken - I'd like to have a brief discussion so that everyone knows what's going on.
14:08:53 <farheen_cefalu> #info Agenda will be licensing (Michelle), archival process from the portal team (Mukesh), Boreas model tile re-arrangement (Murali, Vinayak), Docker compose issue (Ken).
14:09:16 <farheen_cefalu> #topic License Manager (Michelle)
14:11:27 <farheen_cefalu> #info with Clio we are taking lessons learned from Boreas.  We are going to implement a license usage manager component that will decide what actions can be approved/denied.  That will be in another architecture review.  For sprint 1 we are putting license profile with the artifact.  The second thing for sprint 1 is RTU.  Boreas it was yes/no for C
14:11:27 <farheen_cefalu> lios the license manager will store the meta data from the RTU.  Demonstrated the license press file.
14:12:47 <farheen_cefalu> #link https://wiki.acumos.org/display/LM/License+Profile
14:16:45 <farheen_cefalu> #info the license profile is a text file.  Security verification will confirm whether it is open or commercial.  If open then it's in the github repo.  If it's not then security verification will store including company, license type, and anything else the supplier provides.  We have user stories that have onboarding text and json files.  Portal wi
14:16:46 <farheen_cefalu> ll flow the license and text file.
14:21:29 <farheen_cefalu> #info We also have a web form for Boreas.  We will continue to host the web form.  We are going to try to make it easier for the model owner.  Their company should create a commercial license for their users.  Is the web form included in Acumos?  Justin - It's in gerrit.  It was in security verification.  It is a web component.  It can be brought i
14:21:30 <farheen_cefalu> nto another application through iframe or web component.  It is built on Angular8.  #action Michelle provide Mukesh with a link to the web form.
14:22:26 <farheen_cefalu> #link https://acumos-license-editor.stackblitz.io
14:31:42 <farheen_cefalu> #info changing the left side.  It takes a json file and infers a json schema to create the web form on the right.  The web form is tied to non-flat schema.  Current model is to create a nested structure out of it.  If you scroll down the right hand side we will add additional layers.  This was used as a stop/gap.  Mukesh - Has key value pair been d
14:31:42 <farheen_cefalu> e-scoped?  Justin The license scanner requires a key such as apache type and company.  That is done by the security verfication scan only.  When I add a license file is there a check for the duplication of a file?  Justin - validation is only at the form level.  We can add duplication checking but it is not in Clio.  Does this require CDS Changes?
14:31:43 <farheen_cefalu> There is an artifact entry in CDS.  Manoop - Treat it as a stand alone tool that will generate the license file and attach it to the local.  In the future we may want to improve by linking to the existing platform.  when you create a license you are selecting from drop downs.
14:41:23 <farheen_cefalu> #info There will be some standard licenses that don't need modification.  Guy - the data attributes has company, copywright, and software.  With this design it is more than just the license.  Manoop - I assume that the license picked from drop down.  I would download and upload the license with the changes. Example suppose you have repetitive compa
14:41:23 <farheen_cefalu> ny name such as Tech Mahindra.  Software Asset identification example needs to be unique to the model.  Michelle - This is not a legal license.  This is just information about it.  You need a license entitleement to use the license.  Tausif - Will the keyword have the actual license?  This keyword is for SV license scan.  They will take this and lo
14:41:24 <farheen_cefalu> ok in the repo to see if it's open source then it will look at the license config to see if is a commercial license.  Tausif - Do we have to iterate through the site config and SV?  Jason - There are scan tools to add your own commercial license.  As a platform operator there is the ability for the admin to add a license.
14:44:53 <farheen_cefalu> #info you have to add a license to publish a model.  Sayee - I create an open source but evolve to licensed.  Michelle - you can add a new license artifact.  this is done by version.  Manoop- when i update a new version for the same license.  Each version needs a license.
14:46:17 <farheen_cefalu> #info Manoop - do we send notifications for expiration? No, something to consider for Clio.  We still need to get an RTU and read it?
14:46:35 <farheen_cefalu> #top License RTU Michelle
14:49:22 <farheen_cefalu> #info For commercial license you have to contact the supplier and negotiate the contract and license terms.  The supplier takes the rules and asks them to populate the RTU file.  We are working on the design and format fo the RTU file.  We are defining some of the common terms.  Some of these use cases are talking about what restrictions or metrics
14:49:23 <farheen_cefalu> .  We are looking at hosting a web form and we need to figure out how to get the RTU file to the purchases and have them map their internal information in that RTU.
14:49:31 <farheen_cefalu> #link https://wiki.acumos.org/pages/viewpage.action?pageId=20547401
14:50:31 <farheen_cefalu> #info Justin - we are working on the minimal viable product for ODRL.  Michelle - RTU can be used with one or many models.
14:51:37 <farheen_cefalu> #info The rites can be applied to set number of users, actions, instances, or time period.
14:53:03 <farheen_cefalu> #topic Portal jira #3196
14:55:52 <farheen_cefalu> #info Vanayak demonstrated jira 3196
15:03:48 <earlyster> questions -- link the title to model details...should be added
15:04:06 <farheen_cefalu> #info Sayee are we using responsive design.  the text link for the tag will be fixed and "..." to
15:04:09 <earlyster> question -- l noticed in proposed design had new twice
15:04:52 <earlyster> What does it look like for a federated model vs same portal model
15:04:54 <farheen_cefalu> #action Parichay set up an a doc meeting with Manoop, Farheen, Ken and TechM.
15:05:36 <farheen_cefalu> #endmeeting