#acumos-meeting: Architecture Committee

Meeting started by farheen_cefalu_a at 14:03:36 UTC (full logs).

Meeting summary

    1. Agenda - Starting next week Manoop will send the agenda one day in advance with the agenda topics for that week. Any other topics on the call? (farheen_cefalu_a, 14:08:19)
    2. Bryan - at some point we are going to bring together the jenkins / camunda approach. #action Bryan Sullivan bring proposal to this meeting in the weeks ahead. (farheen_cefalu_a, 14:09:50)

  1. OAM - Parichay regarding Platform deployment as Jenkins as a Service. (farheen_cefalu_a, 14:10:24)
    1. Overall platform from two approaches. One approach is Docker compose and Kubernetes with Helm. Docker compose pre-requisites deploy core components portal fe, be, ms, and the configurations for non core components like mariadb and elk stack. And optional installation jupyterhub and Nifi. Both approaches are using Docker containers they dif (farheen_cefalu_a, 14:15:10)
    2. Sayee: When you deploy core component using helm chart. Does every component run on a single container or multiple containers. Parichay - All this will be in a single pod or you can define it in a separate pod. Bryan we have to design this so every service can be distributed across a k8 cluster. It would benefit to have everything as a po (farheen_cefalu_a, 14:22:45)
    3. Questions in chat from Justin asking what version of HELM? Latest version of HELM. Using Jenkins to deploy the HELM charts. (farheen_cefalu_a, 14:23:58)
    4. Chat questions: question- what version of helm is being targeted? there are risks of having tiller installed in helm? In helm v3 it appears that tiller is being removed (v3 is in alpha right now)
question - is there any CI testing of helm being considered? such as - https://github.com/helm/chart-testing.
 (farheen_cefalu_a, 14:24:26)
    5. bryan - I use CI testing to deploy HELM. #action Parichay post the links to the HELM. Justin - there are issues with tiller. You are a super user that is being addressed. For CI testing those tests are not available in open source. Can you post those tests for the open community. Bryan - I have recognized that jenkins and built jobs wil (farheen_cefalu_a, 14:33:31)

  2. Archival Process (farheen_cefalu_a, 14:33:42)
    1. Mukesh - The API should be asynchronous and synchronous responses. Second we need to have a notification process. These apis from the backend should run both asynchronously as well as synchronously. (farheen_cefalu_a, 14:35:36)
    2. we are archiving the Elastic search database logs. The tables from the logs grow and have to be archived to clear up disc space. Presentation of logs and dashboards through kibana. (farheen_cefalu_a, 14:37:18)
    3. For that archival api you can do it in batch or real time. The notification tells the user that the job is complete. (farheen_cefalu_a, 14:39:26)
    4. Byran who will be our developer for the ELK client? Amit is still there but Sumit will be taking over. We had a wireframe review. #action Parichay make sure that synchronous turned on. This is similar to what onboarding does to asynchronously do a call. Manoop - you need a user story to track this item. #action Parichay create a user st (farheen_cefalu_a, 14:42:43)
    5. design is fair. Tausif - this should be at the API level. Will be send a flag? Elastic search has a true / false flag. You can decide using logstash server. There are two approaches. You can put an array list. #action Parichay discuss with Tausif. (farheen_cefalu_a, 14:44:51)
    6. Sayee - We are going to write a log locally and then locally we push to ELK stack? When a model is created is it written directly or is there a cron job? Bryan - How do the logs get into elastic search. filebeat monitors persistent volume and synchs to logs. Parichay - archival backup and cleanup. (farheen_cefalu_a, 14:47:15)
    7. Mukesh - security of archival process? Swagger is not exposed to anyone in Acumos environment. You will not be able to access it in a production environment. Bryan - I am working on tools that will expose the Swagger interface. You shouldn't need it in a production environment. (farheen_cefalu_a, 14:48:41)

  3. Michelle License Artifacts (farheen_cefalu_a, 14:49:13)
    1. Debate of license should be stored in Nexus Acumos or LUM? We will continue to have the artifacts stored in Nexus as it is today. Have the scan results provided to the LUM. We will be discussing further. Keep the artfact in Acumos Nexus. We will store the scan results in the LUM. (farheen_cefalu_a, 14:50:45)
    2. It represents values in an api. SV will provide the key attributes that the LUM needs. We are going to provide the results from he security verification. Justin - we have a draft of the sequence of where it is stored. It will go through the License manager library that will go to LUM. (farheen_cefalu_a, 14:52:50)
    3. ACTION: Justin - we are still working on it. We also have to cover model runner and profile. We need to vet it with the team and we also are having discussions now. We definitely want to be on the agenda. We are also talking about run time models need to check with LUM for rite to use off the platform. We need to get approval off the platfom. (farheen_cefalu_a, 14:54:51)

  4. Docker Compose mismatch (farheen_cefalu_a, 14:55:09)
    1. Ken and Bryan were working together. Ken - I updated the version number in my template and it wouldn't start. I am comparing YMLs. Bottom line is it needs to be communicated well to everyone. Bryan it is fairly simple to remove the extra hosts field and run with what you have with version 2. The only way to do it is to run the scripts yo (farheen_cefalu_a, 15:01:10)
    2. Ken - The All In One is using Docker Compose 3.2. If you deploy the Platform using DNS resolving names you don't need Docker Compose 3.2. I use an environment without hosts I use Docker compose. Compose 3.2 (farheen_cefalu_a, 15:02:57)

  5. Sayee with ML Workbench (farheen_cefalu_a, 15:03:37)
    1. Sayee in one or two weeks we will show something. Camunda and we can show something next week for ML Workbench. #action Sayee provide ML Workbench design reviews next week. (farheen_cefalu_a, 15:04:44)


Meeting ended at 15:04:55 UTC (full logs).

Action items

  1. Justin - we are still working on it. We also have to cover model runner and profile. We need to vet it with the team and we also are having discussions now. We definitely want to be on the agenda. We are also talking about run time models need to check with LUM for rite to use off the platform. We need to get approval off the platfom.


People present (lines said)

  1. farheen_cefalu_a (37)
  2. collabot` (3)


Generated by MeetBot 0.1.4.