14:04:46 <farheen> #startmeeting Architecture Committee
14:04:46 <collabot`> Meeting started Wed Jul 31 14:04:46 2019 UTC.  The chair is farheen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:46 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:04:46 <collabot`> The meeting name has been set to 'architecture_committee'
14:05:48 <farheen> #topic agenda
14:09:34 <farheen> #info Manoop sharing Agenda.  Search engine, ML Workbench, Licensing.
14:11:02 <farheen> #info Vasu, Vineet and Ashwini will be Tausif's backup for the architecture team to review next week while Tausif is away.  Acumos portal footprint may have to be moved to next week.
14:11:23 <farheen> #topic Justin - Licensing flows
14:12:41 <farheen> #info Manoop - what are the overall flows.  What are the updates.  Justin - I have two wiki pages one for license flow and the model runner right to use.
14:13:57 <farheen> first is license profile wiki.  #link https://wiki.acumos.org/display/LM/License+Profile
14:18:40 <farheen> @info Justin we were deciding between LUM and CDS.  We decided to use CDS for the default license profile so we can improve CDS to store default license profiles.  That is going to be reflected from CDS.  The model owner through the front end will be able to get the list of default licenses.  They can select he default license.  We were planning on
14:18:40 <collabot`> farheen: Error: "info" is not a valid command.
14:18:41 <farheen> using he integration.  They can open up the license profile editor.  The iframe can then send back those results.  Sayee: Are you storing as a flat file?  Requirement is we don't need to have a structure.  It's a json.  The meta data is a priority flag so you can prioritized what license you want to check first.  Sayee: As a part of ML workbench w
14:18:41 <farheen> e want to introduce Couchdb.  We can work together.
14:20:50 <farheen> #info Tausif if the file has already been uploaded portal does the validation that the json file is uploaded.  If user selects create template.
14:21:15 <farheen> #action Tausif talk to Justin regarding the portal validation of the json file.
14:22:10 <farheen> #info Justin the json file is not validated today.  The license manager client library has a function that will evaluate the schema and save in the repo.  If not the validation should alert the user that there are invalid values in the license.
14:22:49 <farheen> #info Once license is save it will be scanned by Security Verification by a third party tool.  It evaluates the scan based on scanned data.
14:23:29 <farheen> #info Scan code data is the raw results.  The results artifact are the results of the scan that will tell LUM to activate LTU it's not an SPDF library.
14:26:43 <farheen> #info If your model runner is running you should be able to access the license artifact.  Sayee- Licenses come with an expiration date.  Do we have something that checks for expiration dates?  No this is the docker image to include the license.  Currently there is no ability.
14:28:18 <farheen> #info Manoop - Michelle had noted does the license have an expiration and will they flow?  That is not in scope in this release.
14:28:58 <farheen> #info the license expiration needs to be discussed further.  Is this license artifact saved in nexus can it be seen by the end user?  Yes it is there today.
14:29:42 <farheen> #info the default licenses are we going to make default licenses for Clio release?  Justin yes we can.
14:31:02 <farheen> #info Give the users instructions on how to add it.  Bryan we have instructions on how to add a license and it's up to the user to manage it with their legal team.
14:31:59 <farheen> #info Manoop - The impacted components are CDS, SV any points need to be raised.
14:33:43 <farheen> #info In the Boreas release we had the ability to track usage.  We used a side car approach.  We use ELK stack as an MVP for tracking.  In Clio we need to track.  We need to remove the proxy and bypass.  We wanted to go down to he ML client library and we call it simple sequence of how the library will work with the license mananger.  We want to ac
14:33:44 <farheen> tivate the sequence.
14:37:06 <farheen> #info Bryan - Are you saying the modeler will have to enter this in the pcl file?  No they will not have to.  It can be reverse engineered and remove it.  There are two calls at design time.  There are two actions the user has to do.  Once you enable the function the verify RTU determines whether you are allowed or not allowed.
14:39:02 <farheen> #link https://wiki.acumos.org/display/LM/Model+Runner?preview=/20548377/20548668/model-runner.png
14:42:31 <farheen> #info Manoop - From the LUM demo we discussed what if LUM is not accessible.  In that situation do we let them use the model?  Guy - Goal is to make it easy to onboard and not get involved with licensing.  Not their interest.  We designed to stop them from getting involved.  Bryan - this is optional for the designer at design time.  Manoop - will I
14:42:31 <farheen> lose capabilities if I don't follow this step at design time?  Byran - It is up to the policy the administrator.  Justin this is production check list
14:47:05 <farheen> #info Justin - Enable production environments enable the RTU through configuration.  Bryan - when the developer is vetting he has the option.  The operator/publisher will configure this.  Guy - If this can all be done during publishing then I am happy with it.  Bryan - you may have to retrain the model.  Guy - So I'm training a model that I am able
14:47:05 <farheen> to run.  I spent 200 hours training it and I onboard it.  Now someone else is going to have to go through 200 hours to run the model?  It depends.
14:47:54 <farheen> #info You can put the proxy on the front end.  If you push it into the CL then you have to write one for python, r, c++, etc...
14:48:14 <farheen> #topic Sayee - ML Workbench
14:50:27 <farheen> #info Sayee - Will review the wireframes for ML Workbench.  ML workbench is under design studio in development environment or test.  This will take you to the UI layout.  Models and data pipelines are still discussing. Attaching Notebooks and Data pipelines was in Boreas.
14:56:08 <farheen> #info When a user creates a project they are associating a project to a model.  In Clio when you associate a model you will receive the meta data with an existing model.  A single model can be associated with multiple projects.  We want to see what is published vs. not published.
14:57:34 <farheen> #info We can add the associated catalog to the published and unpublished.  We also removed the repetitive word Project in the UI for aesthetics.  It was repeated.
14:58:25 <farheen> #info Sayee - We want to work with someone who understands CouchDB.
14:58:45 <farheen> #action Sayee will have the end to end ready by the end of Sprint 2.
14:58:55 <farheen> #topic CDS
15:01:01 <farheen> #info Chris - Java 8 reaches end of life.  I had to change the dependency of my POM.  There was not other impact on spring boot.  For most projects the upgrade will not be a big deal.  java 8 stopped receiving security updates so this is critical.  This is not a big code impact.  We need to try the new version and if nothing is failing.
15:04:48 <farheen> #info Once the PTLs give us the OK then one lead from each team has to run their component with java 11 inform the team so release management can start releasing.
15:05:30 <farheen> #action Tausif schedule a call with the stake holders for the Search issues instead of waiting for another week.
15:05:34 <farheen> #endmeeting