14:10:37 <farheen_att> #startmeeting Architecture Committee
14:10:37 <collabot`> Meeting started Wed Sep  4 14:10:37 2019 UTC.  The chair is farheen_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:10:37 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:10:37 <collabot`> The meeting name has been set to 'architecture_committee'
14:10:50 <farheen_att> #topic Acumos-1188
14:12:23 <farheen_att> #info Bryan - We found that we don't have the flexibility to use k8 cluster.  Host map is the only persistence volume of service.
14:13:19 <farheen_att> #info not scalable so you have to distribute the components across a cluster node.  A side car is related to that cluster of services.
14:14:11 <farheen_att> #info this is an effort to deploy components across a k8 cluster.  I am adding labels with their own log volumes.
14:14:44 <farheen_att> #info I have a patch open to system integration to see the first stage.
14:15:14 <farheen_att> #info Regarding the CI pipeline. The design of deployment is there.  Still working on SV.
14:16:29 <farheen_att> #info Looking at how the platform works with Docker in all aspects and consider all of those things are offloaded to an external service like Jenkins.  It is a security concern.  We are establishing a pattern.  Onboarding team should take a look.
14:16:43 <farheen_att> #info What is the scope in Clio?
14:17:47 <farheen_att> #info Bryan - I don't think anything in Clio will be developed in Clio.  There is an interplay of Jenkins and Acumos components.  APIs need to be created and roles distributed.  It is a significant aspect change across the platform.
14:18:30 <farheen_att> #action Guy and Phillippe how does the onboarding code need to be refactored to fit into the CI/CD pipeline.  What can be done in short term and what is coming up in the releases.
14:19:12 <farheen_att> #info Guy - it is do-able but we may not have time to do it in Clio.  It will disrupt and break things.
14:20:04 <farheen_att> #info The ms code is missing.  Even though at a high level we know what can be done and what is feasible.  If you can bring together a plan we can review.
14:20:16 <farheen_att> #action Manoop add this topic to next week's agenda.
14:20:37 <farheen_att> #info Guy I agree we will discuss a bit and bring it up at the next architecture meeting.
14:21:41 <farheen_att> #topic Access Control
14:23:10 <farheen_att> #info Bryan the need for the Docker proxy is less and less therefore it's role can be simplified.  Proposal to manage images through workflow that wraps the platform.
14:23:18 <farheen_att> #topic HA Availability
14:24:32 <farheen_att> #info Bryan this is a big ask.  I don't know that the platform will scale.  Suggested to plan out experiments to test whats possible.  We need to take a planned experiment to see impacts.
14:24:59 <farheen_att> #action Manoop Bryan wants to have a design review for HA
14:26:11 <farheen_att> #info we can perform load tests to baseline what our platform can support.  This will give us a clue to which components are impacted by the load tests.  Save them in he HELM charts.
14:27:05 <farheen_att> #info we need two action items.  Load test and analyze the deployment techniques.
14:27:14 <farheen_att> #info Ask the component leads these questions.
14:27:58 <talasila> #action Ken to perform the load test to baseline the platform performance
14:28:23 <talasila> #action Parichay to analyze the helm chart of k8 deployment to address HA/scalability
14:28:47 <farheen_att> #info Is your component stateless?  What aspects of your app depend on a state.  What aspects are stateless?
14:29:53 <farheen_att> #topic Search functionality
14:31:24 <farheen_att> #info Many defects are being opened.  Records per page.  When we search we search on the 11 - 20 records.  Search does not search all records.  To do the entire database search a lot of changes will be required.
14:33:56 <farheen_att> #info Do we really want to achieve the database search. Acumos-2940.
14:36:28 <farheen_att> #action Tausif, Nat suggested collecting the search defects and we can review on the community call.
14:37:40 <farheen_att> #action Tausif review with the product committee and then with the architecture committee.
14:40:17 <farheen_att> #info regarding Acumos-1188 need support from the Federation team.  When we do an un-publish on the model that has been federated we need to know the rules around how to handle a federated file.
14:41:49 <farheen_att> #info when a model is federated from A to B.  B wants to unpublish the model.  If a model has been published and federated to another instance then the federated instance should un-publish.
14:42:05 <farheen_att> #info un-publish will delete the model everywhere?
14:42:13 <farheen_att> #info yes
14:44:49 <farheen_att> #info Manoop once a model is federated it will show up somewhere.  We can not remove a model once it is federated to the internet.  Show the model as depricated.
14:45:31 <farheen_att> #info what rites does the publisher have?
14:45:53 <farheen_att> #info what rites does the publisher has after publication?
14:46:50 <farheen_att> #info How instance A can changed ownership via instance B? Can we restrict further access?
14:47:02 <farheen_att> #info It depends on license and terms if any.
14:48:08 <farheen_att> #info Does the licensing team address the federated license models?
14:48:56 <farheen_att> #info That has not been discussed.  If the company wants to remove their model and they don't want anyone to use it they will have to do it offline.
14:49:18 <farheen_att> #info Publisher takes the model down from A and B through the federation API?
14:49:33 <farheen_att> #info yes, a scenario has to put together for that.
14:53:21 <farheen_att> #info We can trigger the request from Portal front end but need Federation team to take the action for portal to trigger so it can be un-published.
14:54:49 <farheen_att> #info this is not for-seen in the federation model.  The need to withdraw a model we have to decide how to notify the peer.
14:55:35 <farheen_att> #action Tausif put together a clear design and bring this topic to the Community call to Reuben.
14:58:20 <farheen_att> #action Justin add link to documentation to meeting minutes to the documentation api
14:59:08 <farheen_att> #action Manoop add Priya's Spark review to next weeks agenda.
15:00:32 <farheen_att> #link https://wiki.acumos.org/display/AR/Architecture+Reviews+Score+Card
15:00:57 <farheen_att> #info reviewed score card link above
15:01:07 <farheen_att> #endmeeting