14:04:59 <farheen_att> #startmeeting Architecture Committee
14:04:59 <collabot`> Meeting started Wed Oct  2 14:04:59 2019 UTC.  The chair is farheen_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:59 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:04:59 <collabot`> The meeting name has been set to 'architecture_committee'
14:06:31 <farheen_att> #topic Agenda
14:07:26 <farheen_att> #info we want to spend time on release status, sprint 4 blockers, kafka pub/sub, planning for Demeter, new feature ideas.
14:08:09 <farheen_att> #info Add the self-release of artifacts for mavin or docker feature for gerrit.
14:08:40 <farheen_att> #info Chris Lott has done some self-release process.  This is a good topic to cover.
14:08:53 <farheen_att> #info Chris - Self release is only good for jar files
14:09:11 <farheen_att> #info Justin - LF fixed the bugs and we are releasing docker also.
14:10:02 <farheen_att> #topic Release Status
14:10:37 <farheen_att> #info We want to focus on blockers for the pending items in sprint 4.  Are we on target?
14:11:06 <farheen_att> #info Federation We ware on track Murali is having a separate discussion with Ting.
14:12:40 <farheen_att> #info Guy - we had a pass thru feature for ONAP that has been implemented.  More work regarding adding meta data.  For that we need to synchronize with Tommy.  It is not blocking the demo but it should be finished.  It's work that has to be done by onboarding or common services team.
14:13:18 <farheen_att> #info we will have a demo that will benefit the Acumos community.
14:13:33 <farheen_att> #topic O-RAN October 8th demo
14:13:50 <farheen_att> #info Guy will have it ready next week.
14:14:01 <farheen_att> #topic ONS demo
14:14:25 <farheen_att> #info Guy - There was a resource that was stalled.  Nat said they have gotten someone but I have not heard from TechM.
14:14:55 <farheen_att> #info Nat - I got the input from Amol offshore.
14:16:31 <farheen_att> #action Nat will align the resource to join the next onboarding scrum call
14:17:54 <farheen_att> #action Murali put it as a blocker waiting for a resource.  One week task for a skilled developer.
14:18:48 <farheen_att> #topic Jenkins Model Deployment
14:19:38 <farheen_att> #info Bryan - Was released yesterday.  Mark it as deliver to testing team.  It is available on the TechM K8 server.
14:21:00 <farheen_att> #info Ken - no issues with alignment on deployment.
14:21:07 <farheen_att> #info when can we have the demo on that?
14:21:43 <farheen_att> #info when the portal is integrated with portal 3.0.15.
14:22:00 <farheen_att> #info Ken - we have to wait for the portal team to complete?
14:22:02 <farheen_att> #info yes
14:22:23 <farheen_att> #info in your absense is there anyone who can back you up?
14:22:26 <farheen_att> #info No
14:23:00 <farheen_att> #info open issue in deployment
14:23:20 <farheen_att> #action Vasu talk to Santosh and come up with an ETA.
14:23:29 <farheen_att> #info is there a portal user story?
14:24:03 <farheen_att> #action Murali update  jira epic to 3433.
14:24:39 <farheen_att> #action Murali check ETA for deployment.  This is important to track at that level to set expectations.
14:27:42 <farheen_att> #topic MLWB
14:27:53 <farheen_att> #info Sayee - working through issues no blockers
14:28:00 <farheen_att> #topic Licensing
14:28:11 <farheen_att> #info - no blockers
14:28:53 <farheen_att> #info Justin we are dependent on SV 1.10 to get our SV checking on platform done.  We are tracking down the abandoned commit.
14:29:15 <farheen_att> #info 3024 is the issue to track.
14:29:43 <farheen_att> #info Acumos-3005 should be updated.
14:29:57 <farheen_att> #action Murali update Acumos-3005
14:30:10 <farheen_att> #info Acumos-3065 is open, why?
14:30:23 <farheen_att> #info there may be documentation user stories.
14:30:51 <farheen_att> #topic Upgrade to java 11.
14:30:59 <farheen_att> #info who are the teams working on this?
14:31:14 <farheen_att> #action Murali follow up on the upgrade to java 11.
14:31:38 <farheen_att> #info Ken do you see testing related concerns.  Have you started on the delivered cycle.
14:32:18 <farheen_att> #info Yes, Bryans release does not have portal integration.
14:32:53 <farheen_att> #info keep the progress on the delivered items to test.
14:33:53 <farheen_att> #topic Pub/Sub mechanism support thru Kafka.
14:34:21 <farheen_att> #info Bryan - do homework to understand what is meant and done in other open source projects in the same space.
14:35:15 <farheen_att> #info we change component address to connect to a message bus and know how to subscribe on that bus.  Incoming API subjects on the bus.  It is a more flexible and cloud native approach.
14:35:59 <farheen_att> #info People need to understand the technology to understand the value of this approach to the Acumos project.  People need to come to the table with an understanding of the technology.
14:36:24 <farheen_att> #info Is there a performance hit?  and do we become dependent on the bus.  If the bus goes down does everything stop?
14:37:15 <farheen_att> #info latency of transactions being filled need to be considered.  Openstack would not be based on the same concept for real production clouds.
14:37:52 <farheen_att> #info There is a spring-cloud to help us with this.  There are many message systems such as Kafka nanakube.
14:38:02 <farheen_att> #info To what extent will we go?
14:38:25 <farheen_att> #info this enables a service discovery a lot smoother.  Cost is you have to replace a jar.
14:38:49 <farheen_att> #info wouldn't we put it out as a platform service and allow those who want to use it?
14:39:41 <farheen_att> #info There is a roadmap to adoption.  Everything will have to be changed from APIs to message bus.
14:40:11 <farheen_att> #info suggestion Initially build one component that listens to the bus and reroutes that to the appropriate web API calls.
14:40:47 <farheen_att> #info over time as components switch over they can stop the central bus.
14:41:31 <farheen_att> #info Kafka are for continuous message.  Such as knowing the status.  Or save something on a database.  We don't have to go through Kafka
14:42:03 <farheen_att> #info Yes, CDS is like that. It is well served by the rest interface no need to apply.
14:42:30 <farheen_att> #info we do need to solve the service discovery issue.  When you bring up a system things aren't connected properly.
14:42:54 <farheen_att> #info Service discovery is not the primary use case.
14:43:33 <farheen_att> #info primary benefit is asynchronous use cases.  Any component that wants this mechanism can switch.  Those who do not don't have to.
14:44:25 <farheen_att> #info you are not going to solve this complex spaghetti code system by taking a half step.  You want every API to report to the bus.
14:45:07 <farheen_att> #info what would benefit non lazy components?
14:45:46 <farheen_att> #info Coupling . I can start a service and no other component cares.  Project needs to adopt.
14:46:26 <farheen_att> #info wouldn't bringing down a service change the other components?
14:46:49 <farheen_att> #info remote procedure calls.
14:47:29 <farheen_att> #info To accommodate a-synchronous would require recoding in a lot of places.
14:47:45 <farheen_att> #info java programmers typically don't program that way.
14:48:10 <farheen_att> #info it removes dependencies of trigger events.
14:49:00 <farheen_att> #info If you have a piece of code that says get the list of models from this user.  Put a call back function that updates something.  that will be tricky.
14:49:17 <farheen_att> #info luckily that paradigm familiar to web programmers.
14:50:23 <farheen_att> #info Good discussion.  Let's do our homework on this.  Once we have the intial module the licensing team is building we will adopt pub/sub
14:51:16 <farheen_att> #topic Demeter ideas
14:51:28 <farheen_att> #info enter ideas into the etherpad.
14:52:09 <farheen_att> #topic Self Serve release
14:52:17 <farheen_att> #link https://docs.releng.linuxfoundation.org/projects/global-jjb/en/latest/jjb/lf-release-jobs.html
14:52:57 <farheen_att> #info This will remove the long wait from LF to grant permission.
14:54:13 <farheen_att> #info you do one commit for the mavin and one commit in docker.  Stage the release as you normally do.  pre-req you must have the release job added to your jenkins job configuration.  These are the two jobs in jenkins
14:55:08 <farheen_att> #info two configs in jenkins some projects have multiple jars and single.  on a side note we are ways to release each jar independenly.  If you have all of these sub modules in maven defined.
14:59:29 <farheen_att> #info we want to see the releases we have in the past.
14:59:54 <farheen_att> #info in ONAP we are not creating multiple version files.
15:00:15 <farheen_att> #info ONAP history and release artifacts will address that concern.
15:03:01 <farheen_att> #info use acumos/ and update the tags.
15:04:51 <farheen_att> #info Thank you for stepping up and sharing with the PTLs.  Expect Eric Ball from LF.  LF turn around time is 24 hours.  If you follow this process you can release your artifacts yourself.
15:05:25 <farheen_att> #topic 3433 3430 are in a delivered state.
15:05:46 <farheen_att> #info verify with the portal team that the expected items for SV and jenkins workflow are completed.
15:06:07 <farheen_att> #info which commit were they delivered.
15:06:41 <farheen_att> #action Vasu double check commits to Murali and Bryan.
15:06:46 <farheen_att> #endmeeting