14:05:16 <farheen_att> #startmeeting Architecture Committee
14:05:16 <collabot_> Meeting started Wed Oct  9 14:05:16 2019 UTC.  The chair is farheen_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:16 <collabot_> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:05:16 <collabot_> The meeting name has been set to 'architecture_committee'
14:12:34 <farheen_att> #topic Manually deploy Acumos ML based xApp in RIC and Adapter speaks RMR protocol to RIC (Guy/Manoop)
14:14:56 <farheen_att> #link https://wiki.o-ran-sc.org/display/RICA/ML-based+xApp
14:15:07 <farheen_att> #info Guy reviewing link above.
14:19:36 <farheen_att> #info Do we need the central hub?  Latency is an issue in messaging,
14:20:05 <farheen_att> #info we would have to create a model runner for every model we support in RMR.
14:20:24 <farheen_att> #info endpoints can be called by java.
14:20:55 <farheen_att> #info the model runner takes the services the user has written and presents a net interface.  Standard would present a rest interface.
14:21:18 <farheen_att> #info this two step approach can communicate with all languages.
14:22:08 <farheen_att> #info having a config manager is better than a hop from the services
14:26:57 <farheen_att> #info view the Future work section of the link above
14:27:54 <farheen_att> #topic Blockers for Clio release
14:28:06 <farheen_att> #info Resource issue blocker
14:28:25 <farheen_att> #info Guy - in the next few days we will get an update from the resource.
14:29:09 <farheen_att> #info Priya - End of this week we can provide an ETA.
14:29:41 <farheen_att> #info Bryan is sending us the instructions on how to set up a jenkins job for SV.
14:32:30 <farheen_att> #info Ken- Deploy to Kubernetes is a blocker.  We're being asked to run a curl command.  It should be done through the Admin gui.  The portal team did not have a heads up for this.  There are no user stories.
14:36:14 <farheen_att> #info Manoop Acumos- 3433?
14:36:32 <farheen_att> #info Tausif - it is in a delivered state.
14:37:10 <farheen_att> #info Acumos - 3340 SV dependent on the next version of portal.
14:37:17 <farheen_att> #info Tausif - this is delivered.
14:38:10 <farheen_att> #info Manoop - What is delivered?  SV team has opened a story or sub-task to call a reference or API of sub epics.
14:38:28 <farheen_att> #info Tausif Justin has to test.
14:39:31 <farheen_att> #info Justin - There is an issue with the current version.  We will have a version bump for SV and LUM.
14:40:35 <farheen_att> #info Justin Licensing and SV will change.  Because we're moving checking into portal I will work with Tausif.
14:48:02 <farheen_att> #info Mural - Acumos-3538 improvements RTU comminication with LUM server and UI for LUM editor.
14:48:16 <farheen_att> #info Parag - Waiting on review.
14:49:58 <farheen_att> #link https://wiki.acumos.org/display/REL/Clio+Release+Project+Status
14:50:45 <farheen_att> #info Murali reviewed demo calendar.
14:53:08 <farheen_att> #info Guy AIO Jenkins build.  We would like help to reduce the size and efficiencies.
14:53:41 <farheen_att> #info Justin - the failure rate is pretty high.  When there is a build failure that causes an issue because the user gets stuck.
14:53:51 <farheen_att> #info error found is cryptic
14:54:54 <farheen_att> #info it looks like the R model is while having dependencies can pull the base model.
14:56:15 <farheen_att> #info Guy - difficult to do system level installs in python.  The high failure rate is using the docker in docker using All in One.  The MS generation doesn't work well in an All in One installation.
14:57:11 <farheen_att> #info this is temporary.  We will have the kubernetes deployment.
14:57:30 <farheen_att> #info Guy - an issue with running docker generation in kubernetes.
14:58:28 <farheen_att> #info Justin - Calling too many times can be denial of service.  This happens in both AIO and docker compose.
14:58:57 <farheen_att> #action Guy - Add this to Demeter release.
14:59:11 <farheen_att> #action Manoop - Add this topic to the Architecture Committee call.
14:59:36 <farheen_att> #action Justin - prepare to raise this issue at the face to face meeting.
14:59:51 <farheen_att> #info Parag - What is our recommendation for our users?
15:00:22 <farheen_att> #info Manoop - All in One is available for Kubernetes style.  For enterprise we want to use Docker compose.
15:00:58 <farheen_att> #info Ken recommends if you want to start from scratch then use AIO.  If you're going to use an existing nexus then the Docker compose.
15:01:19 <farheen_att> #info Manoop - Parichay was primarily working on reducing these gaps.
15:03:00 <farheen_att> #info Parag - From Acumos client perpective they can mix and match both approaches.  They have a K8 cluster and cloud.  They want to setup Acumos in that environment.  Docker compose gives more control but requires extensive understanding of Acumos.  AIO is good for a quick.  How easy is it to upgrade?
15:04:16 <farheen_att> #info Ken - set up a helm chart that has non-core and a helm chart for core components.  This way all the core components are in one pod.  It reduces the risk of opening up the doors and deploy a stateless component into a pod.  That will be covered in the D release.
15:05:30 <farheen_att> #info Manoop - Gaps were identified by Bryan.  Streamlining the delivery of the product is a priority in Demeter.
15:06:14 <farheen_att> #action Manoop list Tausif's topic as a first topic in next weeks agenda item.
15:07:12 <farheen_att> #info Mural - Demeter agenda Reuben shared a proposed agenda.  Asked the PTLs to come up with ideas for November workshop.  Prepare and have ready by this Friday.
15:07:56 <farheen_att> #info Manoop - This is a chance to work with your company management to come with focused ideas of what your company cares about.  Bring that to these discussions so we can identify slots for the focused agenda.
15:08:17 <farheen_att> #action PTLs bring key objectives for Demeter to the face to face.
15:08:20 <farheen_att> #endmeeting