14:02:48 <farheen> #startmeeting Architecture Committee
14:02:48 <collabot> Meeting started Wed Oct 16 14:02:48 2019 UTC. The chair is farheen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:48 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:48 <collabot> The meeting name has been set to 'architecture_committee'
14:06:02 <farheen> #topic Agenda portal topics. Onboarding version (Bryan). Release status (Murali)
14:07:51 <farheen> #info Tausif is sharing a word document
14:08:36 <farheen> #info Issues reflecting the Search functionality.
14:11:11 <farheen> #info reviewed Catalog search issues. Viewing the catalog screen.
14:11:32 <farheen> #info CDS Search requires exact string match.
14:14:17 <farheen> #info problem: today the front end is flitering the data. From data base we only get 10 records. If you go for all records then you cache everything and then present it.
14:17:53 <farheen> #info niche search or site search?
14:18:38 <farheen> #info Manoop - Site search addresses common problem. Does the site search support only catalog searches such as search for 5G
14:19:30 <farheen> #info to search within the catalog would be a nice feature but in the screen they have shown is the first 5. This doesn't expose the contents of the catalog.
14:20:26 <farheen> #info Tausif - the search criteria should be applicable for all the columns.
14:20:56 <farheen> #info Manoop - we are trying to apply this logic throughout the tables. Should we add a custom search field consistently?
14:21:10 <farheen> #info Tausif - yes this is what we want to achieve.
14:21:28 <farheen> #info Assuming everyone agrees that this is valuable and needed then what is your proposal?
14:21:42 <farheen> #info Tausif - modify CDS to do that.
14:23:52 <farheen> #info Tausif ask the user to put a % after
14:24:18 <farheen> #info Sayee - CDS calls are causing latency. This should not be database dependencies.
14:25:00 <farheen> #info Tausif either you get all the data on the front end to slow things down.
14:25:45 <farheen> #info Sayee- It should be more dynamic.
14:26:20 <farheen> #info Tausif - Yes either you make multiple calls to CDS or you make a call to the front end. If the community agrees to get all the data at the front end then it is fine.
14:26:55 <farheen> #info Manoop - Rather than imposing new requirements to CDS per table. Getting the data onto UI and making optimal call to CDS and filtering on the UI would be a better approach.
14:27:47 <farheen> #info Chris - You have a lot of features in responsive manner. There is a great risk of blowing up the users browser. The user you give 10 rows of data and not 1000s.
14:28:22 <farheen> #info Manoop - We don't need to add changes to CDS but portal side will handle it.
14:28:49 <farheen> #info Tausif - There will be a lot of work that is time consuming for the front end developers.
14:30:20 <farheen> #info Manoop - We have to start adapting chacheing mechanism and using the elastic features unless there are millions of records.
14:30:34 <farheen> #info We should go on the UI side of filtering.
14:35:37 <farheen> #info Parag - It depends on the UI filtering when there are getting subset of 1000 records then it will require server side filtering.
14:36:23 <farheen> #info Change in revision version attribute as set by Onboarding is breaking SV
14:36:30 <farheen> #topic Change in revision version attribute as set by Onboarding is breaking SV
14:38:19 <farheen> #info Bryan - Incrementing integer that changes the logic.
14:38:42 <farheen> #info Phillippe I tested with Muktar today and the test was successful.
14:39:08 <farheen> #info Bryan - there was nothing I did to change that.
14:39:21 <farheen> #topic Acumos-3531
14:50:16 <farheen> #info We are publishing one model in two catalogs and the version changes in the second catalog.
14:50:32 <farheen> #action Ken work with Nancy from the test team.
14:50:53 <farheen> #topic Clio release blockers and issues.
14:51:24 <farheen> #info November 6 will be the ONAP demo
14:52:04 <farheen> #info Documentation for Acumos C client. We are OK with the user guide. The developer guide is not finished. I didn't anticipate the developer would be out this week.
14:52:32 <farheen> #info the developer guide will be late.
14:56:14 <farheen> #info Murali covered all open issues and user stories with the PTLs.
15:02:10 <farheen> #endmeeting