14:12:57 <farheen> #startmeeting Architecture Committee
14:12:57 <collabot> Meeting started Wed Oct 23 14:12:57 2019 UTC.  The chair is farheen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:12:57 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:12:57 <collabot> The meeting name has been set to 'architecture_committee'
14:13:24 <farheen> #topic Release Status and issues
14:14:59 <farheen> #info no blockers but there are critical and high defects that need to be addressed.
14:15:58 <farheen> #info Epic 3256 was expecting to have the raw client library delivered.
14:16:55 <farheen> #info Manoop worked with Priya on a model that had issues with protobuf conversion.  When they start using the new raw client lib they will not go through the protobuf conversion.  This needs to be watched and closed.
14:17:17 <farheen> #info Guy - all the code is there.  We have to sit down with Tommy to show him how to use it.
14:17:32 <farheen> #info It's up to Guy and Tommy to get it going.
14:17:55 <farheen> #info Murali - is there user story?
14:18:12 <farheen> #info Manoop create a task against the epic to track.
14:18:55 <farheen> #action Guy create a task on Epic 3256 regarding meeting with Tommy.
14:19:08 <farheen> #info Are we able to make progress on test?
14:19:33 <farheen> #info Ken - Test team is blocked on an issue with the license editor to not be able to proceed.
14:19:44 <farheen> #info It is a port issue that we will have resolved shortly.
14:21:03 <farheen> #info Access to the editor is a problem not the edtior.  It is completely separate installation.  Bryan offered the instructions on Tuesday but no one was able to set up.
14:21:54 <farheen> #info Bryan Security verification and deployment are separate installations.  Not a part of the core.  It is a learning process.
14:22:33 <farheen> #info Ken - Does each instance of Acumos need it's own Jenkins?  Can we re-use the same jenkins?
14:23:43 <farheen> #info Bryan - Each instance of acumos today has to have it's own jenkins.  In the future that will not be required.
14:24:43 <farheen> #info Vineet - log user stories have to be incorporated into all the components.
14:25:38 <farheen> #info Manoop - Review that they are the java objects but using these modules will have to incorporate into the maintenance release.  We need someone can verify, re-use.
14:25:58 <farheen> #info Vineet - Yes, we want to show what we have done.
14:26:29 <farheen> #action Manoop add Vineet's demo of logs in Clio to next weeks agenda.
14:26:55 <farheen> #info Murali - Clio press release slide reminder.  Please respond to my request.
14:28:33 <farheen> #info Ken - License editor.  I am finding in ML WOrkbench as well in configuring all the ports.  I understand they want the some pluggable and non pluggable.  Is there ML workbench had to have a fully qualified name and ports.  Are we going to look at Acumos as much more pluggable.  Are we going to start to look from an architectural perspective.
14:28:48 <farheen> #info Manoop - Requires a kubernetes deployment expert.
14:29:29 <farheen> #info Bryan components do interact intnernally.  Front door are designed to be exposed through the ingress end point.  They are presented in an iframe and their content comes from a front end service.
14:30:21 <farheen> #info Ken - Dockerized version it doesn't matter which Docker or K8.  We have to pick a port.  Service names were said to use the fully qualified names.
14:31:15 <farheen> #info Byran - As mentioned even under docker you can communicate outside of the cluster.  Every docker is known by it's docker name.  Exact same in k8 use the cluster domain name.
14:31:36 <farheen> #info Bryan - possible to have secure intra connections using the service page.
14:32:08 <farheen> #info Ken - If you're talking inside the container everyone can start using the same port.  I can't test.
14:32:46 <farheen> #info Bryan - every component uses the same port at a different service.  Any component that has to have a service exposure it has to be mapped.  External mapping should be minimal.
14:33:18 <farheen> #info Ken - What I usually get is everything needs to be external.  I don't know if someone has hard coded to the external port.
14:33:34 <farheen> #info Bryan encourages to review the architecture diagram.
14:35:24 <farheen> #info Ken - The architectural perspective it needs to be reviewed by the architecture committee.
14:35:58 <farheen> #info Manoop - Follow the architecture guidelines.
14:36:09 <farheen> #info is ML Workbench on that diagram?
14:36:13 <farheen> #info yes
14:36:33 <farheen> #info there is a core and they do need to be updated.  Some aspects have been clarified.
14:38:25 <farheen> #topic Apache Nifi Integration - Nat
14:39:04 <farheen> #info IBM supported Romeo is from IBM.  IBM AIF projects to work with Acumos AI
14:40:13 <farheen> #info the models we onboard on the platform can leverage this tool set for unbiased vs biased context.  Ken worked with design tools and the Nifi pipeline.  Romeo has worked out a prototype of Apache Nifi AI 360.  Both Acumos AI and AIF will work together.
14:40:42 <farheen> #info Romeo - sharing screen.  we have a couple of toolkits
14:42:02 <farheen> #info AI Bias tool lets you check for bias.  Python library.  In order to integrate thru Nifi possibilities.  Hello fairness script but data is generated in the script and is editable to see how the lib works
14:42:28 <farheen> #info data driven ground truth and model predictions in the database.  After that fairness call
14:47:14 <farheen> #info Able to add bias detector to the data flow.
14:47:44 <farheen> #link https://wiki.acumos.org/display/AR/Meetings
14:48:04 <farheen> #info recording of demo recorded in link above.
14:51:22 <farheen> #info the models with high bias their bias is removed from the nifi data.
14:51:51 <farheen> #info will Ai360 be a library or service?  Will it be deployed on need to know basis?
14:52:44 <farheen> #info all 3 possible.  pipinstall ai360 python library.  Can be wrapped in any framework.  Also can be provided as rest.
14:53:14 <farheen> #action Nat form a focus team and call around Ai 360.  Once determined we can propose to TSC.
14:53:39 <farheen> #info Nat - The Security verification and ml workbench teams.
14:53:57 <farheen> #info Sayee - Model training steps?
14:54:31 <farheen> #info - Romeo - Yes, it can be integrated or as a separate microservice.  It is up to the team to decide.
14:55:18 <farheen> #info Nat - We have to have a focused discussion.  There are two other products Robust and inaudible.
14:56:05 <farheen> #info Romeo - I will be in Lyon next week.
14:56:43 <farheen> #info Nat and Phillippe will be there.  Martin will be there too.
14:57:28 <farheen> #action Nat report out on your findings at the face to face in Lyon.
15:00:29 <farheen> #action Murali add the Demeter release events to the lists.acumos.org calendar.
15:00:36 <farheen> #endmeeting