15:06:11 <farheen> #startmeeting Architecture Committee
15:06:11 <collabot> Meeting started Wed Nov 20 15:06:11 2019 UTC.  The chair is farheen. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:11 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:06:11 <collabot> The meeting name has been set to 'architecture_committee'
15:06:47 <farheen> #topic Loose Ends that people want to bring to the table about Clio release.
15:08:36 <farheen> #info Murali - brought up the Clio release open defects.
15:12:51 <farheen> #info Ken and Murali did a deep dive into issues and filtered on issues from the maintenance release.  there are 3 that are open and high.
15:13:17 <farheen> #info Acumos-3731 is a new requirement and not a bug.
15:14:01 <farheen> #info Acumos-3707 loading Dashboard and Project giving error.  Ken is working this issue.
15:14:46 <farheen> #info Security verification high defect.  Bryan said it is a work in progress.
15:15:28 <farheen> #topic Logging API integration plan (Vineet)
15:16:27 <farheen> #info this has been demonstrated last week.  It is done.  Will be sharing API.
15:17:16 <farheen> #topic Review deployment namespace/port
15:18:53 <farheen> #info Bryan - How are services exposed what sort of controls do you have over that.  What should we adopt as a project to maintain these platforms.  These are complex platforms.  Such as rabbit mq bus that connects services automatically.  These techniques will help us with maintenance effort.  Defer this discussion until after Clio.  We want to
15:18:54 <farheen> come to an agreement on the priciples.
15:19:59 <farheen> #info Guy - This can go under the deployment configuration.  Watching people deploy the system are struggling.  Therefore for new people it can be a big challenge.  It should be simple enough for people to read documentation and deploy the platform.
15:22:02 <farheen> #action/ Bryan Sullivan - Wants to demonstrate how to deploy the platform with a wrapper inside a wrapper approach that makes it simple to maintain the platform across diverse environment with only a few key options that you have to select.  That trickles down into the maintain deployment of components.  I have used this with 5 different
15:22:03 <farheen> environments including Kubernetes, Openshift, Azure, and others.  I can describe and user experience of this system when Clio work is complete.
15:23:08 <farheen> #action / Guy add to mid December agenda item.  The 10th would be better for scheduling.
15:23:35 <farheen> #action Bryan put the system design documentation into the repo of how things are deployed.
15:23:57 <farheen> #info Sayee - off topic - What does logging API mean?
15:24:37 <farheen> #info Vineet leverages a few additional methods and will help with multiple thread requests.  It will give you a log statement for each thread.
15:24:47 <farheen> #info is this going to be service or standard?
15:25:10 <farheen> #info this is standard.  we are using the jars right now.  We publish the jars needs to be applied to components.
15:25:22 <farheen> #info Once logging is enabled will we pull into kibana?
15:25:28 <farheen> #info yes
15:25:43 <farheen> #info logging will have the same architecture but be improved.
15:26:15 <farheen> #info we need to get the metric for the log.  Have we thought this through completely?  Is this funcitonal, system, or metric log?
15:26:47 <farheen> #info for now it is based on the services.  The rest services they find in each component.
15:27:06 <farheen> #info Sayee would like a further discussion with Vineet on this topic.
15:28:17 <farheen> #info Will Jacob from Orange be joining us?
15:28:33 <farheen> #info Nat - Angel project from Tencent.
15:29:26 <farheen> #info Guy - We are working with Fitz from Tencent trying to onboard a Huawei model.  We are trying to assist.  It is not relevant for Architecture.
15:29:55 <farheen> #info Bryan - the issue they has been resolved this morning.
15:30:57 <farheen> #topic Review the Demeter Release (Murali)
15:31:47 <farheen> #info Murali reviewed
15:31:50 <farheen> #link https://wiki.acumos.org/display/REL/Demeter+Release+Requirements
15:32:33 <farheen> #info epics are due November 22.
15:33:01 <farheen> #info Guy - This is very high level.
15:34:28 <farheen> #info Murali do not use the Demeter tag.  Someone has used the Demeter tag.  This needs to be removed.  Contact Murali Vuppari for details.
15:35:06 <farheen> #topic Acumos-3659 (Nat)
15:36:49 <farheen> #info this is targeted for the point release.  The wireframe team showed screens and the meeting was recorded.  Manoop and Reuben were on the call.  They wanted to start the process and provide the role based restrictions.  The roles will be mvp and catalogs may not be in Demeter.  We will add the link to this summary on the Architecture Committee
15:36:50 <farheen> wiki page.
15:37:29 <farheen> #info Bryan updated value page for the Demeter.
15:37:46 <farheen> #info Does anyone have specific items they want to put on the agenda.
15:38:51 <farheen> #info Bryan insure the Acumos platform fully supports the product.  It is not clear that there is any assurance.  We have not tested.  Bryan has added it to the agenda.
15:39:33 <farheen> #info Bryan insure the Acumos operation of platform and the logs.
15:39:54 <farheen> #info Explore alternates such as filebeat for logging.
15:40:41 <farheen> #info the dependance of logs that filebeat mines requires overhead with the side car.  The current log file collection design.
15:41:53 <farheen> #topic Bryan Automating platform maintenance
15:42:37 <farheen> #info Big goal is CI/CD.  another expanding the community with projects inside public clouds.
15:43:40 <farheen> #info having an automated process for the purpose of managing and deploying training models.  We want a seamless, reliable, management.  The limitation we may have with trust and security with obligations of licenses.
15:44:36 <farheen> #info we can mitigate the risk by ensuring those solutions are deployed in the controlled environments that can't be hacked.  Controlling the process will help to make it more manageable. Expanding the data scientists interest including training and data set sharing.
15:48:46 <farheen> #info platform unification and reliability between components should be easier for the user.  Details can be found at https://wiki.acumos.org/display/REL/Demeter+Release+Requirements see my entries on the wiki page against my name.
15:48:55 <farheen> #link https://wiki.acumos.org/display/REL/Demeter+Release+Requirements
15:49:15 <farheen> #info Sayee - The Azure belongs in ML workbench.
15:51:53 <farheen> #info Phillippe - add discussing of protobuf and metatags to onboarded Dockerized models (AI4EU) to allow their use.
15:51:58 <farheen> #endmeeting