15:03:18 <farheen_att> #startmeeting Architecture Committee
15:03:18 <collabot`> Meeting started Wed Nov 27 15:03:18 2019 UTC.  The chair is farheen_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:18 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:03:18 <collabot`> The meeting name has been set to 'architecture_committee'
15:04:00 <farheen_att> #topic Agenda
15:05:13 <farheen_att> #topic Acumos 3733 - Optional license.
15:05:57 <farheen_att> #info recording the wireframe review.  See Architecture Committee Meeting Minutes page for recording.
15:20:45 <farheen_att> #info recording will be on the wiki and also in the Acumos 3733
15:21:20 <farheen_att> #topic New agenda items
15:22:35 <farheen_att> #info Jason RTU or model that has already been onboarded.  You may receive a denial method.  The easiest path is to re-publish the model.
15:22:54 <farheen_att> #action Jason post migration documentation for users to migrate to rite to use.
15:23:42 <farheen_att> #info Guy - There may be a way to re-onboard the models without having the user go through re-publishing.
15:29:37 <farheen_att> #info Needs to be discussed.
15:30:02 <farheen_att> #topic Onboarding Architecture Phillippe
15:30:06 <farheen_att> #link https://wiki.acumos.org/display/MOB/Architecture+Diagram+for+Demeter+release
15:31:20 <farheen_att> #info Guy invoke the existing artifacts.  Why don't we generate the artifacts on the fly when DS is spun up.  Not sure why we pre-compute these things.
15:31:42 <farheen_att> #info Phillipe - Impacts on portal - add the possibility to upload this file to Acumos.
15:32:35 <farheen_att> #info Phillippe - We can also add the license file.  Today dockerized models don't allow licenses to be added.  This is a good opportunity to add these license files here.  This is a good opportunity to push this file to nexus
15:43:16 <farheen_att> #topic Acumos Platform support
15:44:13 <farheen_att> #info Bryan - Proxy - All components leads.  I need to know does your component require anything from the internet?
15:44:30 <farheen_att> #info Bryan Meaning the component retrieving.
15:44:59 <farheen_att> #info other than what the java requires proxy settings.  Are there others who require a proxy setting?
15:45:46 <farheen_att> #info Guy - the docker host wanted that for some instances.
15:46:04 <farheen_att> #info Bryan - if you are using a proxy then you need to document that in your user guide.
15:46:27 <farheen_att> #info Bryan what are the features that require proxies and document it.
15:46:56 <farheen_att> #info It is better to plan ahead then to find proxy errors in testing.
15:53:45 <farheen_att> #info Ask yourself does your component require anything that requires a proxy.  Document this ahead of time to avoid issues with installers of Acumos.
15:53:51 <farheen_att> #topic Filebeat
15:55:24 <farheen_att> #info Azure does not support sharing (re-write many).  So Bryan had to turn off logs. Workarounds are not acceptable.  Instead put the logs in standard out.  This standard gets shipped to logstash.
15:55:49 <farheen_att> #info this eliminates the dependency for persistant volume to logs.
15:56:49 <farheen_att> #info Guy - you don't want to buffer logs too much because you don't want recent logs to be flushed by the buffer.
15:57:36 <farheen_att> #info bryan agree it is simple but substantial overhead such as in Azure.  It is inconvenient to not be able to share persistent logs across cluster nodes.
15:58:24 <farheen_att> #info Generic environment (accepts), Azure throws logs out the window, and ... docker host?
16:00:32 <farheen_att> #topic Demeter Release wiki jira updates
16:00:50 <farheen_att> #action all PTLs add your epics and user stories with the Demeter Release label!
16:01:08 <farheen_att> #endmeeting