#acumos-meeting: architecture committee

Meeting started by farheen_att at 15:03:51 UTC (full logs).

Meeting summary

  1. agenda (farheen_att, 15:03:56)
    1. Download user experience requested by Philippe D. (farheen_att, 15:08:43)
    2. No portal presence. (farheen_att, 15:09:04)
    3. If anyone wants to discuss topics contact Manoop (farheen_att, 15:09:21)
    4. Nat - Vasu on the Clio point release who are all still pending? (farheen_att, 15:09:35)
    5. Deployment, DS, and ML Workbench are outstanding (farheen_att, 15:10:05)
    6. Justin - Deployment model usage tracking. Having issues but there is no one is assigned to deployment client anymore. (farheen_att, 15:10:34)
    7. Santosh has committer access. Vineet also has committer access. (farheen_att, 15:11:45)
    8. Vineet can help with merge requests. (farheen_att, 15:12:05)
    9. in the deployment client (farheen_att, 15:12:19)
    10. Manoop - Clio maintenance release is our top priority. (farheen_att, 15:13:00)

  2. Sayee - Sprint 1 new feature that the DS/ML Workbench team is working on. (farheen_att, 15:13:38)
    1. Sayee - YML workbench enhancement. We are adding deployment of a model from ML Workbench. (farheen_att, 15:14:47)
    2. you can create and associate notebook and nifi pipeline to a project. Model has to be onboarded on Acumos to be associated. This blue Deploy icon added. (farheen_att, 15:15:34)
    3. this is similar to the portal version. You can give a predictor name. Once complete a deployment in process. A jenkins job is created where the model is being deployed. (farheen_att, 15:16:13)
    4. do you differentiate between models and predictors? (farheen_att, 15:16:28)
    5. this is for trained model. (farheen_att, 15:16:38)
    6. Sayee - predictor is a running model. If you want to scale it to one or two pods. Currently that is not being tested. We want to see where it is being scaled to cutomers. (farheen_att, 15:17:31)
    7. You can check the deployment in the UI . it is a jenkins job. (farheen_att, 15:18:10)
    8. you can redeploy the model. No restrictions on the number of times you can deploy a model. (farheen_att, 15:18:51)
    9. if i have my own jenkins job and deploy in azure I can link it here. We want to provide but we will see if it is needed . This is a way a data admin can manage their model across many clusters and troubleshoot as needed. (farheen_att, 15:19:55)
    10. manoop - is this feature represented as model deployment from ML workbench? (farheen_att, 15:20:18)
    11. yes list of predictors that can be deployed to multiple clusters. (farheen_att, 15:20:38)
    12. Nat - this has a resource constraint. This is a huge gap and going to be an issue. (farheen_att, 15:21:21)
    13. Manoop - deploying the model. Do you have a goal for which environment? (farheen_att, 15:22:08)
    14. k8 (farheen_att, 15:22:12)
    15. Justin got it working. (farheen_att, 15:22:35)
    16. Ken - having trouble getting deployment to work. (farheen_att, 15:22:58)
    17. Justin offered to support Ken. (farheen_att, 15:23:41)
    18. Ken - Recommending a code review. (farheen_att, 15:24:03)
    19. Sayee - It needs to be scrutinized. It needs a lot of work. Sometimes demos don't work. (farheen_att, 15:24:34)
    20. Reuben - We need to start planning to support re-training. License and dist. models is I can plug my data. We need to extend this to training and evaluation. (farheen_att, 15:25:23)
    21. Sayee - I couldn't get Wenting's time. (farheen_att, 15:25:37)
    22. model builder can re-train. Reuben will talk to Wenting and Sayee about the re-training aspect. Sayee will have a separate store for data sets and training. (farheen_att, 15:26:58)
    23. Reuben wants to bring in IBM face detection. We want to be able to run it here (demo of local ML workbenchd) (farheen_att, 15:27:45)
    24. I can deploy at run time. Another is to run in one pod. (farheen_att, 15:28:15)
    25. When you deploy a model as a predictor and then evaluate the model. (farheen_att, 15:28:52)
    26. ACTION: Sayee bring one single draft. (farheen_att, 15:29:09)
    27. Reuben cautions putting a single draft alone. ML flow deals with a model registry trained with different data sets and allows selection of what should be deployed where. (farheen_att, 15:30:35)
    28. Reuben - we want to look at the logic of other projects before designing our own. (farheen_att, 15:31:29)
    29. one way of increasing the value of acumos is to make sure that we have inter-operability. IF we an make this inter-operability a requirement of all the projects, not only do we get the synergy but we also get the benefit of bringing in the expertise such as ML workflow team who understand model version management. We will get more (farheen_att, 15:32:56)
    30. https://wiki.lfai.foundation/display/DL/ML+Workflow+Committee?preview=/10518537/18481275/ML%20stack_v10.pptx (farheen_att, 15:33:21)
    31. Nat sharing the LF ecosystem. (farheen_att, 15:33:38)
    32. can we learn from these sub-projects? (farheen_att, 15:35:46)
    33. Nat - yes, i know the person who already has a deployment. They focus on sprk and python. (farheen_att, 15:36:19)
    34. Sayee - we can work with these teams and leverage already developed resources. (farheen_att, 15:36:56)
    35. Reuben - Angel is being used predominantly with Chinese companies. (farheen_att, 15:37:34)
    36. Manoop is someone at the LF level reaching out to these projects? (farheen_att, 15:37:57)
    37. Nat - I can introduce the people I know with Guy and Philippe. This is the TAG committee (LFAI). Angel has graduated. ONNX also. (farheen_att, 15:39:07)
    38. Manoop can we review with Angel? (farheen_att, 15:39:21)
    39. you clearly see the overlap over the project. Should we bring to discuss with PTLs. Rather than general meetings (farheen_att, 15:40:02)
    40. Reuben - we should know which projects are doing what. We should have an easy way to access these resources. (farheen_att, 15:40:36)
    41. Guy and Philippe have discussed deploying a model. As far as ML workbench and serving pipeline. (farheen_att, 15:41:19)
    42. ACTION: Nat introduce ml workbench with the Angel project. (farheen_att, 15:41:45)
    43. Sayee bring them to this call. (farheen_att, 15:42:05)
    44. Manoop we don't want a marketing call we want to be specific. (farheen_att, 15:42:30)
    45. how can we leverage the feature from open source. (farheen_att, 15:42:42)
    46. ACTION: Reuben will bring information about his contacts on the community meeting next Wednesday. (farheen_att, 15:50:39)

  3. Philippe - UX model deployment (farheen_att, 15:51:08)
    1. Philippe created a user story about downloading multiple artifacts. Today you have to download artifacts one at a time. ACUMOS-3679 (farheen_att, 15:52:16)
    2. There is enough time to move this user story into an epic. We would like to add docker image. Today when you download the image it takes time. (farheen_att, 15:53:57)
    3. https://wiki.acumos.org/display/MOB/Enhance+UX+when+downloading+artifacts (farheen_att, 15:54:00)
    4. should we work on it in this release or save it for the next release? (farheen_att, 15:54:51)
    5. Manoop - remove artifacts... was addressed in the past releases. Manoop will check. The requirement was addressed. Some are hidden that are internally used. Manoop will check. About selecting artifacts. What is the motivation? Downloading one zip file is easier than multiple clicks and time. Easier to select the artifacts and download (farheen_att, 15:56:52)


Meeting ended at 16:07:33 UTC (full logs).

Action items

  1. Sayee bring one single draft.
  2. Nat introduce ml workbench with the Angel project.
  3. Reuben will bring information about his contacts on the community meeting next Wednesday.


People present (lines said)

  1. farheen_att (67)
  2. collabot` (4)
  3. farheen (1)


Generated by MeetBot 0.1.4.