15:02:27 <farheen_att> #startmeeting Architecture Committee
15:02:27 <collabot`> Meeting started Wed Mar  4 15:02:27 2020 UTC.  The chair is farheen_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:27 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:27 <collabot`> The meeting name has been set to 'architecture_committee'
15:07:34 <farheen_att> #topic SoaJS demo by Antoine Hage
15:08:26 <farheen_att> SoaJS demo
15:08:42 <farheen_att> #info meeting being recorded.
15:09:38 <farheen_att> #info SoaJS is an open tool that Anton proposed.  They are interested in integrating with Acumos.  We want to start with a simple PoC in the deployment area.  We should ask questions.
15:10:17 <farheen_att> #info meeting being recorded and will be available.
15:10:38 <farheen_att> #info on wiki.acumos.org under Architecture Committee meetings
15:54:37 <farheen_att> #topic Deployment best practices
15:55:43 <farheen_att> #info Justin we are running into issues with 3rd party dependencies.  We have to go in and reconfigure.
15:57:43 <farheen_att> #info Manoop - When Python code version is the latest?  Guy - We're using something in our build process and we don't specify enough the build fails.  This can be easily fix this by saying we want this version.  For explicitly declared packages we specify an exact version.
15:58:02 <farheen_att> #info It's the generic version that we use with model runner where it's failing.
15:58:49 <farheen_att> #info Guy - it is a part of the common services.  There is a base requirements.txt and expand that.  The idea to create our own docker image is a good idea but it's difficult.  It also speeds up generation.
15:59:48 <farheen_att> #info This is serious problem.  Can we make this a priority for Common Services.
16:00:07 <farheen_att> #info Guy - yes we will include it in Demeter release.
16:00:38 <farheen_att> #topic Clios maintenance release patch - Michelle
16:02:36 <farheen_att> #info Licensing with accessing Nexxus we needed Portal federation and the license management library.  It's been done and delivered.  What is the safest way to deliver it in the Demeter release.
16:03:44 <farheen_att> #info Manoop - were they successful in packaging it on the Clio branch Rajesh.
16:04:29 <farheen_att> #info Nat - We mentioned on the PTL call.  Amol and Rajesh are having issues recreating the environment 3.28.
16:05:17 <farheen_att> #info Manoop - can we add a snap shot patch?
16:06:13 <farheen_att> #info Justin - Can you take the Demeter code base with packages for Federation.  CDS was upgraded and there will issues there.  I took two separate Docker images that are snap shots
16:06:52 <farheen_att> #info I am not sure if portal back end has taken the integration.
16:07:32 <farheen_att> #info Justin - we took the Clio branch and built federation and portal be and it worked fine.  We made sure Nexus didn't have anonymous access.  The AIO allowed annonymous access.
16:08:18 <farheen_att> #info Manoop - Rajesh why could you not move forward on the Clio maintenance release.  Snapshots that Justin provided should work.  Any concerns with anyone, testing team portal team or federation.
16:08:53 <farheen_att> #info Ken - we're going to take the existing Clio and add the updated federation and onboarding and the portal be.
16:09:28 <farheen_att> #info Manoop - We keep Clio Maint as is.  We change these two snapshots.  These fixes the patch with this issue.
16:11:26 <farheen_att> #info there should be two docker images we are interested in for this fix

docker pull nexus3.acumos.org:10003/acumos/acumos-portal-be:3.0.29-SNAPSHOT
docker pull nexus3.acumos.org:10003/acumos/federation-gateway:3.0.3-SNAPSHOT

These 2 images are not using any code changes from Demeter. The only test is to ensure Nexus connection is ok
16:11:27 <farheen_att> when publishing a model and after federation of the model.
16:21:25 <farheen_att> #action Justin - move this patch to the staging version.
16:21:58 <farheen_att> #action Ken - do IST testing on Justin's patches
16:22:30 <farheen_att> #action Vasu - update the release notes and publish once IST approves the patches.
16:23:50 <farheen_att> #action Vasu - move the staging version onto acumosr-dev
16:23:57 <farheen_att> #endmeeting