14:06:51 <farheen_att> #startmeeting Architecture Committee
14:06:51 <collabot`> Meeting started Wed Mar 25 14:06:51 2020 UTC.  The chair is farheen_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:51 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:06:51 <collabot`> The meeting name has been set to 'architecture_committee'
14:07:38 <farheen_att> #info Agenda - Offshore is on holiday.  The agenda is open today.
14:08:52 <farheen_att> #topic Michelle - Look out for emails requesting plus ones.  Alex sent a code review email and it went unwatched for a little over one week.  Please do code reviews.
14:09:26 <farheen_att> #info Michelle - Alex sent email for code review for the LUM.  No one gave a +1 or -1 for one week.
14:10:12 <farheen_att> #info The committer should be able to support.
14:10:57 <farheen_att> #info Michelle - documentation - I needed to assign to the maintenance release sprint.
14:11:28 <farheen_att> #action Murali create a sprint in jira for the Demeter maintenance release.
14:12:20 <farheen_att> #info Secure way to launch the RTU editor jira ticket.  Priya had a suggestion for Clio.
14:14:13 <farheen_att> #info Priya - who can access these features?  Super admin?  if we restrict or not expose these features as they are today the way can still expose these features using the reverse proxy.  API tokens get authenticated first from Kong.  Then to portal B.  We don't want to directly expose these to anybody.  If this can be done it will be easier.
14:14:40 <farheen_att> #info Priya - From the role based access perspective I wasn't able to discuss with Rajesh.
14:21:32 <farheen_att> #info 1.  I want authenticated access to the RTU editor and not a portal interface for that.  2.  and use Priya's reverse proxy to keep the RTU secure.
14:21:51 <farheen_att> #action Priya - add the reverse proxy solution to
14:22:05 <farheen_att> #link https://jira.acumos.org/browse/ACUMOS-4063
14:23:11 <farheen_att> #info Manoop - regarding open src integration.  We will have an open solution with a model and show an internal use case.
14:24:43 <farheen_att> #info Nat- is pursuing the lifecycle of the feature.  I need confirmation that we have a use case and I can put this use case into open source.  I want to check with the community if we have a use case to integrate Ai360 with Acumos.
14:25:23 <farheen_att> #action Manoop add Nat's request for internal use case confirmation in the Architecture backlog.
14:25:55 <farheen_att> #topic Action and Blocker in Demeter
14:26:51 <farheen_att> #info Murali - Portal team SOAJS user story was created by Manoop Acumos-3095.
14:28:24 <farheen_att> #action Murali initiate a meeting regarding acumos-3095.
14:31:15 <farheen_att> #action Ken start communication with Sanjay on how to install SOAJS.
14:31:42 <farheen_att> #info Manoop - Should we use his existing SOAJS or install our own?
14:31:56 <farheen_att> #info We should install this in the IST environment.
14:32:24 <farheen_att> #info we can get Bobbie's help to install SOAJS.
14:32:34 <farheen_att> #info How do we do the hooks for SOAJS.
14:34:32 <farheen_att> #info Manoop - we are working on that in #link https://jira.acumos.org/browse/ACUMOS-4070
14:42:23 <farheen_att> #info Ken - standing up SOAJS it still won't have access to nexus, etc. True?
14:43:07 <farheen_att> #info no it will have access just standing up is not good enough.
14:47:25 <farheen_att> #action Sayee - Address Acumos-3797Acumos-2385
14:48:14 <farheen_att> #action Wenting address Acumos-2385.
14:50:27 <farheen_att> #info Murali is waiting for TechM team to respond about taking over Acumos-3797.
14:52:35 <farheen_att> #info https://jira.acumos.org/browse/ACUMOS-3956
14:54:13 <farheen_att> #info Phillippe it is urgent to work on this 3956.  Orange will provide Python developers next week.  There is a concern about merge conflict. I can not merge my own change.
14:55:45 <farheen_att> #info This change was created one month ago.  Now we are waiting for two weeks a comment or plus 2 from Paul and we have not gotten any response from Paul.  This change blocks future work.  It is urgent to merge this change to continue.
14:58:20 <farheen_att> #action Guy work with Paul and Eric to unblock Phillippe.
15:00:05 <farheen_att> #info Murali - Anwar asked to update the architecture score card.
15:00:37 <farheen_att> #action Manoop link the score card to the Project status page.
15:01:22 <farheen_att> #info Guy on the next architecture meeting we'd like to do a brief demo of CLI onboarding using C++.  Martin and his student will demo.
15:01:45 <farheen_att> #endmeeting