14:05:11 <farheen_att> #startmeeting Architecture Committee
14:05:11 <collabot`> Meeting started Wed Apr 8 14:05:11 2020 UTC. The chair is farheen_att. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:11 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:05:11 <collabot`> The meeting name has been set to 'architecture_committee'
14:05:24 <farheen_att> #topic Agenda
14:06:58 <farheen_att> #info Installation of SOAJS and review the PTL current architecture diagram.
14:07:09 <farheen_att> #topic SOAJS
14:07:46 <farheen_att> #info AT&T team received instructions from SOAJS team to install SOAJS remotely
14:08:06 <farheen_att> #info Anotoine planning on securing resources to provide HELM charts.
14:08:49 <farheen_att> #info Antoine is waiting for resources. If he can't find resources he will inform Manoop once installed.
14:09:25 <farheen_att> #info Bobbie installed SOAJS in a development environment.
14:09:54 <farheen_att> #info is it configured with docker registries to pull the docker images? Ken: no
14:11:18 <farheen_att> #info Manoop - in the dev environment we are the users. We need to deploy and test
14:11:41 <farheen_att> #info Ken connectivity needs to connect back to nexus.
14:12:19 <farheen_att> #info Vaibhav: Is there anyone who can help us from SOAJS to help us configure.
14:12:40 <farheen_att> #info Antoine yes, I can help you and it takes about 2 minutes.
14:12:54 <farheen_att> #info Vaibhav do you have links?
14:13:47 <farheen_att> #info Antoine yes check the detailed documentation.
14:14:06 <farheen_att> #info Manoop how can he configure the docker registry.
14:15:02 <farheen_att> #info Vaibhav first we will review the documentation and then get on a call with Antoine.
14:15:21 <farheen_att> #info Manoop - What should be our overall design while making API calls to SOAJS, etc..
14:15:40 <farheen_att> #info Manoop - Once we have the right step set up we can take the decision to that step.
14:16:49 <farheen_att> #info Vaibhav - Who will be leading this? I went through the documentation to start a daemon you need a profile. Do we need a pre-defined profile for deploying the model. How should we be changing the profile. That kind of documentation I am looking for.
14:17:41 <farheen_att> #info Vaibhave What packages should we be using. It comes out with a lot of things. What things have to be used.
14:18:58 <farheen_att> #info Manoop - I will be coordinating your questions from the architecture perspective. How it will be used in details have to be taken to Antoine.
14:19:16 <farheen_att> #info Manoop we will discuss these questions before taking them to Antoine and team.
14:20:01 <farheen_att> #action Vaibhav provide questions to Manoop for architecture and detailed questions to Antoine.
14:20:19 <farheen_att> #info Ken - it doesn't have to be K8.
14:21:46 <farheen_att> #action Ken provide Manoop with the details for SOAJS resources.
14:22:10 <farheen_att> #info Manoop - We need two development teams.
14:23:00 <farheen_att> #info Priya - we have to have deployments in the same environment as kubernetes. Second dev vm has deployed jenkins. If we can use that server it will help.
14:23:22 <farheen_att> #info Ken - Jenkins is running on the core vm.
14:23:47 <farheen_att> #info Priya - there is one on the dev server. There is another one that Santosh uses for the k8 environment.
14:24:34 <farheen_att> #info Ken we don't want the deploy to an environment in it's own namespace. I guess you need another namespace.
14:25:09 <farheen_att> #info Antoine SOAJS needs its own namespace then you start to create your own environments with their own namespaces. It doesn't put you into a cluster.
14:25:41 <farheen_att> #info Antoine - If you want to create in the same cluster another cluster or deploy to cloud.
14:26:47 <farheen_att> #topic Architecture diagram review
14:28:31 <farheen_att> #info Onboarding Guy Phillippe
14:32:21 <farheen_att> #info Guy - We added Jenkins to the onboarding microservices.
14:32:58 <farheen_att> #info Security verification also calls jenkins
14:33:40 <farheen_att> #info Manoop we want to use the same deployment client. It would be simpler to switch the api calls to soajs api calls.
14:34:01 <farheen_att> #info Priya should we stop working on the defect about jenkins deployment to kubernetes?
14:34:10 <farheen_att> #info Manoop yes that is right.
14:35:26 <farheen_att> #info Phillippe - Onboarding add the C++ client under tools.
14:35:48 <farheen_att> #info onboarding add the c++/pythong client under tools.
14:37:09 <farheen_att> #action Michelle work with Manoop to update the architecture diagram.
14:51:52 <farheen_att> #endmeeting